Network Management

 View Only
last person joined: 6 hours ago 

Keep an informative eye on your network with IMC and AirWave network management solutions.
Expand all | Collapse all

Unable to communicate Cisco and HP switch via glass fiber

This thread has been viewed 10 times
  • 1.  Unable to communicate Cisco and HP switch via glass fiber

    Posted Aug 16, 2022 01:44 PM
    Hello Everyone,

    I am still new with HP procurve switches.

    I am trying to connect Cisco Stacked switch to single HP switch. Connection will be Cisco 1/1/1 will connect to HP procurve switch on port no 25 via glass fiber.

    unable to see any lights coming out from 1/1/1 also tried different SFP module but no luck. Any suggestions will be great help.

    Here is the config

    interface GigabitEthernet1/1/1
    description HP407:port 25
    switchport trunk native vlan 70
    switchport trunk allowed vlan 16,50,70,310,314,317,318,345,413,668,684,693,694
    switchport trunk allowed vlan add 708,834,837,971-976,979,1163-1170
    switchport mode trunk
    ip device tracking maximum 65535
    load-interval 30
    channel-group 22 mode active
    spanning-tree portfast disable
    spanning-tree bpduguard disable
    spanning-tree link-type point-to-point

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    config t

    hostname INV-TSI-407

    spanning-tree

    vlan 1

    name "DEFAULT_VLAN"

    no untagged 1-28

    no ip address

     

    vlan 70

    name "10.74.70.182" (type in)

    ip address 10.74.70.182 255.255.254.0

    untagged 1-3,5-11,13-14,25-28

    write mem

    exit

    ip default-gateway 10.74.70.1

    ip route 0.0.0.0 0.0.0.0 10.74.70.1     copy line separately

    write mem                         

                                                                                                                                                                   

    !

    VLAN 16

    name "VLAN 16" (type in)

    untagged 4

    tagged 25-28

     

    !

    VLAN 979

    name "VLAN 979" (type in)

    untagged 12

    tagged 25-28

    !

    VLAN 50

    name "VLAN 50" (type in)

    tagged 7,25-28

    !

    VLAN 305

    name "VLAN 305" (type in)

    tagged 8,25-28

    !

     

    VLAN 310

    name "VLAN 310" (type in)

    tagged 7,25-28

    !

    VLAN 314

    name "VLAN 310" (type in)

    tagged 7,8,9,13,14,25-28

    !

    VLAN 317

    name "VLAN 317" (type in)

    tagged 7,8,9,13,14,25-28

    !

    VLAN 318

    name "VLAN 318" (type in)

    tagged 11,25-28

    !

    VLAN 345

    name "VLAN 345" (type in)

    tagged 2,3,8,13,14,25-28

    !

    VLAN 413

    name "VLAN 413" (type in)

    tagged 6,25-28

    !

    VLAN 668

    name "VLAN 668" (type in)

    tagged 6,25-28

     

    !

    VLAN 684

    name "VLAN 684" (type in)

    tagged 1,25-28

    !

    VLAN 693

    name "VLAN 693" (type in)

    tagged 7,25-28

    !

    VLAN 694

    name "VLAN 694" (type in)

    tagged 7,25-28

    !

    VLAN 708

    name "VLAN 708" (type in)

    tagged 7,10,25-28

    !

    VLAN 834

    name "VLAN 834" (type in)

    tagged 7,25-28

    !

    VLAN 837

    name "VLAN 837" (type in)

    tagged 7,25-28

     

    !

    VLAN 971

    name "VLAN 971" (type in)

    tagged 7,25-28

    !

    VLAN 972

    name "VLAN 972" (type in)

    tagged 7,25-28

    !

    VLAN 973

    name "VLAN 973" (type in)

    tagged 7,25-28

    !

    VLAN 974

    name "VLAN 974" (type in)

    tagged 7,25-28

    !

    VLAN 975

    name "VLAN 975" (type in)

    tagged 7,25-28

    !

    VLAN 976

    name "VLAN 976" (type in)

    tagged 7,25-28

    !

    VLAN 1163

    name "VLAN 1163" (type in)

    tagged 6,25-28

    !                                             

    VLAN 1164

    name "VLAN 1164" (type in)

    tagged 6,25-28                                  

    !

    VLAN 1165

    name "VLAN 1165" (type in)

    tagged 6,25-28                  

    !

    VLAN 1166

    name "VLAN 1166" (type in)

    tagged 6,25-28                                  

    !

    VLAN 1167

    name "VLAN 1167" (type in)

    tagged 6,25-28                  

    !

    VLAN 1168

    name "VLAN 1168" (type in)

    tagged 6,25-28                                  

    !

    VLAN 1169

    name "VLAN 1169" (type in)

    tagged 6,25-28                  

    !

    VLAN 1170

    name "VLAN 1170" (type in)

    tagged 6,25-28

    wri mem

     

    spanning-tree mode rapid-pvst  (need to do this line separate and answer Y/N question – Y for yes)

    spanning-tree vlan 1,70,16,979,50,310,314,317,318,345,413,668,684,693,694,708,834,837,971-976,1163-1170 disable

    spanning-tree force-version rstp-operation

    no tftp server

    fastboot

    loop-protect 1-24

    loop-protect mode vlan

    loop-protect vlan 16,979,50,310,314,317,318,345,413,668,684,693,694,708,834,837,971-976,1163-1170

    exit

    config t

    no autorun   (might not take)

    no dhcp config-file-update

    no dhcp image-file-update

    no dhcp tr69-acs-url

    device-profile name "default-ap-profile" (might not take)



  • 2.  RE: Unable to communicate Cisco and HP switch via glass fiber

    Posted Aug 17, 2022 03:54 AM

    I'm not sure, but could you please give some additional information for both sides (cisco and hp/aruba)?

    show interface status
    show interface brief
    show interface port-channel
    show interface transceiver
    show lacp
    show trunks
    show port-channel
    show portchannel
    show etherchannel
    show ether-channel
    show spanning-tree

    Not every command is available on any switch. Please use the "?" or tabulator-key for any command help.
    Please insert the commands output by code button, or as a txt attachment for the cisco and the hp/aruba device.


    I do not see any port config for the hp/aruba switch. So not sure if enabled or not or how it is configured. But 'cause of the vlan config there should be a lot of tagged vlan (so a trunk interface).

    BUT:
    What I can see so far is that the cisco interface seems to be configured for ether-channel ("channel-group 22 mode active"). If thats the case all the config (like vlan and spanning tree) has to be done under the appropriate port-channel interface.
    The hp/aruba seems to miss the matching ether-channel configuration. It could be like this:

    conf t
    !
    trunk 25 trk<number> lacp
    !
    interface trk<number>
     enable
    !
    interface 25
     lacp active
    !
    vlan <vlan-id>
     tagged trk<number>
    ! or
    interface trk<number>
     tagged vlan <vlan-id>
    !