802.11 Client Device Interoperability

Frequent Contributor II

Connectivity issues with REALTEK RTL8192se

I am having problems getting a bunch of Lenovo ThinkPads to connect.

The issue is that the connect and immediately disconnect when the HT radio is enabled in my radio-g profile. Turning the HT radio off allows the Lenovo units to connect without problem.

The Thinkpad model is X100e which used a REALTEK RTL8192SE Mini PCI b/g/n adaptor. Driver version is the latest 1092.0.628.2010. for WinXP SP3.

I am having the problem on AP125s and AP105s.
My Controller OS version is

The WLAN is authenticated using PEAP/MSChapv2 and I think this has something to do with the connectivity problem as the Lenovos are able to connect to my Guest WLAN (Captive Portal) on the same APs.

Anyone solved a similar problem? :confused:
Guru Elite

Please open a case

Please Open a case, so this can get looked at.

*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.5 User Guide
InstantOS 8.5 User Guide
Airheads Knowledgebase
Airheads Video Knowledge Base
Remote Access Point Solution Guide
ArubaOS Consolidated Release Notes
ArubaOS 8 ViA VPN Solution Guide
Frequent Contributor II

Re: Connectivity issues with REALTEK RTL8192se

Update. (for those who might be interested)

I opened a case with Aruba as colin suggested. The suggestion was made that I allow weak encryption on my SSID. This had no effect. The supplicants still connect and authenticate Ok and then immediately dissconnect. WinXP pops up a baloon just before disconnection saying "Connected to THE_WLAN(Unsecured)".

With further testing I have been able to determine that the issue is related to the use of AES encryption on the HT radio on the g side.

If I switch from WPA2/AES to WPA2/TKIP the supplicant connects and remains connected. Likewise, if I turn HT support off on the g radio, the client connects and remains connected using WPA2/AES

I duplicated my WLAN onto a non aruba access point. Same SSID, WPA2/AES, RADIUS Server etc. and the Lenovo supplicant connects without a problem.

The weird thing is that I have plenty of supplicants connecting to the HT-g radio. Its just these 180 or so Lenovos that are giving me grief.
I am currently awaiting further instructions from Aruba Support but if anyone else has suggestions, I would welcome them.
Contributor II

Re: Connectivity issues with REALTEK RTL8192se

We seem to have the same problem with the same chip, browsed the specs of the chip adn tried to change MCS from 0-15 to 0-6 with no luck (some laptops connect and remain connected, anothers connect after some tries). Looking on the linux side of the driver the problem seems to come from the driver scanning the air while it negotaties the crypto.

For reference my case is W-13914
Aruba OS 5.0.1
Frequent Contributor I

Re: Connectivity issues with REALTEK RTL8192se

Coincidentally, we're also facing issues with Realtek chipsets on Compaq CQ42 laptops as well.
I just updated the drivers and did the "Station Handoff Assist" on Aruba as well....

Connectivity (ping test) is okie.
However, roaming is still a challenge, as the Clients are still very sticky and dun roam as fast as we expected...

Contributor II

Re: Connectivity issues with REALTEK RTL8192se

if it's interesting for any one I will post my radio profile that seems to get the things a bit better, but not as good as we expected.


Please post the profile(s)

Sure, please post the profiles you are utilizing.
Frequent Contributor II

Status Update

Aruba Support tells me that they have escalated this to the engineers as a bug. Nothing I can do now but wait. For the moment I have turned off HT on the g radios; most of my HT clients are on the 5.8Ghz band anyway.

As soon as I have any feedback other than "we're working on it" from Aruba Support I will post it here.

Search Airheads
Showing results for 
Search instead for 
Did you mean: