ArubaOS and Controllers

This community is currently in a read-only state due to a maintenance window. For more info click here
Occasional Contributor I

Admin Password Flaw with upgrade

Hi Everyone,
I recently upgraded one of our Aruba Switch Controllers from 2.5.3 to
My first step was to upgrade the software version from 2.5.3 to and then apply the to the same partition.
When I first upgraded to version everything was working fine since I were able to login without any problem.
When upgraded from to version something very interesting happened since I was not able to login with my current admin username and password. I tried every possible way including the default Aruba username and password (admin, admin). Since I was doing the upgrade remotely I had to go personally to the site and physically reset the password with the serial console. However the configuration was intact.
So why this situation could happen?
My tests showed me that for some reason does not like certain combinations of passwords. In my case I utilize a password combination with lower case letters, capital letters and numbers.
After the password recovery I tried several times to change the password to my old one without any luck. It seems that this version simply does not like it. Finally I had to change my current password for one that does not use any capital letters.
For those who are planning to do the upgrade remotely my advice is to add another admin (root) user with a simpler password or change the current one. These are the things that you do not expect to happen and can affects your plans accordingly.
Search Airheads
Showing results for 
Search instead for 
Did you mean: