ArubaOS and Controllers

Occasional Contributor I

Aruba OS Multicast issues

I have recently upgraded to ver and have noticed some multicasting issues for my Vocera badges. I am running a Layer 2 solution on the Aruba controllers(I.E all of my Layer 3 routing occurs on another device and are routed to it via L2 trunks) The broadcast function for the Vocera badges have stopped altogether which uses mutlicast to deliver the data. It appears that no multicast joins are going through to my router, I ran a debug on mpackets while running a Vocera broadcast and it shows nothing. I also look at the mrouter lists on the router and there is no (*.G) group created on the router and no outgoing interface list create for the groups. I do however see the clients joining the multicast group on the controller when I run the broadcast function. I also tried creating a Layer3 interface for testing on the Aruba controller and the mutlicasting works fine when using the layer 3 interface on the controller. While it does work with an L3 interface on the controller it's really not a viable solution in this case. I am curious if anyone else has experienced this problem and whether or not they have found a fix for it. I do have a case with Aruba and Vocera but so far no resolve just yet. If anyone has any insight into this issue I would greatly appreciate it.
Super Contributor I

Re: Aruba OS Multicast issues

I have seen something similar, and yes, I found that without a l3 vlan interface on the controller with an IP address, multicast did not work properly. It's unpleasant in that the controller cannot perform like your typical L2 switch with multicast. Adding an address is not scalable since you then need to ensure that each added IP address is protected from unauthorized ssh/http(s) access to the controller (since Aruba hasn't implemented service ACLs).

Let me know if you find out anything on this front, as I'll likely benefit from the information. Thanks!
Ryan Holland, ACDX #1 ACMX #1
The Ohio State University
Aruba Employee

Re: Aruba OS Multicast issues

I'm also running, but can't say I've seen any abnormalities with multicast.

Are you using igmp snooping or igmp proxy on the controller?
New Contributor

Re: Aruba OS Multicast issues

Which version of code were you running where the multicast traffic was passing successfully? You may want to have support confirm if there were default configuration changes made between your previous code rev and current. Additionally check your config for a broadcast-filter all and/or broadcast-filter arp and try no'ing them out on your SSID if found (again, bounce these off support to make sure my advice isn't conflicting).
Occasional Contributor I


After working with Aruba it was determined that in order for multicast to work properly in Ver. that as the first person to reply suggest a L3 vlan inteface need to be created for each of the vlans that I wanted multicast to work with. I was told that this is due to extra functionality that was in to support multicast. from previous versions. I have made the adjustments and things a re looking good now. As far as the person who asked about which previous version was working with the config, it was Ver. which was working without issues for the multicast.
Search Airheads
Showing results for 
Search instead for 
Did you mean: