ArubaOS and Controllers

Upcoming community maintenance Oct. 27th through Oct. 29th
For more info click here
Reply
Highlighted
Regular Contributor I

Duplicate Captive Portal Logins

I'm setting up a public SSID for the first time using Captive Portal and the internal database for authentication. I have no idea how this happened, but now I'm getting prompted for two different Captive Portal login screens. After I authenticate through the first, a new Captive Portal page is displayed, with the default Aruba background. Any ideas?
Network Engineer | Airhead | Titus 3:5
Highlighted
Aruba

Duplicate Captive Portal Logins

To debug this, you should

1) pass the first captive portal
2) stop there, and observe the 'role' that your user is in AFTER the first captive portal.... is it 'guest' ? is it 'guest login' is it something custom ?
3) check the Firewall policies on the controller for that role, specifically analyze if 'captive-portal' is a firewall policy in this role.


Sounds like the authenticated role you are in after the first public captive portal still have a captive portal redirect for http/https, instead of just a permit rule set.
Highlighted
Regular Contributor I

Re: Duplicate Captive Portal Logins

Sorry for the delay...I've been out of town for the 4th. I checked the user role and it was using a role called guest_logon. I changed it to the appropriate role and that appears to have fixed it. I appreciate your help!
Network Engineer | Airhead | Titus 3:5
Highlighted
Aruba

Duplicate Captive Portal Logins

Anytime.

Glad it worked out.