ArubaOS and Controllers

Reply
Highlighted
Aruba

It's after the input that he gets errors

The way I read the post it's __after__ the pasted in lines that he gets the errors. I didn't read it that it ___is___ these pasted lines that give the errors. Thus debugging the included lines isn't going to tell the tale.

Either way, easy to figure out if he posts the output snippet I asked for a few msgs back.
Highlighted
Regular Contributor I

Re: load configuration from another controller


Does the second controller (aka the new controller) have all licenses loaded that the first one does ?

Are you in 'config t' mode before pasting?

What are the errors (maybe post the first 5 lines once you verify the two items above)

Tks




Basically the Net Tech will setup the Controller so that it will be ready for installation at the school with just the IP, VLANs and Ports configured.

To speed up the process, I was hoping that after they follow the console wizard, that they could paste the modified config to it and be done with it.

Once the NetTech installs the controller at the school, I will go back and install the licenses and let the Master Controller do the rest.

Yes, I'm in Config Term mode before pasting.

Thanks for your help!
Highlighted
Regular Contributor I

Re: load configuration from another controller


Certain config lines like "controller config 0" is used internally and not accepted on the CLI. It's normal to get errors for these.

The other two commands should not require any license to execute. You need to be in config mode though.. Try typing it manually in the CLI and see if you still get an error.




Yes, I've been typing the config in manually too and most of the lines in the config throw this error.

Thanks!
Highlighted
Aruba

Please paste a few lines of the console output here

Please paste in a few lines of the console output when you type in the commands to this thread.

That would be helpful to see the interaction of the CLI with the commands.

I am thinking 3-5 commands would be helpful to see pasted in and the resulting errors.

Thx
Highlighted
Regular Contributor I

Re: load configuration from another controller

Here you go, thanks for the help!

User: ADMIN admin

Password: ***********

User: A admin

Password: ***********

(ControllerName) >ENAB ABLE

Password:***********

(ControllerName) #CONFIG configure terminal

Enter Configuration commands, one per line. End with CNTL/Z


(ControllerName) (config) #

(ControllerName) (config) #enable secret "random letters and numbers"

^

% Invalid input detected at '^' marker.



(ControllerName) (config) #

(ControllerName) (config) #hostname "ControllerName"

(ControllerName) (config) #

(ControllerName) (config) #clock timezone EDST -5

(ControllerName) (config) #

(ControllerName) (config) #masterip x.x.x.x ipsec random letters and number

This configuration change requires a reboot.

PLEASE SAVE THE CONFIGURATION AND REBOOT.



(ControllerName) (config) #

(ControllerName) (config) #location "Contoller.MDF.1"

(ControllerName) (config) #

(ControllerName) (config) #mms config 0

^

% Invalid input detected at '^' marker.



(ControllerName) (config) #

(ControllerName) (config) #controller config 0

^

% Invalid input detected at '^' marker.



(ControllerName) (config) #

(ControllerName) (config) #

(ControllerName) (config) #

(ControllerName) (config) #ip access-list eth validuserethacl

^

% Invalid input detected at '^' marker.



(ControllerName) (config) #

(ControllerName) (config) # permit any

^

% Invalid input detected at '^' marker.



(ControllerName) (config) #

(ControllerName) (config) #!

(ControllerName) (config) #

(ControllerName) (config) #netservice svc-snmp-trap udp 162

^

% Invalid input detected at '^' marker.



(ControllerName) (config) #

(ControllerName) (config) #netservice svc-syslog udp 514

^

% Invalid input detected at '^' marker.



(ControllerName) (config) #

(ControllerName) (config) #netservice svc-l2tp udp 1701

^

% Invalid input detected at '^' marker.



(ControllerName) (config) #

(ControllerName) (config) #netservice svc-ike udp 500

^

% Invalid input detected at '^' marker.



(ControllerName) (config) #

(ControllerName) (config) #netservice svc-smb-tcp tcp 445

^

% Invalid input detected at '^' marker.
Highlighted
Aruba Employee

Re: load configuration from another controller

Looks like this controller doesnt have a PEF (pre-5.x) or PEF-NG (post 5.x) license. Check the command "show license verbose" and make sure you have PEF or PEF-NG.
Highlighted
Aruba

Your Controller is in Local Mode

Ok, thanks for the configuration snippet.

Based on that I see that the controller has asked you to reboot as you have put it into local mode.

In local mode, the controller expects to get a large proportion of it's configuration from it's master controller.

Local controllers only need to be programmed with locally significant information such as VLANs, VLAN IPs, Captive Portal Page, internalDB entries ... not with Firewall policies etc. They inherent those latter parameters from the Master automagically.
Highlighted
Regular Contributor I

Re: load configuration from another controller

Great, I was hoping you would say that. I've cut out all the line that had errors and now the script works! :)

My only question left is concerning the Admin/Enable password, can that be configured with this script already encrypted?

For example, the line

enable secret "random letters and numbers"
^
% Invalid input detected at '^' marker.

has the random letters and number, which I assume to already be encrypted; is there a way to make that line work with the cut and paste proceedure I'm working up?

Thanks again.
Highlighted
Aruba Employee

Re: load configuration from another controller

No. The enable secret is loaded in "script" mode when the configuration is read on bootup. In CLI's "interactive" mode it drops you to a prompt to manually type in the password and reconfirm it. It can't be copy/pasted.
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: