Cloud Managed Networks

Reply
Highlighted
New Contributor

Aruba Central template error ["Device <serialnumber>: resulted in empty desired config"]

 

Hi,
I've configured a template group to prestage a switch config ready to deploy , and have moved a switch which was previously deployed as part of a UI group to it, but dont have access to the switch to test (or turn on etc.) and am recieving an error ["Device <serialnumber>: resulted in empty desired config"] and not quite sure what it means but beleive it indicates that it wont apply anything.. I've replicated the config as best I can but cant find the cause for the error:

%_sys_template_header%

%_sys_module_command%

hostname "<switch_hostname>"

include-credentials

no cwmp enable

snmpv3 engineid "%_sys_snmpv3_engineid%

ip routing

ip route 0.0.0.0 0.0.0.0 158.xxx.xxx.41 1

ip dns server-address priority 1 8.8.8.8

timesync ntp

no sntp

ntp unicast

ntp server 158.xxx.x.137 iburst

ntp enable

ip routing

ip route 0.0.0.0 0.0.0.0 158.xxx.xxx.41 1

ip dns server-address priority 1 8.8.8.8

timesync ntp

no sntp

ntp unicast

ntp server 158.xxx.xx.137 iburst

ntp enable

vlan 1

name "Default_VLAN"

untagged 4-10

ip address 159.xx.xx.1 255.255.255.128

exit

vlan 357

name "Wireless-Corp"

tagged 3

ip address 159.**.**.129 255.255.255.128

ip helper-address 159.**.**.14

exit

vlan 352

name "Wireless-Guest"

tagged 3

exit

vlan 875

name "Wireless-Management"

untagged 3

ip address 10.70.**.139 255.255.255.128

ip helper-address 159.**.**.14

exit

vlan 901

name "Wired-Management"

ip address 10.70.**.1 255.255.255.128

exit

vlan 3190

name "transit"

ip address 158.***.***.41 255.255.255.252

untagged 1

tagged 1

exit

device-profile name "default-ap-profile"

tagged-vlan 350-351

untagged-vlan 870

exit

device-profile type "aruba-ap"

enable

exit

mac-delimiter colon

spanning-tree


anyone have any ideas what causes this, input would be much appreciated. KInd regards,

 

template-error .PNG

 

New Contributor

Re: Aruba Central template error ["Device <serialnumber>: resulted in empty desired confi

tried re-arranging the variable values at the top which I thought had worked but still get the error, if I remove all variables then the error goes away and I receive a deployment related error as its not online at the moment so I guess the question is, are the variables still required and if so what are they, or more importantly what is breaking it?? Many thanks in advance.

Aruba Employee

Re: Aruba Central template error ["Device <serialnumber>: resulted in empty desired confi

Hi ChrisDewe,

 

Can you please check if you have a list of variables for that switch. Without this list, central cannot build the config. Here is an example:

Central Variables.png

 

BR

Florian


visit our Youtube Channel:
https://www.youtube.com/channel/UCFJCnuXFGfEbwEzfcgU_ERQ/featured
Please visit my personal blog as well:
https://www.flomain.de
New Contributor

Re: Aruba Central template error ["Device <serialnumber>: resulted in empty desired confi

 

Hi Florian,

Thanks for your speedy response. I have a variables file which contains the mac, serial and hostname along with the modified field set to Y and the variables are showing up on the variables tab. If I remove all variables placemarkers from the template then it doesnt show a template error but rather a config sync issue as the switch is currently offline (being installed by a 3rd party later on) which I have read may be a false positive. Unfortunately I cant test properly yet just wanted to resolve the error mentioned in the title. Here is a snip of the names, am I missing any mandatory ones?? are they still mandatory? seems to want to work without.

Many thanks and kind regards,

Chris
variables.PNG
 

Aruba Employee

Re: Aruba Central template error ["Device <serialnumber>: resulted in empty desired confi

There are still missing variables:

 

%_sys_template_header%

%_sys_module_command%

%_sys_snmpv3_engineid%

 

But they should get populated automatically by central, once the switch gets online. This should resolve the issue you have. 


visit our Youtube Channel:
https://www.youtube.com/channel/UCFJCnuXFGfEbwEzfcgU_ERQ/featured
Please visit my personal blog as well:
https://www.flomain.de
New Contributor

Re: Aruba Central template error ["Device <serialnumber>: resulted in empty desired confi

Hi, thanks again.

Do you mean that I need those variables in the variable file despite not populating it with a value, and in the template as I have already?

 

I understand that they were mandatory fields in the template but just thought they would automatically be populated without entries in the variables file, is this not the case?

 

KInd regards,

Chris

Aruba Employee

Re: Aruba Central template error ["Device <serialnumber>: resulted in empty desired confi

If you know the value of those variables you can pre-populate them and I would recommend doing so. If you do not know the values just leave those variables empty. 


visit our Youtube Channel:
https://www.youtube.com/channel/UCFJCnuXFGfEbwEzfcgU_ERQ/featured
Please visit my personal blog as well:
https://www.flomain.de
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: