Error "Could not determine version number of config file" while applying new boot file

Aruba Employee
Aruba Employee

Environment Information : Product and Software: This article applies to all Aruba Controller and Software:


We can upload a new default.cfg file on controller under it's "dir" (directory) however if we like to boot the controller using that file it might show you below message.

(Aruba) #boot config-file <filename>
Could not determine version number of config file.

Error determing current configuration file version.


Symptoms : Below error message seen if you have space before version.


As below we can see there is a empty space before version start under *.cfg file.



Cause : By default if we download a default.cfg file from controller or extract from flashbackup.tar.gz it doesn't have any space at top however if we modify before uploading the file there maybe chances of have space before text starts and controller cannot determine the *.cfg code version and show the error message.


Resolution : Remove the space and upload the file again and it should work.

Version history
Revision #:
1 of 1
Last update:
‎07-15-2014 12:00 AM
Updated by:
Labels (1)

I remove the spaces from the top of the file and i still get the same error. Please help.

Search Airheads
Showing results for 
Search instead for 
Did you mean: