Why are clients unable to get ipv6 address even though we have enabled DHCPv6 on the Controller?

Aruba Employee
Aruba Employee

Environment : Aruba OS 6.3.x and above
Aruba Controllers 3xxx, 6xx, M3 and 72xx.

Symptoms : Clients are not getting an IPv6 address although the DHCPv6 scope is created and DHCP is enabled on the Controller.


Cause : Issue can occur if IPv6 processing is not globally enabled on the Controller and/or if the VLAN is not trusted.


Solution : Enabled IPv6 globally on the Controller and/or make the VLAN trusted on the uplink port of Controller as it applies.


This issue is seen if we miss out on enabling IPv6 processing globally on the Controller.  Even though the DHCPv6 scope is created and the VLAN interface is configured with an ipv6 client, we may see clients not getting an ipv6 address.  


show ipv6 global 
Global IPv6 Packet Processing is Disabled<<<<<<<<<<<<<<<<<<<<

 (Aruba) #show ipv6 user-table

    IP           MAC       Name   Role  Age(d:h:m)  Auth  VPN link  AP name  Roaming  Essid/Bssid/Phy  Profile  Forw                                                    ard mode  Type  Host Name
----------  ------------  ------  ----  ----------  ----  --------  -------  -------  ---------------  -------  ----     --------  ----  ---------
User Entries: 0/0
(Aruba) #show ipv6 route
Codes: C - connected, O - OSPF, R - RIP, S - static
       M - mgmt, U - route usable, * - candidate default
C    2001:470:faca:4::/64 is directly connected, VLAN200
(Aruba) #show ipv6 dhcp binding
(Aruba) #show ipv6 dhcp database
DHCPv6 enabled
# DHCPv6
subnet6 2001:470:faca:4::/120 {
        default-lease-time 1036800;
        max-lease-time 1036800;
        option dhcp6.domain-search "test.org";
        option vendor-class-identifier  "ArubaAP";
        option dhcp6.vendor-opts  "2001:470:faca:4::1";
        option dhcp6.name-servers 2001:470:faca:4::2;
        option dhcp6.preference 25;
        range6 2001:470:faca:4::3 2001:470:faca:4::fe;
(Aruba) (config) #show ip dhcp statistics
DHCPv4 disabled; DHCPv6 enabled
DHCP Pools
Network Name  Type  Active  Configured leases  Active leases  Free leases  Expired leases  Abandoned leases
------------  ----  ------  -----------------  -------------  -----------  --------------  ----------------
DHCPv6        v6    Yes     252                0              252          -               -
Current leases          252
Total leases            256
NOTE: To make a DHCPv6 pool active, ensure that the pool name is added in vlan interface
(Aruba) (config) #
(Aruba) (config) #show ipv6 interface brief
Interface                   [Status/Protocol]
vlan 1                      [  up/up  ]
vlan 100                    [  up/down]
vlan 101                    [  up/down]
vlan 200                    [  up/up  ]
loopback                    [  up/up  ]
mgmt                        [down/down]

To enable ipv6 processing globally:
(Aruba)# config term

(Aruba) (config) # ipv6 enable
(Aruba) (config) # write mem

(Aruba) #show ipv6 global
Global IPv6 Packet Processing is Enabled
(Aruba) #show ipv6 dhcp bind
# Client: fe80::88d9:6823:cfb0:71fd; IA ID 0xe00219b
ia-na "\016\000!\233\000\001\000\001\030\372\023*\000!\233\336\332\263" {
  cltt epoch 1380207061; # Thu Sep 26 11:50:01 2013
  iaaddr 2001:470:faca:4::fe {
    binding state active;
    preferred-life 648000;
    max-life 1036800;
    ends epoch 1381243861; # Tue Oct 08 11:50:01 2013
(Aruba) #show ipv6 dhcp statistics
DHCPv4 enabled; DHCPv6 enabled
DHCP Pools
Network Name  Type  Active  Configured leases  Active leases  Free leases  Expired leases  Abandoned leases
------------  ----  ------  -----------------  -------------  -----------  --------------  ----------------
DHCPv6        v6    Yes     222                1              221          -               -
Current leases          222

Total leases            512

Another instance when we could see clients not getting an ipv6 address in spite of configuring DHCPv6 correctly and enabling ipv6 globally is when the VLAN is not trusted on the Controller uplink port.  This must be verified from the running configuration (show run):

interface gigabitethernet  1/0
description "Aruba-uplink"
no trusted vlan 1-4094
switchport mode trunk
switchport trunk allowed vlan 1-4094

To resolve the issue, we need to make the client VLAN trusted on the Controller uplink port.
(Aruba)# config term
(Aruba) (config)# interface gigabitethernet 1/0
(Aruba) (config)# trusted vlan 1-4094
(Aruba) (config)# write mem

Version history
Revision #:
1 of 1
Last update:
‎07-11-2014 10:57 AM
Updated by:
Labels (1)
Search Airheads
Showing results for 
Search instead for 
Did you mean: