Controllerless Networks

New Contributor

Aruba Central Template Configuration Issues



I am trying to push configurations to Aruba switches using a variablised template and also a JSON configuration file.


I kept having issues with device configuration with the error message "Config push status: Failed, template is corrupted". So I thought I'd strip it right back section by section to find the problem area.


I found nothing. So now I have created a brand new template as follows:


hostname "%_sys_hostname%"


I have a brand new variables file as follows:


"switchserial": {
"modified": "y",
"_sys_hostname": "hostnameishere",
"_sys_lan_mac": "mac:is:here",
"_sys_serial": "switchserialhere"


I still get the exact same error. I had figured that if I don't specify anything but a hostname it should only configure a hostname and all other config would just be default out of the box configuration on the device.


Is there any way we can enable more verbose logging/auditing to find the actual location of the error?

Frequent Contributor I

Re: Aruba Central Template Configuration Issues

can you try and put this on the top?



New Contributor

Re: Aruba Central Template Configuration Issues



Thanks for that. Turns out what the issue was the entire time - is we were running some configuration in the template to change the default VLAN.


management-vlan xxx

vlan xxx

untagged 1-28


When doing this - you also need to do the following:


vlan 1

no untagged 1-28


Basically the way the template tool works - is any configuration you move which results in the switch negating config elsewhere, you need to do the same in your template file. In our case because moving the untagged ports to a different vlan other than the default we needed to negate the untagged command on vlan 1.


The documentation does seem very vague on templating - would be good to see a more in depth guide to templating.

Search Airheads
Showing results for 
Search instead for 
Did you mean: