Controllerless Networks

Occasional Contributor II

Aruba IAP mixed cluster upgrade - fail


We have just tried to upgrade a networks of mixed cluster IAP's to the latest version. As the customer has a mixed cluster of IAP we used TFTP.

All of the IAP-115's upgraded but the IAP-105's didn't upgrade and went missing from the VC. We tried to SSH onto the slave 105's to try to make them upgrade but they wouldn't. I used the command below

upgrade-image tftp://

After issuing the command I watched the TFTP server but the IAP-105 didn't try to upgrade.

In the end we had to remove every IAP-105 (10) from the network and put them on an isolated staging network away from the existing cluster and then upgrade them manually to the same level as firmware as the IAP-115's. When they were connected back the orignal network they rejoined the cluster and worked.

Becasue of the location of the IAP-105 this process took hours. 

If there an easier way of upgrading the formware slave IAP's if they fail to upgrade?


Guru Elite

Re: Aruba IAP mixed cluster upgrade - fail

The upgrade should have a GUI that will accept TFTP URLs for the different platforms.  Is that what you attempted?

*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.4 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Aruba Central Documentation
Sign up for Security Alerts
Aruba Technical Webinars
Occasional Contributor II

Re: Aruba IAP mixed cluster upgrade - fail

Hi Colin,

Yes this is what attempted, we used different addresses for each class of AP as below


upgrade-image tftp://


upgrade-image tftp://

The IAP-115's upgraded OK but the IAP-105 didn't upgrade. The 115's upgraded, rebooted and the IAP-105's were left out of the cluster becuse of the firmware mismatch so we had to take them all down and upgrade them manually on a seperate network. We tried indiviually connecting to the IAP105's using CLI / SSH to see if they would download the new firmware using TFTP but they wouldn't.


The question is in a mixed class enviroment if a mixed class firmware upgrade fails and some IAP's are left out in the cold becuase of of a firmware mismatch how can we get them upgraded without having to remove them from the network? 


If you CLI to a slave will it upgrade it's firmware using TFTP?


Search Airheads
Showing results for 
Search instead for 
Did you mean: