Controllerless Networks

Reply
Highlighted
Occasional Contributor II

ArubaOS 8.5 on IAP-305 - AP stuck after applying firmware..

So I picked up one of my IAP-305's running 6.5.x and whacked 8.5 just to see what the new OS is like.. Now the unit will not boot properly but can't tell where it is stuck because I don't have a console cable with me!

 

I can see a blinking green LED which sometimes stays on solid for a few seconds. Every now and then there is a solid red for about 2 seconds and it goes to blinking green again - been like that for about 30 minutes.

 

Any ideas on of how to make it boot or revert back to 6.5?

 

 

HELP!

Frequent Contributor I

Re: ArubaOS 8.5 on IAP-305 - AP stuck after applying firmware..

Did you follow the upgrade path...

Occasional Contributor II

Re: ArubaOS 8.5 on IAP-305 - AP stuck after applying firmware..

Can you enlighten me please? Any ideas on what to do now that the AP is not booting?
Frequent Contributor I

Re: ArubaOS 8.5 on IAP-305 - AP stuck after applying firmware..

Dear Adrian,
You can reset AP until it comes to factory default firmware. pull the pin
to reset button hole until LED stable ( more than 1.30min).


Dinusha Chandrasinghe
Network Engineer

Plexus Global (Pvt) Ltd,

No 186, Nawala Road, Nawala, Sri Lanka

D| +94 114 248 807|M: +94 7744324426

E-mail: dinusha.c@plexuss.biz | Web: www.plexuss.biz



[image: PLEXUS logo.jpg]

[image: HPE]
Occasional Contributor II

Re: ArubaOS 8.5 on IAP-305 - AP stuck after applying firmware..

Got the console cable in and the output is:

 

APBoot 2.1.3.4 (build 56756)
Built: 2016-10-05 at 10:14:25

Model: AP-30x
DRAM: 512 MiB
Flash: Detected MX25R3235F: total 4 MiB
NAND: 128 MiB
PCIE0 link up
dev fn venID devID class rev MBAR0 MBAR1 MBAR2 MBAR3
00 00 168c 0040 00002 00 00000004 00000000 00000000 00000000
Power: DC
Nand Flash error. Status = 48
NAND page read failed. page: 4000 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 4001 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 4040 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 4041 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 4080 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 40c0 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 4100 status ffffffb6

NAND page read failed. page: 404c status ffffffb6
UBI error: vtbl_check: bad CRC at record 5: 0x77391fe9, not 0xf116c36b
UBI error: vtbl_check: bad CRC at record 4: 0xcc76eadb, not 0xf116c36b
UBI error: process_lvol: both volume tables are corrupted
UBI error: ubi_init: cannot attach mtd2
UBI error: ubi_init: UBI error: cannot initialize UBI, error -22
Volume aos0 not found!
Creating dynamic volume aos0 of size 0
UBI error: ubi_create_volume: cannot create volume -1, error -23
Volume aos1 not found!
Creating dynamic volume aos1 of size 0
UBI error: ubi_create_volume: cannot create volume -1, error -23
Volume ubifs not found!
Creating dynamic volume ubifs of size 0
UBI error: ubi_create_volume: cannot create volume -1, error -23
Net: eth0
Radio: qca9990#0, ipq4029#1
Reset: warm
FIPS: passed

Hit <Enter> to stop autoboot: 0
apboot>
apboot> osinfo
Partition 0Volume aos0 not found!
 does not contain a valid OS image

Partition 1Volume aos1 not found!
data abort
pc : [<87313bf4>]          lr : [<87310ba8>]
sp : 870efde8  ip : 10d38256     fp : 00000000
r10: 00000000  r9 : 870eff34     r8 : 00000001
r7 : 00000001  r6 : 01800000     r5 : 02000000  r4 : 84000000
r3 : 00000000  r2 : 0a000021     r1 : 0000000a  r0 : 02000000
Flags: nzCv  IRQs off  FIQs off  Mode SVC_32
Resetting CPU ...

resetting ...


APBoot 2.1.3.4 (build 56756)
Built: 2016-10-05 at 10:14:25

Model: AP-30x
DRAM:  512 MiB
Flash: Detected MX25R3235F: total 4 MiB
NAND:  128 MiB
PCIE0 link up
       dev fn venID devID class  rev    MBAR0    MBAR1    MBAR2    MBAR3
       00  00  168c  0040 00002   00 00000004 00000000 00000000 00000000
Power: 802.3af POE
Nand Flash error. Status = 48
NAND page read failed. page: 4000 status ffffffb6

 

apboot> upgrade os 0 ArubaInstant_Ursa_6.5.1.0-4.3.1.0_57768
eth0 up: 100 Mb/s full duplex
Using eth0 device
TFTP from server 10.10.0.5; our IP address is 10.10.0.122
Filename 'ArubaInstant_Ursa_6.5.1.0-4.3.1.0_57768'.
Load address: 0x84000000
Loading: #################################################################
         #################################################################
         #################################################################
         #############
         1.3 MiB/s
done
Bytes transferred = 13258960 (ca50d0 hex)

Image is signed; verifying checksum... passed
SHA2 Signature available
Signer Cert OK
Policy Cert OK
RSA signature verified using SHA2.
Volume aos0 not found!
Verifying flash...
Volume aos0 not found!
byte at 0x84000000 (0x00) != byte (0xff)
**** ERROR: upgrade failed ****.
apboot>
Occasional Contributor II

Re: ArubaOS 8.5 on IAP-305 - AP stuck after applying firmware..

Posting for reference, got my AP finally out of the loop...

 

In apboot:

 

dhcp
setenv serverip 10.10.0.5 <-- tftp server address

then:

 

apboot> tftpboot ArubaInstant_Ursa_6.5.1.0-4.3.1.3_59179
eth0 up: 100 Mb/s full duplex
Using eth0 device
TFTP from server 10.10.0.5; our IP address is 10.10.0.122
Filename 'ArubaInstant_Ursa_6.5.1.0-4.3.1.3_59179'.
Load address: 0x84000000
Loading: #################################################################
         #################################################################
         #################################################################
         #############
         1.3 MiB/s
done
Bytes transferred = 13266816 (ca6f80 hex)

Image is signed; verifying checksum... passed
SHA2 Signature available
Signer Cert OK
Policy Cert OK
RSA signature verified using SHA2.
Automatic boot of image at addr 0x84000000 ...
Uncompressing Kernel Image ... OK
[    0.000000]
[    0.000000] Aruba Networks
[    0.000000] ArubaOS Version 6.5.1.0-4.3.1.3 (build 59179 / label #59179)
[    0.000000] Built by p4build@samos on 2017-04-11 at 22:11:54 PDT (gcc version 4.6.3)
[    0.000000]
[    0.000000] CPU: ARMv7 Processor [410fc075] revision 5 (ARMv7), cr=10c5387d
[    0.024476] SMP: Total of 4 processors activated (384.00 BogoMIPS).
[    0.055158] i2c-gpio driver registered
[    9.668912] 3 ofpart partitions found on MTD device 7980000.qcom,nand
[    9.739075] Creating 3 MTD partitions on "7980000.qcom,nand":
[    9.807808] 0x000000000000-0x000002000000 : "aos0"
[    9.906476] 0x000002000000-0x000004000000 : "aos1"
[    9.992533] 0x000004000000-0x000008000000 : "ubifs"
[   10.124642] m25p80 spi0.0: found mx25r3235f, expected n25q128a11
[   10.209444] Found AT97SC3203 on i2c_1.8
[   10.248468] Key type dns_resolver registered
[   10.293938] Registering SWP/SWPB emulation handler
[   11.065462] msm_nand_read_oob: 0x2000000 datalen 0x800 ooblen 0 err -74 corrected 0
[   11.144701] UBI warning: ubi_io_read: error -74 (ECC error) while reading 64 bytes from PEB 0:0, read only 2048 bytes, retry
[   11.279607] msm_nand_read_oob: 0x2000000 datalen 0x800 ooblen 0 err -74 corrected 0
[   11.370747] UBI warning: ubi_io_read: error -74 (ECC error) while reading 64 bytes from PEB 0:0, read only 2048 bytes, retry
[   11.505630] msm_nand_read_oob: 0x2000000 datalen 0x800 ooblen 0 err -74 corrected 0
[   11.596776] UBI warning: ubi_io_read: error -74 (ECC error) while reading 64 bytes from PEB 0:0, read only 2048 bytes, retry
[   11.731667] msm_nand_read_oob: 0x2000000 datalen 0x800 ooblen 0 err -74 corrected 0
[   11.822820] UBI error: ubi_io_read: error -74 (ECC error) while reading 64 bytes from PEB 0:0, read 2048 bytes
[   11.943116] UBI assert failed in ubi_io_read at 202 (pid 1)
[   12.009959] UBI error: ubi_attach_mtd_dev: failed to attach mtd1, error -5
[   12.091598] UBI error: ubi_init: cannot attach mtd1
[   12.554402]
Starting Kernel SHA1 KAT ...
[   12.588861] Completed Kernel SHA1 KAT
[   12.635748] Starting Kernel HMAC-SHA1 KAT ...
[   12.685903] Starting Kernel DES KAT ...[   12.731639] Completed Kernel DES KAT
[   12.775346] Starting Kernel AES KAT ...
[   12.819129] Completed Kernel AES KAT
[   12.819129]
[   12.882649] Starting Kernel AESGCM KAT ...
[   12.929461] Completed Kernel AESGCM KAT
[   12.978776] Completed Kernel HMAC-SHA1 KAT
Thu Jan  1 00:00:00 PST 1970
[   13.113633] UBIFS error (pid 112): ubifs_mount: cannot open "ubi2:ubifs", error -19
mount: Mounting ubi2:ubifs on /aruba/fs failed: No such device
Mount ubifs fail
apfcutil: apfc_read failed: Cache uninitialized
Will reboot to mount ubifs
killall: nanny: no process killed
killall: sapd: no process killed
cd: 15: can't cd to /tmp/apfc
apfcutil: read failed: Is a directory
killall: wdg: no process killed
SIOCSIFADDR: No such device
The system is going down NOW !!
Sending SIGKILL to all processes.
Unmounting UBIFS failed.  Please report this error (Invalid argument).

Please stand by while rebooting the system.
[   22.841461] reboot: Restart▒

APBoot 2.1.3.4 (build 56756)
Built: 2016-10-05 at 10:14:25

Model: AP-30x
DRAM:  512 MiB
Flash: Detected MX25R3235F: total 4 MiB
NAND:  128 MiB
PCIE0 link up
       dev fn venID devID class  rev    MBAR0    MBAR1    MBAR2    MBAR3
       00  00  168c  0040 00002   00 00000004 00000000 00000000 00000000
Power: 802.3af POE
Nand Flash error. Status = 48
NAND page read failed. page: 4000 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 4001 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 4040 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 4041 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 4080 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 40c0 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 40c0 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 40c0 status ffffffb6
Nand Flash error. Status = 48
NAND page read failed. page: 40c0 status ffffffb6
apboot> tftpboot ArubaInstant_Ursa_8.5.0.0_70258
eth0 up: 100 Mb/s full duplex
Using eth0 device
TFTP from server 10.10.0.5; our IP address is 10.10.0.122
Filename 'ArubaInstant_Ursa_8.5.0.0_70258'.
Load address: 0x84000000
Loading: #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         ####
         1.3 MiB/s
done
Bytes transferred = 20994204 (140589c hex)

Image is signed; verifying checksum... passed
SHA2 Signature available
Signer Cert OK
Policy Cert OK
RSA signature verified using SHA2.
Automatic boot of image at addr 0x84000000 ...
Uncompressing Kernel Image ... OK
[    0.000000]
[    0.000000] Aruba Networks
[    0.000000] ArubaOS Version 8.5.0.0-8.5.0.0 (build 70258 / label #70258)
[    0.000000] Built by p4build@pr-hpn-build07 on 2019-04-27 at 00:59:39 UTC (gcc version 4.6.3)
[    0.000000]
[    0.000000] CPU: ARMv7 Processor [410fc075] revision 5 (ARMv7), cr=10c5387d
[    0.016889] SMP: Total of 4 processors activated (384.00 BogoMIPS).
[    0.053960] i2c-gpio driver registered
[   15.522077] 3 ofpart partitions found on MTD device 7980000.qcom,nand
[   15.591202] Creating 3 MTD partitions on "7980000.qcom,nand":
[   15.659933] 0x000000000000-0x000002000000 : "aos0"
[   15.759140] 0x000002000000-0x000004000000 : "aos1"
[   15.845731] 0x000004000000-0x000008000000 : "ubifs"
[   15.979167] m25p80 spi0.0: found mx25r3235f, expected n25q128a11
[   16.065992] Found AT97SC3203 on i2c_1.8
[   16.110244] Key type dns_resolver registered
[   16.150496] Registering SWP/SWPB emulation handler
[   16.921322] msm_nand_read_oob: 0x2000000 datalen 0x800 ooblen 0 err -74 corrected 0
[   17.000562] UBI warning: ubi_io_read: error -74 (ECC error) while reading 64 bytes from PEB 0:0, read only 2048 bytes, retry
[   17.135469] msm_nand_read_oob: 0x2000000 datalen 0x800 ooblen 0 err -74 corrected 0
[   17.226600] UBI warning: ubi_io_read: error -74 (ECC error) while reading 64 bytes from PEB 0:0, read only 2048 bytes, retry
[   17.361519] msm_nand_read_oob: 0x2000000 datalen 0x800 ooblen 0 err -74 corrected 0
[   17.452635] UBI warning: ubi_io_read: error -74 (ECC error) while reading 64 bytes from PEB 0:0, read only 2048 bytes, retry
[   17.587535] msm_nand_read_oob: 0x2000000 datalen 0x800 ooblen 0 err -74 corrected 0
[   17.678688] UBI error: ubi_io_read: error -74 (ECC error) while reading 64 bytes from PEB 0:0, read 2048 bytes
[   17.799000] UBI assert failed in ubi_io_read at 202 (pid 1)
[   17.865917] UBI error: ubi_attach_mtd_dev: failed to attach mtd1, error -5
[   17.947454] UBI error: ubi_init: cannot attach mtd1
[   18.611581] There is no gpio reset info
[   18.679659]
Starting Kernel SHA1 KAT ...
[   18.714122] Completed Kernel SHA1 KAT
[   18.761153] Starting Kernel HMAC-SHA1 KAT ...
[   18.811146] Starting Kernel DES KAT ...[   18.856920] Completed Kernel DES KAT
[   18.900602] Starting Kernel AES KAT ...
[   18.944378] Completed Kernel AES KAT
[   18.944378]
[   19.007965] Starting Kernel AESGCM KAT ...
[   19.054716] Completed Kernel AESGCM KAT
[   19.103975] Completed Kernel HMAC-SHA1 KAT
Thu Jan  1 00:00:00 PST 1970
ls: ubi?_*: No such file or directory[   19.312194] UBIFS error (pid 1170): ubifs_mount: cannot open "/dev/ubifs", error -22

mount: Mounting /dev/ubifs on /aruba/fs failed: Invalid argument
Mounting ubifs failed
apfcutil: apfc_read failed: Cache uninitialized
Will reboot to mount ubifs
killall: nanny: no process killed
killall: sapd: no process killed
cd: 23: can't cd to /tmp/apfc
apfcutil: read failed: Is a directory
killall: wdg: no process killed
SIOCSIFADDR: No such device
The system is going down NOW !!
Sending SIGKILL to all processes.
Unmounting UBIFS failed.  Please report this error (Invalid argument).

Please stand by while rebooting the system.
[   29.222083] reboot: Restarting system
[   29.253532] flash ready,reboot


APBoot 2.1.3.4 (build 56756)
Built: 2016-10-05 at 10:14:25

Model: AP-30x
DRAM:  512 MiB
Flash: Detected MX25R3235F: total 4 MiB
NAND:  128 MiB
PCIE0 link up
       dev fn venID devID class  rev    MBAR0    MBAR1    MBAR2    MBAR3
       00  00  168c  0040 00002   00 00000004 00000000 00000000 00000000
Power: 802.3af POE
Volume aos1 not found!
Creating dynamic volume aos1 of size 30982144
Volume ubifs not found!
Creating dynamic volume ubifs of size 62726144
Net:   eth0
Radio: qca9990#0, ipq4029#1
Reset: warm
FIPS:  passed

Hit <Enter> to stop autoboot:  0
Booting OS partition 0
Checking image @ 0x0
Copying image from 0x84000000

Image is signed; verifying checksum... passed
SHA2 Signature available
Signer Cert OK
Policy Cert OK
RSA signature verified using SHA2.
Uncompressing Kernel Image ... OK
[    0.000000]
[    0.000000] Aruba Networks
[    0.000000] ArubaOS Version 6.5.1.0-4.3.1.0 (build 57305 / label #57305)
[    0.000000] Built by p4build@lemnos on 2016-11-14 at 01:13:48 PST (gcc version 4.6.3)
[    0.000000]
[    0.000000] CPU: ARMv7 Processor [410fc075] revision 5 (ARMv7), cr=10c5387d
[    0.024552] SMP: Total of 4 processors activated (384.00 BogoMIPS).
[    0.055182] i2c-gpio driver registered
[    9.679706] 3 ofpart partitions found on MTD device 7980000.qcom,nand
[    9.749766] Creating 3 MTD partitions on "7980000.qcom,nand":
[    9.818509] 0x000000000000-0x000002000000 : "aos0"
[    9.917164] 0x000002000000-0x000004000000 : "aos1"
[   10.003251] 0x000004000000-0x000008000000 : "ubifs"
[   10.135436] m25p80 spi0.0: found mx25r3235f, expected n25q128a11
[   10.220229] Found AT97SC3203 on i2c_1.8
[   10.259206] Key type dns_resolver registered
[   10.304734] Registering SWP/SWPB emulation handler
[   12.012317]
Starting Kernel SHA1 KAT ...
[   12.046793] Completed Kernel SHA1 KAT
[   12.093668] Starting Kernel HMAC-SHA1 KAT ...
[   12.143796] Starting Kernel DES KAT ...[   12.189551] Completed Kernel DES KAT
[   12.233261] Starting Kernel AES KAT ...
[   12.277064] Completed Kernel AES KAT
[   12.277064]
[   12.340641] Starting Kernel AESGCM KAT ...
[   12.387377] Completed Kernel AESGCM KAT
[   12.436632] Completed Kernel HMAC-SHA1 KAT
Thu Jan  1 00:00:00 PST 1970
AP-type has_ble_support: ONBOARD.
Domain Name: instant.arubanetworks.com
Current OEM Name : Aruba Networks
Disabling ipv6 for devices by default
IPv6 capability is supported for devices
No panic info available
Writing /dev/ttyMSM1 into /tmp/ble_port
Enabling ble_daemon and ble_relay via nanny
Enabling clarity_dnsdhcp via nanny
apfcutil: sector CACHE: Cache uninitialized
apfcutil: sector RAP: Cache uninitialized
apfcutil: sector FAT: Cache uninitialized
apfcutil: sector SCRATCH: Cache uninitialized
Backup ENV.
apfcutil: sector MESH Prov: Cache uninitialized
[   22.873055] bus_scale_table is NULL
[   22.908486] sps:Pipe 3 already allocated on BAM 0x08e04000
[   22.967915] sps:Failed to allocate connection
[   23.017920] sps:Fail to allocate resource for BAM 0x  (null) pipe 0.
[   23.096016] QCE50: qce_sps_init_ep_conn: sps_connect() fail pipe_handle=0xdde8dc00, rc = -1
[   23.196138] qcrypto: probe of 8e20000.qcrypto failed with error -1
Installing glenmorangie ethernet driver
[   23.525817] edma module_init
Starting watchdog process...
Cfg len is 0
Configuration file is empty, turning on default services...
extended ssid activate due to no AP config ...
touching file /tmp/ip_mode_0
No configuration file. Enabling Cluster security DTLS.
eth1 admin down
SIOCGIFFLAGS: No such device
init usb modem ...
[   24.571257] SCSI subsystem initialized
No USB Plugged in
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
Ethernet uplink not active yet
[   65.644510] bond0: GMAC Link is up with phy_speed=100
Mesh is DISABLED on this device.
copying bootuplog ...
[   66.467937] drvlog_mod: module license 'Proprietary' taints kernel.
[   66.542205] Disabling lock debugging due to kernel taint
allow PAPI
notify asap_mod 3g no present...
apdot1x authentication is not enabled
Got all network params from APboot env. Skipping DHCP
10.10.0.122 255.255.255.0 10.10.0.1
Compressing all files in the /etc/httpd directory...
Done.
Starting Webserver
bind: Transport endpoint is not connected
bind: Transport endpoint is not connected
bind: Transport endpoint is not connected
bind: Transport endpoint is not connected
Launching NTP Client on pool.ntp.org
AP rebooted caused by warm reset
shutting down watchdog process (nanny will restart it)...

        <<<<<       Welcome to the Access Point     >>>>>

Completed SW FIPS KAT test
User: admin
System uptime is 88 seconds and CLI is not ready yet, please try again later.
User: 

 

Frequent Contributor I

Re: ArubaOS 8.5 on IAP-305 - AP stuck after applying firmware..

Dear Adrian,

I recommend reinstalling the firmware using cpboot> mode. Please try lower Aruba OS version 

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: