Controllerless Networks

Reply
Frequent Contributor II

Re: Converting IAP to Campus AP fails - Retrieve Image Failed

If the controller is running 8.2.1.0, I have no idea.

Could you try to upgrade IAP to latest version first then convert to join the controller?


Thank you,
Ratchapas S.
Land of Smiles
Frequent Contributor I

Re: Converting IAP to Campus AP fails - Retrieve Image Failed

I have also tried to set up a same VMC in test environment, converted, then provisioned the AP. Then took it to client and still it fails to connect. (Of course, I changed the master IP to client's controller first.)

 

I also tried a few firmwares. Upgraded and downgraded the AP but ended up with same result. The AP connects to other controllers except client controller. I also tried hooking up a different AP to the same physical port and it converts. So I ruled out network problem.

 

I also had an intresting phenomenon. I also put a laptop in the same subnet as the AP and controller. I could ping the controller from laptop and back. I could ping AP from laptop and back. But I couldn't ping either the controller from AP or the other way around. Thats why I thought the controller has somehow blacklisted the ap (even though the AP is in whitelist accepted status) and is blocking traffic.

 

If someone has an Idea wheather this is possible. I am open to suggestions.

 

THX

Daniel

Frequent Contributor II

Re: Converting IAP to Campus AP fails - Retrieve Image Failed

Did you try to change Regulatory Domain?


Thank you,
Ratchapas S.
Land of Smiles
Frequent Contributor I

Re: Converting IAP to Campus AP fails - Retrieve Image Failed

Every appliance runs on HU regulatory domain. Before trying to convert AP I set it also to HU.

Frequent Contributor II

Re: Converting IAP to Campus AP fails - Retrieve Image Failed

Please try to create another regulatory domain for testing. Maybe US, SG. Just for testing.


Thank you,
Ratchapas S.
Land of Smiles
Frequent Contributor I

Re: Converting IAP to Campus AP fails - Retrieve Image Failed

In a productive environment I don't know if its possible.

Guru Elite

Re: Converting IAP to Campus AP fails - Retrieve Image Failed

If it is a connectivity issue, it probably is not related to the regulatory domain.

 

Please open a TAC case to save yourself some time:  https://www.arubanetworks.com/support-services/contact-support/


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.4 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Aruba Central Documentation
Sign up for Security Alerts
Aruba Technical Webinars
Frequent Contributor I

Re: Converting IAP to Campus AP fails - Retrieve Image Failed

Hello Everyone!

 

Just an update, because I saw that other people had the same problem as me, so I thought I share my results.

 

I opened a TAC case side-by-side with this thread. TAC confirmed my hunch that it was a hardware problem:

 

When the AP boots:

 

[    0.428064] msm_pcie_probe: msm_pcie_probe: PCIe: RC0 is not enabled during bootup; it will be enumerated upon WAKE signal.
[    0.428074] msm_pcie_probe: msm_pcie_probe: PCIe: Driver probe failed for RC0:-1
[    0.429137] msm_pcie: probe of 80000.qcom,pcie failed with error -1

 

Also, when AP boots, its routing table is all messed up. Sometimes it would erase the default-gw adress and set it to 0.0.0.0.

 

So that was the big mystery. A faulty hardware :)

 

Cheers!

Highlighted
New Contributor

Re: Converting IAP to Campus AP fails - Retrieve Image Failed

I was having the same problem with a few cases of IAP325's. My Controller running version 6.5.4.9 and IAP's coming with 6.4.4.4.... 

 

Updated the IAP's to 6.5.4.9 and resolved the problem.

Frequent Contributor I

Re: Converting IAP to Campus AP fails - Retrieve Image Failed

Old post but i just hit this snag as well and it wasnt a hardware issue which was listed..

 

After some show commands I noticed I missed some config..

 

MC# show crypto ipsec sa

 

Oh the AP has an inner ip of 0.0.0.1

but I made my VPN Pool...

 

show log all 30.. Okay it uses the default-vpn-role and uses L2TP

 

Go to the default-vpn-role ->More-> L2TP field is EMPTY. Make sure the L2TP drop down has your VPN Pool selected :D

 

TFTP is used between RAP and MC btw for image updates

 

Reboot AP, convert again,. Boom - Correct inner IP and conversion successful.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: