Controllerless Networks

New Contributor

Help w/ XBOX Live "Strict" or "Moderate" NAT Type - Call of Duty on Aruba Instant AP!

Please Help w/ Fix For Aruba Instant & XBOX Users:


For those gamers out there, particularly XBOX Call of Duty franchise fans, this topic has likely been a HUGE annoyance to you for years. I'm talking about the "Strict" or "Moderate" NAT type issue on XBOX's Call of Duty games (and many others I'm sure). 


Strict or Moderate NAT types cause issues to XBOX live users such as: 

- inability to join friends for games

- inability to join partys or chats

- getting booted from XBOX Live servers mid-game

- getting disconnected from XBOX Live


Basically, this issue makes the game experience unbearable for the user. 


Now, the general fix for the consumer market routers (netgear/linksys, etc.) is to configure Port Forwarding and enable UPnP on your home router, such as is shown here --> See Here From Microsoft


Required Open Ports: 

  • Port 88 (UDP) 
  • Port 3074 (UDP and TCP) 
  • Port 53 (UDP and TCP) 
  • Port 80 (TCP)


I am using a RAP-109 and am running the latest and greatest InstantOS - .If you couldn't tell, I am an XBOX/COD fan as well. :smileylol:


I have my cable modem plugged in to my RAP-109 E0 port and the XBOX connected to the E1 port.

NOTE: This involves NO wireless connectivity - all wired.


In the "Wired" settings I configured a "Wired Network" that has, in sum, everything "open".  


I have everything in "Services" enabled, excluding:

- "Enable Guest Bonjour Multicast"

- "Enable AirGroup Across Mobility Domains". 


I have also created a "Network-Based" Access Rule for Port Forwarding (much like I did on my old Netgear router in the past). 


What am I missing here?

I'm sure this isn't the first time an Aruba-user has run in to this issue - especially with edu & hospitality being very pro-Aruba. 


Thoughts? Suggestions??


Thanks, All. 



Guru Elite

Re: Help w/ XBOX Live "Strict" or "Moderate" NAT Type - Call of Duty on Aruba In

This is generally an issue high up in your network. Is the wired port set to tunnel?

| Tim Cappalli | Aruba Security | @timcappalli | |

NOTE: Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba or Hewlett Packard Enterprise.
New Contributor

Re: Help w/ XBOX Live "Strict" or "Moderate" NAT Type - Call of Duty on Aruba In

My RAP-109 is not hitting a controller. Consider it an Instant Access point with an extra wired port.


When I click "Wired" in the Virtual Controller WebUI and Edit my Wired Network profile, the only "mode" so to speak that I can choose from is "Access" or "Trunk". I have no VLANs runnning on my network - I have this set to Access. 


I also have my Access Rules set to "Unrestricted". 


If I were to remove the RAP-109 from the equation, plugging my XBOX right in to my cable modem, then I get an "Open" NAT type - problem solved. But I don't want to remove my RAP-109. :smileywink:



New Contributor

Re: Help w/ XBOX Live "Strict" or "Moderate" NAT Type - Call of Duty on Aruba In

I managed to fix this one over the weekend and thought I should share. I would love to hear your feedback. 


To Recap: 

I was receiving either "Strict" or "Moderate"  NAT type warning message on my XBOX and this prevented me from gaming with my friends (end of the world, right?). See image below for example.


The Fix:

I edited my Wired Network settings for "Client IP Assignment" from "Virtual Controller Managed" to "Network Assigned".

This is found when configuring your wired settings under Step 2 "VLAN". See image below for example.


The Problem:

I think XBOX doesn't like dual-NAT. 

Prior to me making the above fix I was receiving DHCP from the Virtual Controller. That was giving me a 172.31.98.x. 

Once I allowed my modem to provide DHCP to devices connected to the wired RAP port I was no longer receiving the "Strict" or "Moderate" NAT type warning from my XBOX. Horray!! :smileyhappy:


My Questions: 
Why doesn't XBOX like dual-NAT?

What if I was required to to dual-NAT? What would be a workaround?


Thanks for reviewing!





This is the error message I was receiving from my XBOX:

Strict NAT.png



This is how my network is set up. I only have one wired device and that is my XBOX:

My Network.png



This is the setting I changed under "Wired" settings when editing my "defaul-wired-port-profile".

That port profile is used for my "E/1" port on my RAP-109: 

My Settings.png


MVP Expert

Re: Help w/ XBOX Live "Strict" or "Moderate" NAT Type - Call of Duty on Aruba In

Just for others landing on this topic - as I did when trying to find a solution for the same problem - I'd like to update this.


The reason this change worked is because the RAP is no longer acting as gateway and doing the NAT for this device. The ArubOS/Instant software doesn't support UPnP for this setup, but the modem obviously does.


I haven't found a single thread where the NAT-Strict/Moderate problem is solved when using Aruba equipment.

John Solberg

-ACMX #316 :: ACCX #902 :: ACSA
Aruba Partner Ambassador
Intelecom/NetNordic - Norway
Remember to Kudo if a post helped you! || Problem Solved? Click "Accept as Solution" in a post!
New Contributor

Re: Help w/ XBOX Live "Strict" or "Moderate" NAT Type - Call of Duty on Aruba In

Is there any fix for the strict NAT issue on Xbox for an SSID?  What settings do we need to configure to remove the strict NAT?



Search Airheads
Showing results for 
Search instead for 
Did you mean: