Controllerless Networks

New Contributor

IAP conversion trouble


We have two IAP-305 which I have successfully converted to CAP a few days ago.
Now, the site where they were deployed is changing it's network configuration from one C-net to another. I figured that I had to reset the CAPs and do the conversation again to get them up and running again, but they aren't showing up in our controller.

We have a 7010 controller running and the required version for the IAP-305 is This isn't the issue since I managed to add them previously. We also have the required licenses for them to be added.

When the APs were reset, they functioned just like the IAPs they were before, but after I tried to convert them they keep going online and offline on the network. Attached is a "log" of the ping responses I get.

The first time it happened I figured I'd just reset them again, but after doing that and converting one of them again the same thing is happening.


Is there anything I have to do on my controller to make it "forget" that the APs were previously connected? What I have done is that I removed them from the Monitoring -> Network -> All Access Points page. Also, I removed one of them from Wireless -> AP Installation -> Whitelist page.

Re: IAP conversion trouble

Hi Eric,


Is it possible to get the console output for one of the IAP-305's being converted?


Does it says conversion successful when you try to convert them ?


Are the IAP's able to reach the controller in the new subnet ?


In case the conversaion fails, please collect the IAP to get more clue in to the issue.


Just to make sure there is no change on controller side, please verify the following outputs :


1. show ap license-usage -- This commans will tell you if you have licenses available


2. show  datapath session table <ip of IAP>


The above command will tell you if there is any traffic seen from the IAP on the controller.


3.  Do you have CPSEC enabled on the controller. If yes , please check the following command to see the IAP mac-address is present in the CPSEC whitelist:


show whitelist-db cpsec | include <mac-address of IAP>

New Contributor

Re: IAP conversion trouble

Hi, Nitesh

Thank you for your reply.


1. show ap license-usage
There are 9 licenses available.


2. show  datapath session table <ip of IAP>

This command turns up empty. Not sure what that means but I can ping the AP from my controller.


3.  Do you have CPSEC enabled on the controller. 

CPSEC is enabled, yes. The AP that I'm having trouble finding is not present in the list because I already purged it when I was troubleshooting last friday.

Usually they show up as "not approved" (or some such phrase) and I just have to approved them, but it's not showing up at all.


The AP is in the same state as before the weekend. It's online for about 3 minutes and then goes offline for 3 minutes - pending over and over.

Re: IAP conversion trouble

Hi Eric,


show datapath session table <ip of IAP> 


The above command will show if IAP is trying to send any traffic to the controller while the conversion process is in place.


Does the following commands on controller point to any errors related to conversion ?


show log system all

show log all


Does the IAP logs point to any messages related to failed conversion ?

New Contributor

Re: IAP conversion trouble

After a bit more of troubleshooting I finally got one of my APs to appear on my controller.

What I did was to add the DHCP options 43 and 60 to the scope, I deleted the lease on my AP and I never dropped another ping.
I'm not sure if it was the options or the lease removal that fixed it.

The conversions always worked I believe.


I lost the AP again after giving it a non-dhcp address, but I will try to resolve this by reserving the addresses that I want in the scope instead.


Thank you for your aid, Nitesh.

Search Airheads
Showing results for 
Search instead for 
Did you mean: