Controllerless Networks

Occasional Contributor II

Many IAP-103s image upgrade fails (6.4 --> 6.5)



We need to upgrade many IAP-103 clusters at many customers many sites, but I'm experiencing an interesting phenomenon.


There is an IAP-103 cluster each site, and I have experienced the error at every cluster update.


Not all members are running the update, and at the end of the cluster update there are always a few APs that can not update and can not come back to the cluster by this error meesage: "image version mismatch"

I checked during the update, these problematic APs didn't go over download-done state.


I tried to update them by disabling all APs (disable poe on the switch) and launching a single AP from the wrong ones. Since the other members were down, so she became the master, I logged in and start the upgrade. During the upgrade, I checked cli (sh upgrade info) I saw the upgrade was successful and reboot comes.

However, after reboot, he returned again with the old image (, but according to the log everything is fine:


AP3# sh ver
Aruba Operating System Software.
ArubaOS (MODEL: 103), Version
Copyright (c) 2002-2015, Aruba Networks, Inc.
Compiled on 2015-05-12 at 12:03:05 PDT (build 50009) by p4build

AP uptime is 15 minutes 5 seconds
Reboot Time and Cause: AP rebooted Wed Jul 25 12:33:34 CEST 2018; Image Upgrade Successful


I tired also:


upgrade from web

upgrade to many versions (,,

reset config on iap before upgrade


None of them works. :(


I need to upgrade to minimum because of a major error fix (iap-100 series wifi driver problem)


What can I do with these problematic APs?

MVP Guru

Re: Many IAP-103s image upgrade fails (6.4 --> 6.5)

How are these IAP's managed locally or via Central/AirWave? If so do you have Firmware compliance enabled? Is there any preferred masters configured?


As a step you could also try upgrading to the latest 6.4 then try to 6.5.

If my post addresses your query, give kudos:)
Occasional Contributor II

Re: Many IAP-103s image upgrade fails (6.4 --> 6.5)

These are managed locally and there are no preferred master configured.


OK, I will try to upgrade first to the lastest 6.4, and I will write about expreiences.



New Contributor

Re: Many IAP-103s image upgrade fails (6.4 --> 6.5)

Same issue in two IAP103 clusters.

Neither works with latest 6.4, neither upgrading from to (or similar, didn’t have exact versión now)

Tried switch-partition command, all logs ok, but when reboot, did it os same versión.

Any idea? Thanks
Guru Elite

Re: Many IAP-103s image upgrade fails (6.4 --> 6.5) does not exist.  If you give us the exact version numbers we can understand what could be going on here.

*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.4 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Aruba Central Documentation
Sign up for Security Alerts
Aruba Technical Webinars
New Contributor

Re: Many IAP-103s image upgrade fails (6.4 --> 6.5)



anyone can help me ? I have two cluster iap-103, i want upgrade firmware, but it doesnt works. I try upgrade from file over local LAN in to IP of controller, I try automatically upgrade from portal over check, it still doesnt work. It takes about 15-20 minutes, and after few reboots are still same firmware. I tried Firefox, Chrome, Explorer, Edge, still the same problem.


Thanks a lot.






Search Airheads
Showing results for 
Search instead for 
Did you mean: