Controllerless Networks

Reply
MVP Expert

SNMPWALKing the VC does not always respond

Hello,

 

We have an access controller (developped in-house) to deliver captive portal which is in front of the IAP cluster.

 

From this access controller, I cannot snmpwalk directly the VC.

When I attempt to walk any of the other APs on the network it works, then I try walking the VC and it works.

After some time, snmpwalking the VC directly stops working.

 

The network is designed as such

 

Access controller -> Cisco Core Switch -> Aruba S2500 edge switches -> IAP

Everything is on the same subnet (not my design :) )

 

Any ideas?

 


Accepted Solutions
Highlighted
Aruba

Re: SNMPWALKing the VC does not always respond

This issue is addressed in IAP 4.1 which is forthcoming shortly. Thanks to pmonardo for helping isolate the issue with Dev/Eng at Aruba.

 

Adam



| Adam Kennedy, Systems Engineer - adamk@hpe.com

| Service Providers – Aruba, an HPE Company

| Twitter: @adam8021x | Airheads: akennedy

View solution in original post


All Replies
Highlighted
MVP Expert

Re: SNMPWALKing the VC does not always respond

No responses I guess.

I am also experiencing the following where it sometimes responds and sometimes does not.

If a VC would transfer over to another AP, the snmpwalk breaks.

IAP now version 3.4.0.1
Highlighted
Aruba

Re: SNMPWALKing the VC does not always respond

hey pmonardo, I've got a potential bug filed for this within a client deployment. PM me and we can validate your setup as well as the suspected issue.



| Adam Kennedy, Systems Engineer - adamk@hpe.com

| Service Providers – Aruba, an HPE Company

| Twitter: @adam8021x | Airheads: akennedy
Highlighted
MVP Expert

Re: SNMPWALKing the VC does not always respond

Sure thing.
Highlighted
MVP Expert

Re: SNMPWALKing the VC does not always respond

Fix has been released in 3.4.0.3.
Highlighted
MVP Expert

Re: SNMPWALKing the VC does not always respond

Not fixed in release 3.4.0.3 and neither in 4.0.0.1.
Still working on it
Highlighted
Frequent Contributor II

Re: SNMPWALKing the VC does not always respond

Do you have debug level enabled on the iAP's and if soo is there anything that happens everytime the VC stops reposding.

Do you have SNMP walk the VC IP and the AP IP at the same time and you are not getting replies from either?

If you found my post helpful, please give kudos!
Highlighted
MVP Expert

Re: SNMPWALKing the VC does not always respond

I've done the following:
Taking a pcap at the uplink
Taking a pcap at the AP
Enabled SNMP debug on the IAP

Aruba has identified this as a bug and I am awaiting an answer
Highlighted
Frequent Contributor II

Re: SNMPWALKing the VC does not always respond

I told you what settings I applied on my iAP and I'm still able after 48 hours to get SNMP replies from my VC.

Tried them out and let us know :)

If you found my post helpful, please give kudos!
Highlighted
MVP Expert

Re: SNMPWALKing the VC does not always respond

I tried the same with my IAP and it does not work.

Again, Aruba has filled a bug and was able to replicate it.
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: