Controllerless Networks

Frequent Contributor I

Unable to get aruba 2540 switches in aruba central

Hi All,


Im facing a little problem.


I try to get the 2540 into our aruba central account.


Things that i did:


show activate provision
 Configuration and Status - Activate Provision Service
  Activate Provision Service   : Enabled
  Activate Server Address      :
  Activation Key               : Not Available


The activation key is not shown. This is a indication that it cannot reach aruba activate?



# aruba-central enable

# show aruba-central

Configuration and Status - Aruba Central

  Server URL       : None
  Connected         : No
  Mode                 : NA
  Last Disconnect Time : NA


The DNS is set and i can ping:

ping is alive, time = 146 ms

From this network i also tryed to get a IAP into central. This is no problem and works right away.


I also tryed to add the switches to central using the SN and MAC. I also assigned a subscription key.


I have requested a activate account but it takes a few days to get this account approved.


Tested both with 16.2 and 16.3 firmware.


Someone knows a solution?

Frequent Contributor I

Re: Unable to get aruba 2540 switches in aruba central

Seems that the switch needs to be factory default. When in central, it looks like you can only configure it from the central gui and not use the CLI.

New Contributor

Re: Unable to get aruba 2540 switches in aruba central


I have had the same issue with my Aruba 2530.

what I worked out eventually was a way to force the switch to reconnect to Aruba Central

I used the following commands:

activate provision enable

activate provision force

This then gave me the activation key

And when I ran the following command

show aruba-central

I was presented with

Server URL               :

Connected                  : Yes

Mode                         : Monitor

Last Disconnect Time           : NA

Hope this helps.


Search Airheads
Showing results for 
Search instead for 
Did you mean: