Controllerless Networks

Occasional Contributor I

Upgrade RAP-3WNP-US

Hi there,

I try to upgrade a RAP-3WNP-US from version to the lates version for use at home, I know old systems.

Did connect to the Instant SSID and downloaded the image, the RAP-3 will boot and show on the console the new version, looks OK!

After some minutes the system restart and boot again with a OLD version "ArubaOS Version (build 38532 / label #38532)".

What is happening??


Greatings Fred

73, pe0fko.


Re: Upgrade RAP-3WNP-US



De firmware is erg oud; ik zou via de laatste firmware downloaden en handmatig installeren via de 'Browse' optie bij firmware updates. Doe dat ook twee keer achter elkaar zodat beide firmware partities op recente firmware zijn en een factory reset je niet terug brengt naar versie 3.0.


Let even op, het model RAP-3WNP-US is vast ingesteld op FCC regelgeving en mag daardoor uitsluitend in de VS gebruikt worden, het is niet toegestaan deze in Nederland te gebruiken waar ETSI regels gelden.


I would upgrade the image on this AP twice manually with the firmware that can be found in the Lifetime Warranty section (direct link: Upgrade twice, with a reboot in between to make sure the backup image is on the same recent version and a hardware reset would bring you back to the recent version instead of the ancient 3.0 release.


Please note that the -US version may only be operated in the United States and cannot be used in other countries. For The Netherlands you would need the model RAP-3WNP (without the -US suffix) to operate according to regulations.


73. Herman (PA3FYW)

If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).
Occasional Contributor I

Re: Upgrade RAP-3WNP-US

Hello Herman,


The firmware is old and upgrading with the web interface will not always work. I understand that the RAP-3 did have two partitions, I can't see it in the web interface?

When I upgrade to the new version it will download from Aruba(?) the version, that is no IAP version but only RAP/CAP and it will connect to the Aruba controller on the internet. After a new factory default I will get the old version again, so thereare more partitions!


Is there a way to load (both) partitions on the flash with the same IAP version, maybe by using the serial line command tftp?


I know about the FCC / ETSI rules, what I understand is the difference between US & NL for the 2.4GHz band (2.4-2.4835) only the output power (ETSI: 100mW EIRP, FCC: 1W conduct output). In the 5GHz band there are more differences (channels) but the RAP-3 only used the 2.4GHz.


73, Fred



Re: Upgrade RAP-3WNP-US

If you can access the console, you can upgrade the image over TFTP as well; however the console has a special 4-pin header and you need a level converter cable (AP-CBL-SER) TTL-RS232 to connect it to a serial port.


If you can SSH into the Instant AP, you can use the upgrade os commands there as well to upgrade either flash partition:

d8:c7:c8:cc:45:54# upgrade-image?

d8:c7:c8:cc:45:54# upgrade-image ?
<url>     ftp/tftp/http URL syntax

From the WebUI you only see the current running version, and by upgrading twice (the upgrade will put the running firmware in the backup slot), you can make both slots the same firmware.


I have never seen an Instant AP with the automatic update procedure switch into a campus AP; however again the 3.0 firmware is pretty ancient and upgrading manually with firmwares that you download from the support website will most times do the thing...

If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).

Re: Upgrade RAP-3WNP-US

We found out that in this case, the access points were placed in Aruba Activate to convert to Remote APs by the previous owner. So that was the reason the AP converted from Instant firmware to RAP firmware.


If your (second hand) AP's are configured by the previous owner in Activate, you can either block to prevent the AP from communicating to Activate; or let the original owner (who we didn't know) or Aruba TAC remove the provisioning rules for that AP from Activate.


In this case, worked with Aruba TAC to get the APs moved in Activate to a place where they were no longer converting, and that solved the issue.

If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).
Search Airheads
Showing results for 
Search instead for 
Did you mean: