Controllerless Networks

Reply
MVP

iAP 4g uplink troubleshooting

I'm coming late to the 4G uplink party, and I'm surprised I can't find that much here to help me figure out whether something is broken or if I'm just being dense.

 

I have an iAP 205H which brings up a VPN connection and works flwalessly as a remote office on wired Internet (DSL/Cable etc.)

 

The user of this iAP wants to take it on the road and will be needing 4G uplink. I have set the uplink bits as pictured here:

iAP-uplink.png

When I unplug the DSL ethernet, the iAP LEDs stay as before (green above amber) and the USB 4G dongle from Verizon has both LEDs green.

I see the error at the bottom of "show cellular config:"

*********************************************************************************************************
 11/26/2019 14:41:57 PM    Target: RAP-11-ap    Command: show cellular config 
*********************************************************************************************************

Cellular configuration
----------------------
Type            Value
----            -----
4g-usb-type     
usb-type        
usb-dev         
usb-tty         
usb-init        
usb-auth-type   
usb-user        
usb-passwd      
usb-dial        
usb-modeswitch  
modem-isp       Verizon
modem-country   

Supported Modem Types
---------------------
Modem Type      Driver Used
----------      -----------
option          option
acm             acm
airprime        airprime
hso             hso
sierra-evdo     sierra-evdo
sierra-gsm      sierra-gsm
pantech-uml290  pantech-3g
novatal-mc551   ether-3g
sierra-net      sierra-net
franklin-u770   rndis-u770
rndis-l800      rndis-l800
huawei-cdc      huawei-cdc
novatel-u620    novatel-u620
pantech-uml295  rndis-uml295
sierra-gobi     sierra-gobi

Supported Country list
----------------------
Country list
------------

Supported ISP list
------------------
ISP list
--------
Verizon

modem status summary:USB modem attached with auto detect not successful

How do I "help" autodetect detect the modem?

--Matthew

if I've helped, please give kudos
if I've provided a solution, please mark the solution so others can find it
MVP

Re: iAP 4g uplink troubleshooting

It depends on the dongle type.

what dongle are you using and what's Instant firmware version?

check this link for troubleshooting 3G/4G troubleshooting.

The document is about 3G/4G back up for IAP-VPN.

 

https://community.arubanetworks.com/t5/Controllerless-Networks/IAP-VPN-Centralised-L2-and-Distributed-L3-with-3G-4G-pre-emption/td-p/528954

 


If a reply adequately addresses your issue, please click on the "Accept as Solution"
MVP

Re: iAP 4g uplink troubleshooting

Thanks for the link.

 

I'm running 6.5.4.11 using the Verizon USB730L (the 720 is int he support products list, but Verizon doesn't sell it anymore) as far as I can tell it's nearly identical to the 720.

--Matthew

if I've helped, please give kudos
if I've provided a solution, please mark the solution so others can find it
MVP

Re: iAP 4g uplink troubleshooting

I've been over that document and note that my modem must be getting mostly recognized.

 

I was thinking that the 205H on 6.5.4.11 was too old or something, so I switched to a 303H running 8.5.0.3 and see the same thing.

The only options I get in the uplink section are as shown:iAP-uplink2.png

No country setting available and ISP can be Verizon or None.

--Matthew

if I've helped, please give kudos
if I've provided a solution, please mark the solution so others can find it
MVP

Re: iAP 4g uplink troubleshooting

Novatel U730L is not suported on IAP-205H. but it shold be supported on AP-303H with instant verson of 8.4 or better. I think those modems needs to be configured for enterprise mode first.

quick way to check this to reboot the AP303H with the dongle connected and look at the console messages for vendor_id and product_id.

is it 1410 and 9030?


If a reply adequately addresses your issue, please click on the "Accept as Solution"
MVP

Re: iAP 4g uplink troubleshooting

The modem is configured to "just connect" - it comes up almost magically on my Linux laptop.

Not so much the micro-USB serial cable from the iAP303H - I take it I need an adpter of some sort?

Once the iAP boots, can I review the boot logs from the CLI?

 

--Matthew

if I've helped, please give kudos
if I've provided a solution, please mark the solution so others can find it
MVP

Re: iAP 4g uplink troubleshooting

yes the command is "sh log iap-bootup"


If a reply adequately addresses your issue, please click on the "Accept as Solution"
MVP

Re: iAP 4g uplink troubleshooting

Lifted out of the show-tech:

[  102.757205] usb 1-1: new high-speed USB device number 5 using xhci-hcd
[  102.812087] usb 1-1: New USB device found, idVendor=1410, idProduct=9030
[  102.812110] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  102.812123] usb 1-1: Product: MiFi USB730L
[  102.812136] usb 1-1: Manufacturer: Novatel Wireless
[  102.812148] usb 1-1: SerialNumber: 0123456789ABCDEF
--Matthew

if I've helped, please give kudos
if I've provided a solution, please mark the solution so others can find it
MVP

Re: iAP 4g uplink troubleshooting

iap-bootup log shows what I snipped above from the show tech.

show cellular configuration shows this:

RAP-09-ap# sh cellular config
Comm USB Plugged in: Vendor_ID=1410 Product_ID=9030

Cellular configuration
----------------------
Type            Value
----            -----
4g-usb-type
usb-type
usb-dev
usb-tty
usb-init
usb-auth-type
usb-user
usb-passwd
usb-dial
usb-modeswitch
modem-isp       Verizon
modem-country   US

Supported Modem Types
---------------------
Modem Type      Driver Used
----------      -----------
option          option
acm             acm
airprime        airprime
hso             hso
sierra-evdo     sierra-evdo
sierra-gsm      sierra-gsm
pantech-uml290  pantech-3g
novatal-mc551   ether-3g
sierra-net      sierra-net
franklin-u770   rndis-u770
rndis-l800      rndis-l800
huawei-cdc      huawei-cdc
novatel-u620    novatel-u620
pantech-uml295  rndis-uml295
sierra-gobi     sierra-gobi
zte-mf832       zte-cdc

Supported Country list
----------------------
Country list
------------

Supported ISP list
------------------
ISP list
--------
Verizon

modem status summary:USB modem attached with auto detect not successful

Does that indicate that I have to wait for Aruba to add the 730, or check provisioning with Verizon, or something else?

--Matthew

if I've helped, please give kudos
if I've provided a solution, please mark the solution so others can find it
Highlighted
MVP

Re: iAP 4g uplink troubleshooting

ok that modem has to be set to operate in enterprise mode. You can connect the modem to your laptop and basically try to get to the modem's web interface, there you can upgrade the modem's firmware and also enable enterprise mode.

 

 


If a reply adequately addresses your issue, please click on the "Accept as Solution"
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: