Deutschsprachiges Forum

Reply
Contributor II

IMC Backup-Probleme nach Update/Patch

Hi@all,

nach dem ich von 7.2 auf 7.3 inkl Patch den IMC aktualisiert habe (iMC PLAT 7.3 (E0605P04)) läuft mein Backup nicht mehr.

Der IMC läuft auf einen Windows 2008-Server, die DB auf einem SQL-Server auch 2008.

Nach dem Patch habe ich vom IMCnoch das installslave angestartet (auf dem SQL-Server) um das DBman anzupassen. Das Backup soll auf dem SQL-Server liegen (war vor dem Update auch so)

 

Vor dem Update lief alles:

2018-07-27 22:03:58 [LOG] [TimeBackup] Success to auto backup databases

2018-07-28 22:00:01 [LOG] [TimeBackup] Begin to auto backup databases

2018-07-28 22:03:50 [LOG] [TimeBackup] Success to auto backup databases

2018-07-29 22:00:01 [LOG] [TimeBackup] Begin to auto backup databases

2018-07-29 22:03:58 [LOG] [TimeBackup] Success to auto backup databases

Nach dem Update/Patch bekomme ich nur noch:

2018-08-10 22:00:03 [LOG] [CommonBackup] Begin backup ...

2018-08-11 22:00:03 [LOG] [CommonBackup] Begin backup ...

2018-08-12 22:00:03 [LOG] [CommonBackup] Begin backup ...

Aber er macht kein Backup.

Hat jemand eine Idee????

 

Das Manuelle Backup geht (also Lokal auf den IMC-Server)

aber wenn ich es einplane (unter Configure) bekomme ich das im debug-log

2018-08-13 11:47:00 [ERROR] [locateDbPosition] Can not find DB[192.168.160.39@aclm_db_imc_aclm] information in config !
2018-08-13 11:47:00 [ERROR] [CDbBackup::BackupAllDataBase] Fail to found DB[192.168.160.39@aclm_db_imc_aclm] information in backup system config
2018-08-13 11:47:00 [ERROR] [CommonBackup] backup all db failed .

 

wobei der 192.168.160.39-Server mein SQL-Server und Zielserver für das Backup ist (also dort wo auch der DBMAN noch läuft)

Contributor II

Re: IMC Backup-Probleme nach Update/Patch

Hallo Thomas,

in der Internationalen Community hab ich ja schon einen Call empfohlen. Ist sicher besser, als irgendwas auszuprobieren, ohne die Auswirkungen zu kennen.

Aber...

Ich hab die Screenshots aus dem "internationalen" Post angeschaut. Da ist mir noch was aufgefallen.
Du hast bei "Master Server IP of Backup System" die IP des Datenbank Servers drin stehen.
Die steht aber eigentlich schon (ausgegraut) im Feld "Database Address".
War das vorher auch schon so?
Ist das beim installslave passiert?
Hast Du das eingetragen?

Anyway. Ich hab in einer meiner Installationen nachgeschaut. (IMC Server mit remote mysql Server). Da ist das Feld leer. Das ist m.W. für eine redundante IMC Installation gedacht. Die läuft über Synchronisation mit dbman. Daher auch "Master ... Backup System".

Vielleicht sucht der dbman ja nach der zugehörigen Datenbank des Backupmasters. Die findet er dann aber nicht, da es ja gar keinen Backupmaster gibt.
Probier doch mal das autobackup aus, nachdem du die IP aus dem Feld "Master Server IP of Backup System" entfernt hast...

Sollte das dann immer noch nicht gehen, bleib ich bei meiner Empfehlung für eine TAC Case ;-)

Nochmal zum Update auf dem DB-Server:

Bei der Installation wird auf dem DB-Server ja auch der "Deployment und Monitoring Agent" installiert. Nach dem Update auf dem IMC Server musst Du nur den "DMA" auf dem Datenbankserver aufrufen. Der kümmert sich dann um das Update auf dem Datenbankserver. installslave sollte dazu nicht nötig sein.

Viele Grüße, Jörg

 

Please give kudos, if you like my post.
Please Accept as solution, if my post was helpful.
Contributor II

Re: IMC Backup-Probleme nach Update/Patch

Hi,

das mit dem "leer" lassen der IPÜ geht nicht. (siehe Anhang)

die "Master Server IP of Backup System" ist die IP, auf der das Backup abgespeichert werden soll.

Das ganze System läuft mehr oder weniger als Demo/Test bei uns. von daher diese Konfig. Sonst wäre das nicht so "clever" das Backup der DB auf dem SQL-Server abzulegen.

Aber vor dem Update ging es genau so.

Ich denke, nach dem nächsten Update wird es wieder gehen.

 

Was vielleicht auch noch eine Überlegung ist, auf einen anderen Server/system mal das installslave aufrufen und dort nur das backup abspeichern.

 

Thomas

 

Contributor II

Re: IMC Backup-Probleme nach Update/Patch

Hi,

das Backup der Datenbank wird ja bereits lokal auf dem Datenbankserver erzeugt.
Deine Konfiguration erzeugt also das Backup lokal auf dem DB-Server und kopiert das ganze dann nochmal "über Netzwerk" wiederum auf den Datenbankserver.

Schau mal in "HPE IMC Remote Database Backup (Windows) Configuration Examples:
https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c05162586
Kein Eintrag in "Master Server IP of Backup System".

Das Feld "Database Backup Pfad" taucht nur bei einer Remote Datenbank auf. Wenn die DB auf dem IMC Server mitläuft, dann gibt es das Feld nicht.
Da steht das lokale Backup Verzeichnis auf dem Datenbankserver drin. Mit dem Browse Button siehst Du die Verzeichnisse auf dem DB Server.
Ich benenne die Verzeichnisse auf den beiden Servern immer unterschiedlich (z.B. d:\imcbackup und d:\dbbackup). Dann erkennt man im Auswahlfeld daran, auf welchem Server das ausgewählte Verzeichnis liegt.

"Master Server IP of Backup System" ist für eine hochverfügbare Installation. Also zwei vollständige IMC Systeme. Das zweite läuft dann passiv mit. Die Daten werden über dbman synchronisiert. Auf dem zweiten System werden die dann mit Autorestore eingespielt.
Hat aber nix mit "normalem" Backup zu tun.

Vielleicht hat der alte dbman die Config ja ignoriert?

Gruß,

Jörg

Please give kudos, if you like my post.
Please Accept as solution, if my post was helpful.
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: