Developer Community

Reply
Highlighted

AOS-CX Ansible Role in Galaxy!

AOS-CX Ansible Role is now available for download in Ansible Galaxy! Roles are compatible with AOS-CX 10.3 release and allow to configure interfaces, vlans, Access-Control Lists and so much more!

Check out our AOS-CX Ansible Role on Galaxy today!

 

https://galaxy.ansible.com/arubanetworks/aoscx_role

 

Highlighted
Occasional Contributor I

Re: AOS-CX Ansible Role in Galaxy!

Hi Tiffany!

 

I am trying to test the Ansible module for CX in my lab with the 10.04 OVA, but I have a hard time to get the basic connection to work.

 

I installed a clean, new Ubuntu 18.04LTS host, followed the instructions of the other article (https://community.arubanetworks.com/t5/Developer-Community/How-to-Install-Ansible-and-Aruba-Ansible-Modules-on-Ubuntu-18-04/m-p/555488)

 

But when I try the basic L3 port or the vlan config example, the play shows an error. When I run it with the verbose option, I get this error output:

 

 

An exception occurred during task execution. To see the full traceback, use -vvv. The error was: AttributeError: 'NoneType' object has no attribute 'has_key'
fatal: [sw-access1]: FAILED! => {"changed": false, "module_stderr": "Traceback (most recent call last):\
  File \"/home/labadmin/.ansible/tmp/ansible-local-10451VX2f6D/ansible-tmp-1573554454.14-69301531100280/AnsiballZ_aoscx_vlan.py\", line 102, in <module>\n
    _ansiballz_main()
  File \"/home/labadmin/.ansible/tmp/ansible-local-10451VX2f6D/ansible-tmp-1573554454.14-69301531100280/AnsiballZ_aoscx_vlan.py\", line 94, in _ansiballz_main\n    
invoke_module(zipped_mod, temp_path, ANSIBALLZ_PARAMS)
  File \"/home/labadmin/.ansible/tmp/ansible-local-10451VX2f6D/ansible-tmp-1573554454.14-69301531100280/AnsiballZ_aoscx_vlan.py\", line 40, in invoke_module
    runpy.run_module(mod_name='ansible.modules.aoscx_vlan', init_globals=None, run_name='__main__', alter_sys=False)\n
  File \"/usr/lib/python2.7/runpy.py\", line 192, in run_module
    fname, loader, pkg_name)
  File \"/usr/lib/python2.7/runpy.py\", line 72, in _run_code
    exec code in run_globals
  File \"/tmp/ansible_aoscx_vlan_payload_CU2cXY/ansible_aoscx_vlan_payload.zip/ansible/modules/aoscx_vlan.py\", line 146, in <module>
  File \"/tmp/ansible_aoscx_vlan_payload_CU2cXY/ansible_aoscx_vlan_payload.zip/ansible/modules/aoscx_vlan.py\", line 106, in main
  File \"/tmp/ansible_aoscx_vlan_payload_CU2cXY/ansible_aoscx_vlan_payload.zip/ansible/module_utils/aoscx_vlan.py\", line 29, in create_vlan
AttributeError: 'NoneType' object has no attribute 'has_key'
", "module_stdout": "", "msg": "MODULE FAILURE
See stdout/stderr for the exact error", "rc": 1}

 

I ran a tcpdump and ansible is not even attempting to connect to the target system, so something seems wrong with my local installation.

 

I downloaded the cx role from Ansible Galaxy.

 

Any clues on what I'm missing?

 

 

 

 

 

 

 

Highlighted
MVP Guru Elite

Re: AOS-CX Ansible Role in Galaxy!

Hi Peter,

 

I think, it will be better to open a new topic for this

look a issue when install the role, do you have try to reinstall ?



PowerArubaSW: Powershell Module to use Aruba Switch API for Vlan, VlanPorts, LACP, LLDP... More info

PowerArubaCP: Powershell Module to use ClearPass API (create NAD, Guest...) More info

PowerArubaCX: Powershell Module to use ArubaCX API (get interface/vlan/ports info)

PowerArubaIAP: Powershell Module to use Aruba Instant AP

PowerArubaMC: Powershell Module to use Mobility Controller / Master


ACMP 6.4 / ACMX #107 / ACCP 6.5 / ACSP
Highlighted
Occasional Contributor I

Re: AOS-CX Ansible Role in Galaxy!

ok, I will make a new topic, thank you.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: