Higher Education

Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.
Frequent Contributor I

Re: Yosemite roaming issues

We are also seeing some odd roaming issues.  Usually restarting the machine causes the device to connect immediately.   The odd thing is we are not even seeing anything in our logs when the issues appear.  Because we are not seeing anything in the aruba logs we are thinking this must be driver related issues with the latest OSx.  We are seeing most of our issues on devices manufactured before 2013.

Contributor II

Re: Yosemite roaming issues

Looks to be the authentication chain delays again, just like in early Mavericks. 

 

Head into Keychain, go to Certificates, then open each certificate in the chain and set the Extensible Authentication (EAP) to "Always Trust". 

 

If this works for you, please post up here. 

Contributor II

Re: Yosemite roaming issues

Changing the Keychain trust settings doesn't seem to work, even with 10.10.1. Back to the drawing board.....

Contributor I

Re: Yosemite roaming issues

I would like to confirm what theiglu shared just now, that 10.10.1 does not seem to address the roaming issue.

Contributor II

Re: Yosemite roaming issues

Confirmed that without changing any trust settings in the certificate chain in Keychain, it takes between 10 to 17 seconds to reconnect when roaming. 

 

Just now I set the entire certificates to "Always Trust", not just EAP, and I have less than a second delay on roaming. Will continue to experiment and post results here. 

 

The students in the library are starting to be confused by the IT guy walking back and forth across the large room over and over while staring at a computer......

New Contributor

Re: Yosemite roaming issues

Can you get ahold of one of these MACs running Yosemite and connect it to the wireless; then start a packet capture using wireshark on the wireless interface and filter by eap. Once the capture is started, just do a quick walk around with the device so we can see what it looks like when it is trying to roam.

Contributor II

Re: Yosemite roaming issues

Will do, just finishing backtracking my Keychain settings. 

 

Right now, I have both the Thawte SSL CA and Thawte Primary Root CA set back to "System Default" on the trust settings. Roaming is still within a second. The only certificate that isn't on default system settings is our internal NPS server certificates for 802.1X. That is still set to "Always Trust" for the entire certificate. I'll start narrowing down the individual trust settings in there to see which one is the holdup. I've already tried EAP last time. Apparently that wasn't it. 

 

This was a clean load of 10.10.1 as of yesterday, no other modifications. 

New Contributor

Re: Yosemite roaming issues

Ive had pretty good luck setting SSL, EAP, and X.509 to always trust, re-auth times according to wireshark are always under a second, completley un-noticeable unless you are looking at wireshark when you roam.

Contributor II

Re: Yosemite roaming issues

Removed all custom settings from Keychain. Tried to roam, still quick and working properly. Rebooted hoping to get it back to a failure state. No luck. Removed all Wifi SSID profiles, removed all entries and certificates from Keychain, reconnected fresh. Still no issue roaming. 

 

Will wipe the machine again and start fresh with a 10.10.1 clean install. 

 

Very difficult to troubleshoot something if you can't duplicate the problem.

Frequent Contributor I

Re: Yosemite roaming issues

I would be interested to see anything in a log on this issue.  I have set a handful of our problem machines running 10.10.x and when they are having roaming issues the wifi cards are not sending any packets and or communicating at all with the aruba gear...

 

The fact that turning off and on the wifi adapter fixes the problem instantly leaves me to believe that it is a software/driver issue...

 

That being said - we have ONLY seen this issue on MacBook Pro devices (2012, 2013, and the latest models) seem to have this issue atleast once a day.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: