Reply
New Contributor

IAP-325 Beaconing APB: Disabled

Hi

 

I have a problem with an IAP-325 apparently I have everything well configured but for some reason I can not see the beacon and when I execute the debug commands I only realize that the beacon is off or does not appear.

 

What I have noticed is that side of the state of beaconing in the configuration appears (APB: disabled), does anyone know what this refers to or what I have to do?

 

Output of debug commands:

 


*********************************************************************************************************
5/15/2018 13:39:16 PM Target: PruebaAP Command: show ble-config
*********************************************************************************************************

BLE Configuration
-----------------
Item Value
---- -----
Authorization Token eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJsIjo1NjUyMjA0OTc0MjQzODQwLCJ0IjoxNTI1OTY3NzMwfQ.AIhgzGzwunzwfkznlwFlDovtJGSWqBoH6eeC8Fc3Bv0
Endpoint URL https://edit.meridianapps.com/api/beacons/manage
Update Intvl (in sec) 600
Operational Mode beaconing
Mgmt Server
Mgmt Handshake Server
Mgmt Handshake Token
Mgmt Location Id

*********************************************************************************************************
5/15/2018 13:38:12 PM Target: PruebaAP Command: show ap debug ble-connect
*********************************************************************************************************
* About to connect() to edit.meridianapps.com port 443 (#0)
* Trying 216.58.193.51...
* Connected to edit.meridianapps.com (216.58.193.51) port 443 (#0)
* Connected to edit.meridianapps.com (216.58.193.51) port 443 (#0)
* successfully set certificate verify locations:
* CAfile: /etc/pki/tls/certs/ca-bundle.crt
CApath: none
* CyaSSL: Connecting to edit.meridianapps.com:443
* CyaSSL: Connecting to edit.meridianapps.com:443
* CyaSSL: Connecting to edit.meridianapps.com:443
* SSL connected
> POST /api/beacons/manage HTTP/1.1

Host: edit.meridianapps.com

Content-Type: application/json

Authorization: MERIDIAN eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJsIjo1NjUyMjA0OTc0MjQzODQwLCJ0IjoxNTI1OTY3NzMwfQ.AIhgzGzwunzwfkznlwFlDovtJGSWqBoH6eeC8Fc3Bv0

Accept: application/vnd.meridian.v1+json

Content-Length: 225

 

* upload completely sent off: 225 out of 225 bytes
< HTTP/1.1 200 OK

< Content-Language: en

< Vary: Accept, Accept-Language, Cookie

< ETag: "dc4e217787010f5fd69fdc6d3f0d3631"

< Allow: POST, OPTIONS

< Access-Control-Allow-Credentials: false

< Access-Control-Allow-Origin: *

< Content-Type: application/json; application/vnd.meridian.v1+json;

< X-Meridian-Media-Type: version=v1

< X-Cloud-Trace-Context: 02e93c83d1288a87cb3c504e7cc083ac

< Date: Tue, 15 May 2018 19:19:01 GMT

< Server: Google Frontend

< Content-Length: 32

<

* Connection #0 to host edit.meridianapps.com left intact


*********************************************************************************************************
5/15/2018 13:36:48 PM Target: PruebaAP Command: show ap debug ble-config
*********************************************************************************************************

BLE Configuration
-----------------
Item Value
---- -----
BLE Supported ONBOARD
BLE HW Type BT-AP320
Master IP 192.168.1.180
Authorization Token eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJsIjo1NjUyMjA0OTc0MjQzODQwLCJ0IjoxNTI1OTY3NzMwfQ.AIhgzGzwunzwfkznlwFlDovtJGSWqBoH6eeC8Fc3Bv0
Endpoint URL https://edit.meridianapps.com/api/beacons/manage
BLE Ready Yes
Beacon Mgmt Update Intvl (in sec) 600
APB Info Update Intvl (in sec) 362 (1532/1503)
BLE debug log Enabled
Operational Mode Beaconing (APB: Disabled)
Message Selector 0xffff (APB: 0x0)
AP USB Power Override Disabled (-1)
Uplink Status Up (APB: -NA-)
APB Connection Status 0
Last BLE Device Update Attempted 00:00:00:00:00:00
Last AP to APB Message Time 1970-01-01 00:00:00
Last Update to Endpoint Time 2018-05-15 19:19:00
Log Levels Available { All(0xffff), Info(0x04), Warning(0x02), Error(0x01), Ageout(0x08), BMReq(0x10), FW-Upgrade(0x20), FW-UpgradeErr(0x40), CfgUpdate(0x80), CfgUpdateErr(0x100), Beacon(0x200), BcnTLV(0x400), BcnErr(0x800), APB(0x1000), AssetUpdate(0x2000), None(0x00) }
Current Log Level { 0x1e1 : Error(0x0001), FW-Upgrade(0x0020), FW-UpgradeErr(0x0040), CfgUpdate(0x0080), CfgUpdateErr(0x0100) }
Log Mac Filter None
Bundled BluOS Images Bank A(/aruba/bin/UpgradeImage_AP_OAD-A_1.2-19.bin) Bank B(/aruba/bin/Beacon_AP_OAD-B_1.2-19.bin)
-----------------
Note: Uplink status is applicable only for Controller with Dynamic Console operational mode.
For APBs of type LS-BT1USB, applied operational mode is Beaconing if ap system profile setting is either Persistent or Dynamic.
Note: Setting Message Selector value to 0x0 will cause the APB to function improperly. Use the knob with caution.
Note: Message Selector Bits: All(0xffff), V0 Scan (0x01), V1 Scan (0x02), UI Scan (0x04), Proximity Advert (0x08), IBeacon (0x10), Heartbeat-1 (0x20), Heartbeat-UI (0x40), Upg Ack (0x80), Heartbeat-2 (0x200), Generic Scan (0x400), Generic Advert (0x800), Tag V1 Scan (0x1000), Tag V1 Advert (0x2000)

*********************************************************************************************************
5/15/2018 13:36:31 PM Target: PruebaAP Command: show ap debug ble-table all
*********************************************************************************************************


Total BLE devices:0

Note: Battery level for LS-BT1USB devices is indicated as USB.
Note: Uptime is shown as Days hour:minute:second.
Note: Last Update is time in seconds since last heard update.
Status Flags:L:AP's local beacon; I:iBeacon; A:Beacon management capable
:H:High power beacon; T:Asset Tag Beacon; U:Upgrade of firmware pending

 

 

Re: IAP-325 Beaconing APB: Disabled

What exactly are your trying to achieve? The AP Beacon (APB) can be used as a location/proximity beacon, for asset tracking, for beacon management of battery beacons or as a wireless console port.

 

 

The beacon is disabled by default (at least in the firmware I tried), and can be enabled under More -> Services -> RTLS -> Aruba:

Screen Shot 2018-05-16 at 3.50.17 PM.png

If you put it to Beaconing, it will be enabled with a delay of about 10-15 seconds, and you should see the beacon up:

ac:a3:1e:cd:47:2c# show ap debug ble-config

BLE Configuration
-----------------
Item                               Value
----                               -----
BLE Supported                      ONBOARD
BLE HW Type                        BT-AP320
....
Operational Mode                   Beaconing (APB: Beaconing)
--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).
New Contributor

Re: IAP-325 Beaconing APB: Disabled

Hi Herman

 

thanks for your answer, actually if I know everything you mention, I want to use it for location but as you can see in the post, the beacon despite having it in beaconing does not turn on for some strange reason.

I have installed more than 200 beacons on AP, USB or battery and it is the first time this happens to me with an AP 325 beacon.

 

normally in the output of the command  "show ap debug ble-config" it appears like this:

Operational Mode                   Beaconing (APB: Beaconing)

 

but in this case it appears like this:

 

Operational Mode                   Beaconing (APB: Disabled)

 

already probe it in IAP mode and in CAP mode, the result is the same.

 

Regards

Frequent Contributor II

Re: IAP-325 Beaconing APB: Disabled

Hi,

 

same issue overhere, did you found a solution? or is the AP broken?

 

Kind regards,

Thomas

Thomas
ACMX#370 ACCX#1000 ACDX#1071 AMFX#74

-- Found something helpful, important, or cool? Click the Kudos Star in a post.
-- Problem Solved? Click "Accept as Solution" in a post.
Occasional Contributor I

Re: IAP-325 Beaconing APB: Disabled

Hi,

 

Finally, the AP was broken... TAC team sent me another AP after 4-5 hours of supports to try make it work again... 

Question: Before your AP beacon stop working, did you've swipe out the AP beacon outside of the map while you try to configure it in the Aruba Beacon App (Manipulation error) ? 

 

Cheer's,

 

Simon Rousseau

Frequent Contributor II

Re: IAP-325 Beaconing APB: Disabled

They never appeared in the meridian editor.

 

I will initiate an RMA

 

Kind regards,

Thomas

Thomas
ACMX#370 ACCX#1000 ACDX#1071 AMFX#74

-- Found something helpful, important, or cool? Click the Kudos Star in a post.
-- Problem Solved? Click "Accept as Solution" in a post.
Occasional Contributor I

Re: IAP-325 Beaconing APB: Disabled

Hi Thomas,

 

The support team will certainly be able to help you solve your case.

 

P.S. I'm pretty sure you already know this... but, just in case:  you should configure your AP beacons throught the Aruba Beacon mobile app before it will appear in the meridian web editor.

Simon Rousseau
simon@rioh.io

Frequent Contributor II

Re: IAP-325 Beaconing APB: Disabled

Indeed, but of all my APs configured (+40) only 2 are not working, and even not seen on https://edit.meridianapps.com while other are just apearing in the online meridian portal when I have configured my meridian settings on the controller side.

 

Thanks anyway, I will open a ticket with TAC

Thomas
ACMX#370 ACCX#1000 ACDX#1071 AMFX#74

-- Found something helpful, important, or cool? Click the Kudos Star in a post.
-- Problem Solved? Click "Accept as Solution" in a post.
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: