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Articles relating to existing and legacy HPE Aruba Networking products and solutions including AirWave, Meridian Apps, ALE, Central / HPE Aruba Networking Central, and UXI / HPE Aruba Networking User Experience Insight

Airwave - Users unable to login 

Jun 01, 2014 10:58 PM

Symptoms

Airwave users unable to login to GUI

 

Apache::AuthCookie allows you to intercept a user's first unauthenticated access to a protected document. The user will be presented with a custom form where they can enter authentication credentials. The credentials are posted to the server where AuthCookie verifies them and returns a session key.
The session key is returned to the user's browser as a cookie. As a cookie, the browser will pass the session key on every subsequent accesses. AuthCookie will verify the session key and re-authenticate the user.

AMP works on Linux Platform where it uses postgresql DB to store user's information. So if AMP's DB is not responding to Apache AuthCookie then also we could see the error of user not getting authenticated. There could be various reasons for DB issue. For example:

If the AMP restore did not complete successfully then either all the services keep on restarting or there could be postmaster crash issues. These crashes will cause auth failure for AMP users.

Diagnosis

The following error message is visible in the error log under httpd directory.


AuthCookieHandler could not authenticate: ERROR:  column t1.send_interferers_to_vrf does not exist
LINE 1: ..._sec_secret,t1.syslog_expiration,t1.ldap_pri_port,t1.send_in...
 

Solution

To resolve this issue we need to re-compile the code by running a make.
Run the command 
#make 

and then update the kernel version if prompted and then access the GUI with user credentials.

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