Network Management

Reply
Highlighted
Contributor I

Adding 2930 Switch to AMP

 

Attempted adding Aruba 2930 to AMP using default v2c and it failed the first time.  Then, I added SNMP v3 community, user, and enabled SNMPv3 and it failed using those same creds on AMP.  Then, I tried the same using SNMPv2c with a community and got the same result.  I have tried every combination of using telnet/ssh, community, and user fields and always get an "SNMP get failed".

 

I was able to add CPPM to AMP just fine though, but not 2930 switches.

 

I want to start from scratch now. 

What specific config on the 2930 needs to be configured?  ,,,AND ...

What specific config on AMP needs to be configured on the DEVICE--> ADD page (ssh ? community ? user ?)

 

NOTE:  Using latest version of AMP from Dec-2019 which is 8.2.X

NOTE:  Aruba 2930F switch sh version info below:

# sh version
...

                Nov  1 2019 19:24:11
                WC.16.10.0002
                208
Boot Image:     Primary

Boot ROM Version:    WC.16.01.0008
Active Boot ROM:     Primary

 

 


Accepted Solutions
Highlighted
MVP Guru

Re: Adding 2930 Switch to AMP

For reference, here is my relevant SNMPv3 configuration:

timesync ntp
ntp unicast
ntp server 192.168.2.1 iburst
ntp enable

snmpv3 enable
snmpv3 only
snmpv3 restricted-access
snmpv3 group managerpriv user "airwave" sec-model ver3
snmpv3 group managerpriv user "clearpass" sec-model ver3
snmpv3 targetaddress "traphost.airwave.192.168.32.24" params "traphost.airwave.192.168.32.24" 192.168.32.24 taglist "TrapHost"
snmpv3 params "traphost.airwave.192.168.32.24" user "airwave" sec-model ver3 message-processing ver3 priv
snmpv3 user "airwave" auth sha "auth-removed" priv aes "priv-removed"
snmpv3 user "clearpass" auth sha "auth-removed" priv aes "priv-removed"

One important thing is that for SNMPv3, the time on the switch (and polling device/Airwave) should be synchronized.

 

If you can't make the poll work from Airwave at first, try an smtpwalk (or similar) from another device first to verify the switch configuration.

snmpwalk -v 3 -l authPriv -a SHA -A *auth-removed* -u airwave -x AES -X *priv-removed* -O b 192.168.31.1
--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).

View solution in original post

Highlighted
Contributor I

Re: Adding 2930 Switch to AMP

We had another team member configure the 2930 switches for SNTP and not NTP.  After we saw this, I removed SNTP and added those 4 NTP commands on the 2930 switches.  This fixed the issue and allowed AMP to discover all the 2930 switches.

 

Thanks

View solution in original post


All Replies
Highlighted
MVP Expert

Re: Adding 2930 Switch to AMP

Default Airwave uses snmpv2 protocol, if you want to use SNMPv3 then you need to change protocol version under Groups>Basic>Aruba > SNMP Version section.

 

We need to add device from Devices>Add page and provide IP address and community string , if you want to monitor using snmpv2, else need to provide snmv3 user details and protocols and change version in group>basic page to V3


Pavan Arshewar | ACCP

If my post address your queries, give kudos and accept as solution!
NOTE: Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba or Hewlett Packard Enterprise.
Highlighted
MVP Guru

Re: Adding 2930 Switch to AMP

For reference, here is my relevant SNMPv3 configuration:

timesync ntp
ntp unicast
ntp server 192.168.2.1 iburst
ntp enable

snmpv3 enable
snmpv3 only
snmpv3 restricted-access
snmpv3 group managerpriv user "airwave" sec-model ver3
snmpv3 group managerpriv user "clearpass" sec-model ver3
snmpv3 targetaddress "traphost.airwave.192.168.32.24" params "traphost.airwave.192.168.32.24" 192.168.32.24 taglist "TrapHost"
snmpv3 params "traphost.airwave.192.168.32.24" user "airwave" sec-model ver3 message-processing ver3 priv
snmpv3 user "airwave" auth sha "auth-removed" priv aes "priv-removed"
snmpv3 user "clearpass" auth sha "auth-removed" priv aes "priv-removed"

One important thing is that for SNMPv3, the time on the switch (and polling device/Airwave) should be synchronized.

 

If you can't make the poll work from Airwave at first, try an smtpwalk (or similar) from another device first to verify the switch configuration.

snmpwalk -v 3 -l authPriv -a SHA -A *auth-removed* -u airwave -x AES -X *priv-removed* -O b 192.168.31.1
--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).

View solution in original post

Highlighted
Contributor I

Re: Adding 2930 Switch to AMP

I didn't have the 'target address' and 'params' config on the switch; I will have to check NTP also.  Thanks for the suggestions.  I will try these config options and reply to this thread again with results.

Highlighted
MVP Guru

Re: Adding 2930 Switch to AMP

The target host and params line (I believe) are for sending SNMP Traps to Airwave. I don't think that is required for monitoring, but it won't hurt.

--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).
Highlighted
New Contributor

Re: Adding 2930 Switch to AMP

od to know this.

Highlighted
Contributor I

Re: Adding 2930 Switch to AMP

We had another team member configure the 2930 switches for SNTP and not NTP.  After we saw this, I removed SNTP and added those 4 NTP commands on the 2930 switches.  This fixed the issue and allowed AMP to discover all the 2930 switches.

 

Thanks

View solution in original post

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: