Network Management

Reply
Contributor I

AirWave wont verify configuration on switches

I currently use AirWave to manage about 500 IAPs. I am now looking into using it to manage switch configuration/firmware and have added a few switches to test. I added HP2530-8P and HP2530-24P groups and folders. I then added a test switch with our standard configuration using the "amp-server" command and used it's config to make a template for each group. Only 1 of the 6 I have tried adding after the initial switch will actually verify the configuration. They check-in with AirWave but just stay as "Unknown" for the configuration. 


I see that the switches themselves often have logs showing the AirWave server entering an incorrect username/password despite all our switches having the same login credentials. The AirWave server log shows that the SSH timed out. I have upped the SSH timeout setting in AirWave to the max 120 seconds and still nothing. 

 

There are slight revision differences between the switches (part of why I am adding them) so I found other switches with the same version as the working ones and was still not able get the ssh connected. I changed the default SSH credentials for Aruba Switches in Device Setup > Communication and re-added deleted/re-added the switches. Still nothing. 

 

I see on the successful switches that the AirWave system logs in, and enters the following commands:

 

console local-terminal none
session interactive-mode disable
terminal width 1920
include-credentials

 

Any ideas as to what is going wrong here?

 

Frequent Contributor II

Re: AirWave wont verify configuration on switches

Hello,

 

what is the version number that is working and not working? if amp itself is unable to ssh to the switch, are the ssh creds same for all the switches or could they be different? could you manaully try ssh into the switch using putty or some other ssh client, check if the login credentials work? once confirmed, update the same creds on the manage page of this switch in question on Airwave? 

 

 

--

-If you got what you need with my answer please give kudos and mark it as solution.
Contributor I

Re: AirWave wont verify configuration on switches

Thanks for the reply. Both working switches are on YA.16.05.0008 but there are other switches on the same version that don't work. I can SSH to the device with the same credentials, and can also SSH to the device from AirWave if I do it manually from the Monitor page. All our 2530 switches have the same credentials and I have logged into all the ones I have tried to load.

Highlighted
Contributor I

Re: AirWave wont verify configuration on switches

Seems like the issue stemmed from the banner we had. That was the only difference I could find between working and non-working. The working ones had no banner. Once I removed the banner they seemed to load fine. I think it was because we used the '%' symbol as our delimiter which is the same as the variables in the configuration. Not sure why that would cause an SSH issue, I would think it would still be able to successfully login. 

Occasional Contributor I

Re: AirWave wont verify configuration on switches

Hi , what is Airwave version ? Yes we had issues in getting configuration if banner is set. And we have fixed that issue in 8.2.9.0 release. Could you please upgrade your Airwave and provide the feedback

 

New Contributor

Re: AirWave wont verify configuration on switches

we have the same issue, and we are on version 8.2.9.1

Frequent Contributor I

Re: AirWave wont verify configuration on switches

MOTD banner issue on switch is actually fixed in Airwave 8.2.10 version. For Airwave 8.2.9, there's apatch to fix the issue. Please work with TAC for the patch to be applied on the server or upgrade to 8.2.10 which has the fix.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: