Network Management

New Contributor

Airwave 7.7.12 and RHEL 6.5

There is a RHEL 6.5 server and we are trying to install the Airwave OS, but getting an error

WARNING: enabling "trust" authentication for local connections You can change this by editing pg_hba.conf or using the option -A, or --auth-local and --auth-host, the next time you run initdb.

Success. You can now start the database server using:

/opt/airwave/pgsql-9.2/bin/postgres -D /var/lib/pgsql/9.2/data or
/opt/airwave/pgsql-9.2/bin/pg_ctl -D /var/lib/pgsql/9.2/data -l logfile start

Starting postgresql service: [ OK ]
Stopping postgresql service: [ OK ]
Postgres didn't seem to start up. at ./upgrade_postgres_92 line 71.
make[2]: *** [postgresql] Error 3
make[2]: Leaving directory `/root/svn/mercury/src'
make[1]: *** [src_install] Error 2
make[1]: Leaving directory `/root/svn/mercury'
make: *** [install] Error 2


Tried manually restarting postgresql and it did not help.

Tried running the below command and it did not work.

[root@airwave ~]# /opt/airwave/pgsql-9.2/bin/pg_ctl -D /var/lib/pgsql/9.2/data -l logfile start
pg_ctl: cannot be run as root
Please log in (using, e.g., "su") as the (unprivileged) user that will own the server process.
[root@airwave ~]#

Also, tried logging in as “su postgres” and ran the below command and it did not work.

# /opt/airwave/pgsql-9.2/bin/postgres -D /var/lib/pgsql/9.2/data


Currently we are reinstalling the RHEL server, but would like to know if there is any fix if we run into trouble again



Guru Elite

Re: Airwave 7.7.12 and RHEL 6.5

If you must install Airwave separately on RedHat instead of using the combined installer, please work with TAC to determine your specific issue.


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
New Contributor

Re: Airwave 7.7.12 and RHEL 6.5

Yes we did call Aruba TAC 

And their escalation team installed couple of security updates to install the Airwave 7.7.12 on RHEL6.5





Search Airheads
Showing results for 
Search instead for 
Did you mean: