Network Management

Reply
Contributor I

Amp CLI upgrade not working to 8.2.7.1

I am currently on Amp 8.2.4.1 and went into the CLi to upgrade and I keep getting an error that I am not understanding, can someone help me out here?

 

Enter your Aruba Support Portal password:
curl: (60) Peer certificate cannot be authenticated with known CA certificates
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn't adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
the -k (or --insecure) option.
If your firewall restricts direct HTTP communication to
the internet, it is possible to use a HTTP proxy server.
Enter the proxy details when prompted.

Hit enter to continue, 's' to show output, 'r' to show return code.
r
Error, return code: 888

 

Highlighted
Contributor I

Re: Amp CLI upgrade not working to 8.2.7.1

Also I tried 8.2.6 from the release notes and that shows same error

MVP Expert

Re: Amp CLI upgrade not working to 8.2.7.1

Looks like some certificate issue which is not letting it trust. I would suggest opening a TAC case, so that they can check it.
Also, you can try the offline upgrade as a workaround.

Regards,
Vishnu
If my post helped you, don't forget to give kudos ;)
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: