Network Management

Reply
Occasional Contributor II

Globa setting for telnet / ssh credentials

New to Airwave. I am currently using it to monitor my HP / Aruba switches. as I have started to bring in my locations switches into thier repective groups I am getting a lot of mismatch alerts. the majortiy of them complaining about this. "Error(Telnet/SSH Error: No username specified) " I would prefer to not enter this information in per error / switch. Where can I set this globally please? Thanks.

Guru Elite

Re: Globa setting for telnet / ssh credentials

Device Setup> Communication> Aruba> Edit.


*Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba Networks or Hewlett Packard Enterprise.*
ArubaOS 8.3 User Guide
InstantOS 8.3 User Guide
Airheads Knowledgebase
Airheads Learning Videos
Occasional Contributor II

Re: Globa setting for telnet / ssh credentials

I'm sorry. I forgot to mention that I had already done that. It seems to be being ignored. So I thought there may be somewhere else to do it. I am on 8.2.6.1

Moderator

Re: Globa setting for telnet / ssh credentials

The Device Setup -> Communications page is used when you first add the device (either manually or through discovery).  If the devices are already added, then you need to bulk edit from the Devices list view.

 

 

go to Devices list

create a view that shows only the devices with Config = Error

click the pencil at the top right of the list table to get bulk edit options

1.jpg

check all the devices that need updating

2.jpg

from the Device actions drop down, select "Update the credentials used to communicate with these devices", click update

3.jpg

it should take you to a view that prompts for the creds, input creds and click update

4.jpg

 

it'll then take you to a confirmation page, apply changes now

5.jpg

 

 


Rob Gin
Senior QA Engineer - Network Services
Aruba Networks, a Hewlett Packard Enterprise Company
Occasional Contributor II

Re: Globa setting for telnet / ssh credentials

I did this already to fix the ones that were already wrong. What I am looking for is to not to have to do this in the future as I add more switches to the system. Thanks.

Moderator

Re: Globa setting for telnet / ssh credentials

New switches should observe the Device Setup -> Communication settings - unless you type something else in the fields at time of adding.


Rob Gin
Senior QA Engineer - Network Services
Aruba Networks, a Hewlett Packard Enterprise Company
Occasional Contributor II

Re: Globa setting for telnet / ssh credentials

presuming that this is the correct one for HP Procurve / HP Aruba switches I have already set that. device setup/communication/Aruba I had also done the same for the HPE  just to cover my bases.

 

Moderator

Re: Globa setting for telnet / ssh credentials

It depends on which switch models, there's several categories under Device Setup -> Communication for various Aruba / HPE models:

 

Aruba (covers general Aruba branded)

Aruba MAS

ArubaOS Switch

ArubaOS-CX Switch

HPE (covers general HPE branded)

HPE OfficeConnect Switch

 

I've also filed a few defects to simplify this, and to address that there's not a 1-1 mapping between Device Setup -> Add selection vs Device Setup -> Communication options.


Rob Gin
Senior QA Engineer - Network Services
Aruba Networks, a Hewlett Packard Enterprise Company
Occasional Contributor II

Re: Globa setting for telnet / ssh credentials

So I shotgunned it and did all the ones you listed:) One of those fixed it. I just pulled in another school of 23 switches with no SSL credentials issue. Thanks!

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: