Network Management

MVP Expert

Re: HPE switches and AIrwave

Hi ,


Try add it as HPE switch, in drop down list we have option to select as HPE.




Pavan Arshewar | ACCP

If my post address your queries, give kudos and accept as solution!
NOTE: Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba or Hewlett Packard Enterprise.
Frequent Contributor I

Re: HPE switches and AIrwave



I would like to ask a related question. I am running AMP 8.2.7 and I want to manage an Aruba 2930F switch with WC.16.05.0007 version. I have set the following command on the switch (like the first person said):

amp-server ip <AMP server IP address> group aruba_switches folder aruba_switches secret secret


Then I added the switch manually under Device setup->add. I added it as Aruba device. Then I set the IP adress of the switch and the host name. In the community string I typed the "secret".


Then my switch comes up in down state, and has a "Status: Down (SNMP get failed) ".


Also getting the following log in the switch:

I 08/31/18 13:13:46 05103 amp-server: Default, Primary or Management VLAN is not configured with IP or DHCP.
W 08/31/18 13:13:38 00236 snmp: Security access violation from <AMP server IP address> for the community name or user name : secret (8 times in 60 seconds)


What am I missing?


I also tried to create snmpv3 user and setting that in the "manage" tab, but with no luck.


The only way I could get the switch to communicate with AMP is when I do a ZTP with Activate. Then the switch comes up to AMP, but when I change the IP adress to static (because it has a DHCP IP because of the ZTP) then the switch stops communicating and gives me a Status: Down (SNMP get failed) message again.


If someone has any idea please share.



Frequent Contributor I

Re: HPE switches and AIrwave

And on more thing, if I add it as custom device, it immediately comes up as "UP" in AMP.


So I am thinking it is not coming up because a wrong device selection, but I didn't find any "aruba switch" selection when I add it manually. I also tried adding it as HPE type switch but failed.




Re: HPE switches and AIrwave

I see you're trying to do SNMPv3 -> make sure the Group - select group - Basic tab is set to use SNMPv3 to communicate with the device.


Also, make use of this guide for testing SNMP communication

Rob Gin
Senior QA Engineer - Network Services
Aruba Networks, a Hewlett Packard Enterprise Company
Aruba Employee

Re: HPE switches and AIrwave



Did you by any chance try the following command (on the switch):


snmp-server response-source dst-ip-of-request


Better late than never!


Kindly share the solution if you have already found it!

New Contributor

Re: HPE switches and AIrwave

For me, to solved the "Default, Primary or Management VLAN is not configured with IP or DHCP." problem. I had to change my primary vlan from the default of 1 to 253 because we use 253 for our switch management IP. The command was: primary-vlan 253


Then the debug ztp output showed:


0000:00:38:57.68 ZTP mairwaveCtrl:Received message 0x910001
0000:00:38:57.68 ZTP mairwaveCtrl:Default, Primary or Management VLAN is configured with IP or DHCP
0000:00:38:57.68 ZTP mairwaveCtrl:AMP server registration started.
0000:00:38:57.68 ZTP mairwaveCtrl:IPSEC ZTP: No amp type vpn, Check-in to Airwave
0000:00:38:57.68 ZTP mairwaveCtrl:sending request to
0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Type: Device-Reg
0000:00:38:57.68 ZTP mairwaveCtrl:Added X-OEM: HP
0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Mode: SWITCH
0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Current-Version: WC.16.09.0004_786
0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Device-Info: TW94HKZ2LL,
38:21:C7:BA:5C:F0, 2930F-8G-PoE+-2SFP+ Switch
0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Group: Kitchener
0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Folder: Kitchener
0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Shared-Secret: d2l-kit-switches
0000:00:38:57.68 ZTP mairwaveCtrl:Added X-Device-State: Non-factory
0000:00:38:59.53 ZTP mairwaveCtrl:Switch registered Sucessfully 0 - HTTP/1.1 200 OK


Cheers, Mark W.

Search Airheads
Showing results for 
Search instead for 
Did you mean: