Network Management

Reply
Occasional Contributor I

IP Routing - InterVlan not working - One Switch

Hi Guys,

 

Could you please help!!

 

I have a new 2930F switch and I’m unable to get interVlan communication working, I have enabled IP Routing :)

 

I have a client machine plugged into port 8, with the following IP setting:

IP: 192.168.152.25

Sub: 255.255.255.0

Gateway: 192.168.152.254

 

Other Client machine plugged into port 11, with the following IP settings:

IP: 192.168.153.25

Sub: 255.255.255.0

Gateway: 192.168.153.254

 

I can ping both IP gateways and clients from the CLI but the two clients are unable to ping the others gateway or client IP.

 

Each client can ping their own IP range Gateways (VLAN interface).

 

Please see attached config

 

 

 

 

 

Re: IP Routing - InterVlan not working - One Switch

Hi,

JayBee

It depends where is your gateway defined.

If your switch is acting as gateway for both subnets, it can route traffic between the,

If switch is configured as a Layer 2 device and firewall is your gateway for clients, routing has to be done on firewall.

 

IP default-gateway is only for the switch itself, so let's say management traffic. For all other traffic, you have IP routing. When no dynamic routing protocol configured this will be directly connected routes in combination with static routes. Hope this makes it clear.

 

*Be sure also to disable firewalls on WIN10 PC'S while checking ICMP between stations on diffrent/or same VLAN.

*****************2Plus Wireless Solutions****************************
Aruba Airheads - Powered By community for empower the community
************ Don't Forget to Kudos + me,If i helped you******************
Occasional Contributor I

Re: IP Routing - InterVlan not working - One Switch

Hi,

As you can see the gateway is my Layer 3 switch on my Clients IP settings.
Windows firewall and A/V has been disabled.

I have no router/firewall attached to this environment, I would like the layer 3 switch to route traffic between vlans.

Regards,

New Contributor

Re: IP Routing - InterVlan not working - One Switch

Hi,

 

Your switch configuration looks fine. Can you reconfirm the subnet & gateway IP addresses on both PCs?

 

Contributor II

Re: IP Routing - InterVlan not working - One Switch

I agree, the configuration here looks OK at the switch level. It's nice and simple.

 

I can't think of anything else that could be an issue other than client configuration. Each client with the correct gateway address should be able to configure the other subnets gateway address at a minimum and without any filtering on the client end then pinging between clients should succeed.

Occasional Contributor I

Re: IP Routing - InterVlan not working - One Switch

Hi Guys,

 

I was doing the configuration on the Switch remotely and I had x2 connections one via WiFi (working network - for internet access) the other on the switch Range (Local LAN)... after 2 days of trouble-shooting I released the WiFi connection was taking preference over the LAN (Tracert pointed it out). So when trying to access the other VLAN range the WiFi metric took preference and routed over the wrong network ☹

 

Once I disconnected the WiFi adapter everything worked as expected, could not believe I didn’t think of that!!!

 

Thanks for the advice and assistance, but it was just a blond moment!

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: