Network Management

Reply
Highlighted
MVP

Upgrade 8.2.9.0 > 8.2.10.0 Fails - Can't Login

Hi,

 

Basically I am trying to upgrade Airwave from 8.2.9.0 to 8.2.10.0

 

When upgrading I upload the new file start the upgrade and the process starts as normal as shown in the screenshot below:

 

Upgrade failure.png

It sits on the above message for a very long time before seeming to break out to the login screen again.  I can no longer log in with my CLI admin username and password - when browsing to the webpage itself it says scheduled for maintence.  I have restored the checkpoint and tried again with the same result.  Not sure if I am doing something wrong or better to open a TAC?

Thanks


Accepted Solutions
Highlighted
MVP Expert

Re: Upgrade 8.2.9.0 > 8.2.10.0 Fails - Can't Login

scott we followed below steps to fix :)

 

 

upgrade.log.

 

Requires: python-libs(x86-64) = 2.6.6-66.el6_8

           Removing: python-libs-2.6.6-66.el6_8.x86_64 (@base)

               python-libs(x86-64) = 2.6.6-66.el6_8

           Updated By: python-libs-2.6.6-68.el6_10.x86_64 (airwave)

               python-libs(x86-64) = 2.6.6-68.el6_10

Error: Package: python-devel-2.6.6-66.el6_8.x86_64 (@base)

           Requires: python = 2.6.6-66.el6_8

           Removing: python-2.6.6-66.el6_8.x86_64 (@base)

               python = 2.6.6-66.el6_8

           Updated By: python-2.6.6-68.el6_10.x86_64 (airwave)

               python = 2.6.6-68.el6_10

You could try using --skip-broken to work around the problem

** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:

aw-perl-libwww-perl-5.813-1.noarch has missing requires of aw-perl(Authen::NTLM)

aw-perl-libwww-perl-5.813-1.noarch has missing requires of aw-perl(HTTP::GHTTP)

aw-perl-libwww-perl-5.813-1.noarch has missing requires of aw-perl(Win32)

make[2]: *** [do_repo_update] Error 1

make[2]: Leaving directory `/var/airwave/git/mercury/src'

make[1]: *** [localrepo_update] Error 2

make[1]: Leaving directory `/var/airwave/git/mercury'

make: *** [upgrade] Error 2

make: Leaving directory `/var/airwave/git/m

 

 

Manually installed missing python-lib packges by running yum command $ yum install python-libs  and recompiled code.

 


Pavan Arshewar | ACCP

If my post address your queries, give kudos and accept as solution!
NOTE: Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba or Hewlett Packard Enterprise.

View solution in original post


All Replies
Highlighted
MVP

Re: Upgrade 8.2.9.0 > 8.2.10.0 Fails - Can't Login

Seems on the logs itself it only gets as far as below, been sitting at this stage for the last 50 minutes:

 

make: Entering directory `/root/git/mercury'
Thu Jan 23 13:50:43 2020: Dropping 'Test' database if exists....
DROP DATABASE
Thu Jan 23 13:50:44 2020: Creating 'Test' database....
CREATE DATABASE
ALTER DATABASE

 

Highlighted
MVP

Re: Upgrade 8.2.9.0 > 8.2.10.0 Fails - Can't Login

Just an update got these logs from the console window, after this it no longer accepts my admin username and password and I have to then revert to backup.  I have raised a support case interesting to see what this is as I followed the user upgrade guide.

 

Upgrade Aborted.png

Highlighted
MVP Expert

Re: Upgrade 8.2.9.0 > 8.2.10.0 Fails - Can't Login

Capture.PNG

In 8.2.10 code password requirment is more complex cotain atleast 15 words and it will get expiry every 60 days, we have reverted this changes back to default requirment in 8.2.10.1 code.

 

May be during upgrade you forgot to provide new complex password requirment due to this you are not able to login.

 

If you have snapshot try upgrade to 8.2.10.1. If server have large database it will take time to drop and create table.

 

 


Pavan Arshewar | ACCP

If my post address your queries, give kudos and accept as solution!
NOTE: Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba or Hewlett Packard Enterprise.
Highlighted
MVP Expert

Re: Upgrade 8.2.9.0 > 8.2.10.0 Fails - Can't Login

Upgrade failed due to missing rpm package, need to manually install and recompile code to fix it.

 

 


Pavan Arshewar | ACCP

If my post address your queries, give kudos and accept as solution!
NOTE: Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba or Hewlett Packard Enterprise.
Highlighted
MVP

Re: Upgrade 8.2.9.0 > 8.2.10.0 Fails - Can't Login

I did think this however I did not get a prompt to update the password and also upon the screen to login at the top it still shows the old version 8.2.9.0 as if the upgrade as failed.

 

Anywhere give a method on how to do this manual install and recompile or better to just leave it with support?

 

Thanks

Scott

Highlighted
MVP Expert

Re: Upgrade 8.2.9.0 > 8.2.10.0 Fails - Can't Login

small correction,complex password requirment applies only for fresh 8.2.10 install not for upgrade, we need to have root access to install missing package and recompile the code.

 

As you already opened TAC ticket they willl fix it.


Pavan Arshewar | ACCP

If my post address your queries, give kudos and accept as solution!
NOTE: Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba or Hewlett Packard Enterprise.
Highlighted
MVP Expert

Re: Upgrade 8.2.9.0 > 8.2.10.0 Fails - Can't Login

scott we followed below steps to fix :)

 

 

upgrade.log.

 

Requires: python-libs(x86-64) = 2.6.6-66.el6_8

           Removing: python-libs-2.6.6-66.el6_8.x86_64 (@base)

               python-libs(x86-64) = 2.6.6-66.el6_8

           Updated By: python-libs-2.6.6-68.el6_10.x86_64 (airwave)

               python-libs(x86-64) = 2.6.6-68.el6_10

Error: Package: python-devel-2.6.6-66.el6_8.x86_64 (@base)

           Requires: python = 2.6.6-66.el6_8

           Removing: python-2.6.6-66.el6_8.x86_64 (@base)

               python = 2.6.6-66.el6_8

           Updated By: python-2.6.6-68.el6_10.x86_64 (airwave)

               python = 2.6.6-68.el6_10

You could try using --skip-broken to work around the problem

** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:

aw-perl-libwww-perl-5.813-1.noarch has missing requires of aw-perl(Authen::NTLM)

aw-perl-libwww-perl-5.813-1.noarch has missing requires of aw-perl(HTTP::GHTTP)

aw-perl-libwww-perl-5.813-1.noarch has missing requires of aw-perl(Win32)

make[2]: *** [do_repo_update] Error 1

make[2]: Leaving directory `/var/airwave/git/mercury/src'

make[1]: *** [localrepo_update] Error 2

make[1]: Leaving directory `/var/airwave/git/mercury'

make: *** [upgrade] Error 2

make: Leaving directory `/var/airwave/git/m

 

 

Manually installed missing python-lib packges by running yum command $ yum install python-libs  and recompiled code.

 


Pavan Arshewar | ACCP

If my post address your queries, give kudos and accept as solution!
NOTE: Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba or Hewlett Packard Enterprise.

View solution in original post

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: