Primary (K-12) Education

This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.
Occasional Contributor I

Google Expeditions

I was able to get Google Expedtions working on our iPads by adding a new AirGroup service for _googexpeditions._tcp

I am running with campus APs.

Brett W.
New Contributor

Re: Google Expeditions

Thank you for the solution.  We have been troubleshooting expeditions within our district.  We are using vlan ip pools and seemed to be causing issues when clients had different network IP addresses.  This fixed that issue.  Thank you.

Occasional Contributor II

Re: Google Expeditions

Thanks for posting, Brett!  Would you mind sharing more about the config you got Expeditions working with?  I'm having some trouble getting Expeditions working on our Aruba network.  The behavior I see is the teacher will open Expeditions on an Android or iOS device, enter Guide mode, create a class (e.g. download Mount Everest), click Start, and then on a student's Android or iOS device they go into Explorer mode but they never see the Guide.  I can get this working fine on an old Linksys WRT54G.  I cannot get Expeditions working on our campus Aruba controllers and AP's.


Here are some details about our infrastructure and the SSID I've been testing with: We have 7210 controllers, mostly AP-21x access points, and we're running code rev  I created a separate SSID and VLAN isolated to a single controller for testing this without affecting our production SSID's and VLAN's.  I tried the following:


Created expeditions AirGroup service with service ID: _googexpeditions._tcp


airgroup service expeditions enable    
airgroupservice expeditions
     id _googexpeditions._tcp
     autoassociate apgroup
     description Google Expeditions

Verified that AirGroup was allowed for the VLAN



airgroup vlan 106 allow

Tried disabling auto associate



airgroupservice expeditions no autoassociate

Tried enabling IGMP snooping



interface vlan 106
interface vlan 106 ip igmp snooping

I tried various combinations of the broadcast / multicast options for the SSID.  It seems logical to me that the problem exists somewhere in the broadcast / multicast settings on the controllers.  The knob I was expecting to be blocking the traffic was Drop Broadcast and Unknown Multicast, but still no go.



wlan virtual-ap "Expeditions-vap_prof"
  no dynamic-mcast-optimization
  no broadcast-filter all
  no broadcast-filter arp

I also found a helpful blog post called "Running Google Expeditions on your Cisco Wireless" ( that suggested formatting the service string as "_googexpeditions._tcp.local." instead, and when I tried entering it that way the controller said "The format should be " _abc._tcp/udp, _abc-def._tcp/udp or urn:schemas-upnp-org:device:MediaServer:1" so I guess Aruba controllers don't like the _local part.


Any ideas or replies are greatly appreciated!  Thanks!


Occasional Contributor II

Re: Google Expeditions

I got it working!  I created a fresh VAP and SSID profile.  The settings are basically identical to what I was testing with, so I'm not sure why this one is working.  In any case, I'm still curious to see what other folks' configs look like.  Here's mine...




wlan virtual-ap "Expeditions-vap_prof"
   aaa-profile "Expeditions-aaa_prof"
   ssid-profile "Expeditions-ssid_prof"
   vlan 106
   dynamic-mcast-optimization-thresh 80
   broadcast-filter arp

I created airgroup service for google expeditions (I disallow it on VLAN 1):

airgroupservice "expeditions"
  id "_googexpeditions._tcp"
  disallow-vlan "1"
  description "Google Expeditions"
  autoassociate "apgroup"

I made sure airgroup is allowed on vlan 106:



airgroup vlan 106 allow

Here is my VLAN config:



interface vlan 106
    ip address
    no suppress-arp
    operstate up

Here is my SSID profile:

wlan ssid-profile "Expeditions-ssid_prof"
   essid "Expeditions"
   opmode wpa2-psk-aes
   wpa-passphrase ***************

My aaa and user-role configs:

aaa profile "Expeditions-aaa_prof"
   initial-role "authenticated"
   authentication-dot1x "default"
user-role authenticated
 access-list session global-sacl
 access-list session apprf-authenticated-sacl
 access-list session ra-guard
 access-list session allowall
 access-list session v6-allowall

Happy exploring!


Occasional Contributor II

Re: Google Expeditions

On my VAP I had to set no broadcast-filter all to make this stable. It seems to work fine with broadcast-filter arp enabled.

Aruba Employee

Re: Google Expeditions

I was helping a school get Google Expeditions working. I found out that in their controller - Configuration - Advanced Services - Airgroups - that AirGroup CPPM Enforce Registration was set to enable. Therefore if users iPads and iPhones were not setup in Clearpass they would not work. We changed this to Disabled and then Google Expeditions started working - so if you are using Clearpass you either need to setup the devices that you want to present in Clearpass or disable this feature on your controller. I attached a screen shot
Occasional Contributor II

Re: Google Expeditions

Thanks for the reply, David.  We don't use ClearPass, so our "AirGroup CPPM enforce registration" knob is set to Disabled.  Also note that I've noticed problems when the "AirGroup location discovery" knob is set to Enabled.  I set "AirGroup location discovery" to Disabled and it works better.  For the service policy (Configuration > Advanced Services > AirGroup > Services > expeditions) I have found that setting "Auto Associate" to "AP-Group" works better than using "AirGroup location discovery".


One very unfortunate thing I've found about getting Google Expeditions working on Aruba (without ClearPass) is that I need a separate VAP / SSID specifically just for Expeditions to work.  The reason being that I had to uncheck "Drop Broadcast and Unknown Multicast" in order for it to work.  I don't want to do that on our main network for obvious reasons.  I'd really like to get Google Expeditions working on our main network instead of having this separate VAP / SSID, but it really wants to throw a ton of unknown multicast / broadcast traffic around.

Occasional Contributor II

Re: Google Expeditions

Update: I'm preparing to make a ticket with Aruba TAC about Google Expeditions. Currently, I can only get Expeditions working correctly when "broadcast-filter all" (or, "Drop Broadcast and Unknown Multicast" in the GUI) is disabled on the VAP profile. For the longest time, Expeditions worked fine with "broadcast-filter all" enabled on the VAP, as long as AirGroup was allowed for the VLAN [and the "_googexpeditions._tcp" mDNS string was configured in AirGroup]. This school year, Expeditions clients (i.e. students) are unable to see Expeditions servers (i.e. teachers) in their VLAN. When I disable "broadcast-filter all" on the VAP profile, it works fine. I cannot leave "broadcast-filter all" disabled since there are literally thousands of devices in a school connected to that VAP, and that setting is preventing performance problems, so my temporary solution is I made a separate VAP for Expeditions traffic, and just blocked internet access on that VLAN [so people don't stay connected to it indefinitely].

Occasional Contributor II

Re: Google Expeditions



what answer did the TAC give you?


I have a similar case in my organization.


Google Expeditions not working.



New Contributor

Re: Google Expeditions

We just had to add the appropriate airgroup service definitions

google expeditions Enabled _googexpeditions._tcp
Search Airheads
Showing results for 
Search instead for 
Did you mean: