Security

Reply
New Contributor

ClearPass Guest for Wired problem

I'm trying guest captive portal for wired. I have created a self-registration portal, with login options parameters "HPE" based on workshop document "HPE-Aruba-CPPM-Wired-Workshop-2018-Labguide". I get error when i press login after self registration " Required parameters unavailable. " Any ideas where i should look? 

 

 

Guru Elite

Re: ClearPass Guest for Wired problem

I’m not sure what document that is but you should follow the ClearPass Solution Guide for Wired Policy Enforcement.

| Tim Cappalli | Aruba Security | @timcappalli | timcappalli.me |

NOTE: Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba or Hewlett Packard Enterprise.
New Contributor

Re: ClearPass Guest for Wired problem

Thanks Tim, i know that document, just double checked everything is as described, but the problem is the following: 1 . i open a self reg page, register myself an account 2. the account is created i see it in the cppm , but when i press login, a webauth should happen after which the policy with port bounce shoud be issued, but this webauth never happens. My setup is clean demo install, no extra configuration. What should i look next?
Guru Elite

Re: ClearPass Guest for Wired problem

Did you check the web login configuration against the wired policy enforcement doc?

| Tim Cappalli | Aruba Security | @timcappalli | timcappalli.me |

NOTE: Answers and views expressed by me on this forum are my own and not necessarily the position of Aruba or Hewlett Packard Enterprise.

Re: ClearPass Guest for Wired problem

I have seen this 'required parameters missing' in the past when there is a redirect happening at the edge which doesn't include the client MAC address in the redirect URL. Sometimes it helps to add ?mac=00:00:00:00:00:00 to the redirect. In your case, as it looks like you want to do server initiated captive portal, ClearPass Guest needs to know your client mac address on order to send a CoA.

 

What could be an issue as well is that it looks like you removed the password field in the sef-registration receipt. The password field is mandatory for logging in with the login button. If you make the password a hidden field, instead of disabled, it might work.

--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: