Occasional Contributor I

Onboard Andriod Provisioning



I'm having issues provisioning an Andriod device (s7) with Onboard. Once I associate to the SSID I'm automatically redirected to the "Sign in to Wi-Fi networks" popup and presented with the Onboard captive portal. I then enter my credentials and click on the Quick Connect app. Here I get an error:


"Web page not available

The web page at market://details?id=com.arubanetworks.quickconnect.andriod could not be laoded because: net::ERR_UNKNOWN_URL_SCHEME"


I'm using an allow any rule in my provisioning role on the controller to eliminate it filtering any traffic. I've also tried to provision my Windows 10 latop and it worked without any issues allowing me to sucecssfully install Quick connect and authenticate with EAP-TLS.


I've also seen a post here from 6 years ago stating that the error is related to the browser not having an application association to the google play store. I've tried with both chrome and IE being my default applicationw without success. Under Application Info>Google Play Store>Set as Default it reads "None set as default", when I click into this under "App links" it's set to "Go to supported URLs"--> "Via this app" and under "Supported web addresses"-->search, and


Has anyone come across this issue before? Any help is appreciated.

Regular Contributor I

Re: Onboard Andriod Provisioning

Have you tried putting the device in the authenticate role to see if it allows the access.  My "authenticate" role allows any any all.


Also have you tried using a difference Android device like an s6?


Do a "show datapath session table (your android ip)" and look for Y and D flags while trying to access the playstore.

Occasional Contributor I

Re: Onboard Andriod Provisioning

Yep it was a role issue, my role didn't have the correct Android white list in the provisioning role:


Thank you


Occasional Contributor I

Re: Onboard Andriod Provisioning

HI Nart1,


can you share the way you done this settings on the controller please. Even though I configured any any rule on ACL, my Android tabs cant download the app " quick connect" from the play store.

Search Airheads
Showing results for 
Search instead for 
Did you mean: