MVP Expert

Reinstating cluster master publisher


Yesterday I had a remote sesson with TAC to increase the swap size on our cluster master publisher.

I then rebooted the VM out of normal working hours as asked to do.


1). Reboot command took the server down but didn't bring it back up

2). Use VMWare console to power cycle server

3). Although it did come back, by this time our standby publisher kicked in 

4). rejoined original MP to cluster

5). When I tried to make it the MP again I got a message saying

"All application licenses will be deactivated pleasecontact support to reactivate licenses"


I'm running 6.7.5 so would have thought with the licensing model this wasn;t applicable.


Also, last night connecting to the standby publisher everythnig seemed o.k.

This morning, after logging in I get loads of error processing request messages, so don;t think I can actually move back to my original publisher via the standby gui.


Got a TAC call outstanding but is the applicatino license message true?


MVP Expert

Re: Reinstating cluster master publisher

Simples really


Log onto old master publisher CLI as appadmin

cluster make-publisher


<Get warning messages about losing application licenses - don't think it applies to new 6.7 license model>

Say yes 


and it gets on with it

FYI after selectingf Yes, what you should see is something  like this ... replacing our IP addresses with yours and dependent on number of nodes in your cluster



Continue? [y|n]: y

INFO - Checking cluster connectivity
INFO - Temporarily pausing replication on all nodes...
INFO - Trying to bring all nodes to sync...
INFO - Transfering ownership from node with management IP=
INFO - Switching local node to publisher
INFO - Switching replication on other nodes to replicate from this node
INFO - - Subscriber now replicating from publisher
INFO - - Subscriber now replicating from publisher
INFO - - Subscriber now replicating from publisher
INFO - - Subscriber now replicating from publisher
INFO - - Subscriber now replicating from publisher
INFO - Subscription ownership changed to node with management IP=
INFO - Restoring replication setup...
INFO - is now setup as the publisher


Point to note howewver


When the secondary publisher had taken over, although you could connect to it using a web browser it wouldn't really display anything, just kept coming up with web browser errors or clearpass"unable to process request"  messages. Initally worked just fine but after 24 hours seems to have had issues


So everything back to normal 


Search Airheads
Showing results for 
Search instead for 
Did you mean: