Software Defined Networking (SDN)

New Contributor

Install ID for trial licence

Hi !
I have a problem with the install ID. I run this curl command lines 

curl -sk -H 'Content-Type:application/json'-d
I replace MyUser and MyPassword with my actual values.

This line returns me a token.

But when I run this, I have an error "The specified HTTP method is not allowed for the requested resource". (you will find attached a screenshot of the error)

It does not return the token.


Can I get some help, please?


PS: I try this from an ubuntu 14.04 and from the OVA file

Aruba Employee

Re: Install ID for trial licence

I'd recommend changing the curl options from -sk to -sSkf. This will give you insecure mode (-k) silent mode (-s), but showing errors (-S), and ignoring HTTP failure messages (-f).


Here's what I get when I try it against an OVA which is running remotely (at x.x.x.x):


$ curl -sSkf -H 'Content-Type:application/json' -d '{"login":{"user":"MyUser","password":"MyPassword","domain":"sdn"}}' https://x.x.x.x:8443/sdn/v2.0/auth
curl: (22) The requested URL returned error: 401 Unauthorized


$ curl -sSkf -H 'Content-Type:application/json' -d '{"login":{"user":"correctUser","password":"correctPassword","domain":"sdn"}}' https://x.x.x.x:8443/sdn/v2.0/auth
{"record":{"token":"aabaa889ef8a4d51b1b4cf1e5e7d7d21","expiration":1525119860000,"expirationDate":"2018-04-30 13-24-20 -0700","userId":"1cf5d7a6cef74be8b490855670eb3b27","userName":"correctUser","domainId":"b5133edc902340dca4203e371fd52de3","domainName":"sdn","roles":["sdn-admin"]}}

Search Airheads
Showing results for 
Search instead for 
Did you mean: