Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
Contributor I

2930M OSPF wont peer with second switch

Have 2 seperate 2930M stacks both having an issues peering with 2 different OSFP peers at the same time.

So the below vlan 2008 is working fine and peers ok with Comware switch 1(Peer1) but Vlan 2009 sits in INIT state going to switch 2(Peer2) and i cannot even ping the peer IP address.

If i shut down 1/48 VLan 2009 peer comes up fine and OSPF then works fine but it would appear both cannot peer at the same time?

 

vlan 2008
tagged 1/48
ip address 172.31.255.42 255.255.255.252
ip ospf 172.31.255.42 area backbone
ip ospf 172.31.255.42 md5-auth-key-chain "1"
ip ospf 172.31.255.42 cost 100


vlan 2009
tagged 2/47
ip address 172.31.255.38 255.255.255.252
ip ospf 172.31.255.38 area backbone
ip ospf 172.31.255.38 md5-auth-key-chain "1"
ip ospf 172.31.255.38 cost 65500
ip ospf 172.31.255.38 network-type point-to-point

Highlighted
MVP Guru Elite

Re: 2930M OSPF wont peer with second switch

What do you have on the log ?



PowerArubaSW: Powershell Module to use Aruba Switch API for Vlan, VlanPorts, LACP, LLDP... More info

PowerArubaCP: Powershell Module to use ClearPass API (create NAD, Guest...) More info

PowerArubaCX: Powershell Module to use ArubaCX API (get interface/vlan/ports info)

PowerArubaIAP: Powershell Module to use Aruba Instant AP

PowerArubaMC: Powershell Module to use Mobility Controller / Master


ACMP 6.4 / ACMX #107 / ACCP 6.5 / ACSP
Highlighted
Contributor I

Re: 2930M OSPF wont peer with second switch

---- Reverse event Log listing: Events Since Boot ----
I 01/28/20 10:25:05 00001 vlan: ST1-CMDR: OSPF-2-SIMMS virtual LAN enabled
I 01/28/20 10:25:05 00076 ports: ST1-CMDR: port 2/48 is now on-line
I 01/28/20 10:25:03 00435 ports: ST1-CMDR: port 2/48 is Blocked by STP

 

Nothing else in the logs, could it be spanning tree?

 

interface 2/48
tagged vlan 2009
untagged vlan 1
exit

Highlighted
MVP Guru Elite

Re: 2930M OSPF wont peer with second switch

Yes, the port is blocked by Spanning Tree...

 

Check if you don't have a loop...

May be better to use access port ? (and disable spanning tree ?)



PowerArubaSW: Powershell Module to use Aruba Switch API for Vlan, VlanPorts, LACP, LLDP... More info

PowerArubaCP: Powershell Module to use ClearPass API (create NAD, Guest...) More info

PowerArubaCX: Powershell Module to use ArubaCX API (get interface/vlan/ports info)

PowerArubaIAP: Powershell Module to use Aruba Instant AP

PowerArubaMC: Powershell Module to use Mobility Controller / Master


ACMP 6.4 / ACMX #107 / ACCP 6.5 / ACSP
Highlighted
Contributor I

Re: 2930M OSPF wont peer with second switch

But the port goes into blocking first then forwarding so that does not appear to the be issue?

 

2/48 1000LX | 20000 128 Forwarding | 883a30-93e4ca 2 Yes No

Highlighted
MVP Guru Elite

Re: 2930M OSPF wont peer with second switch

ok ! on it is on the reverse :)

 

what do you have on show ip ospf neighbor ?



PowerArubaSW: Powershell Module to use Aruba Switch API for Vlan, VlanPorts, LACP, LLDP... More info

PowerArubaCP: Powershell Module to use ClearPass API (create NAD, Guest...) More info

PowerArubaCX: Powershell Module to use ArubaCX API (get interface/vlan/ports info)

PowerArubaIAP: Powershell Module to use Aruba Instant AP

PowerArubaMC: Powershell Module to use Mobility Controller / Master


ACMP 6.4 / ACMX #107 / ACCP 6.5 / ACSP
Highlighted
Contributor I

Re: 2930M OSPF wont peer with second switch

I only see 1 peer connection to my working switch 1 nothing to switch 2, cant even ping switch 2 until i disable the link to switch 1

 

Highlighted

Re: 2930M OSPF wont peer with second switch

i see that you untagged vlan 1 on one of the uplink ports,did you to that on both ports? you must remove that otherwise a loop is detected on vlan 1, that's why only one interface at a time works, propably the peer is blocking. Check both spanning tree and loop detect.

 

Before troubleshooting anythong with ospf, make sure your mac and ip connectivity are good, so: make sure you can ping your ospf peer and learn the mac-adress of the peers on both ports.

 

Can you validate the untagged vlan 1 with:

show run in 1/48

show run in 2/47

 

Please verify it on the peer as well.



- - - - Aruba ACEX #105 (ACCX, ACDX, ACMX, ACSP, ACEAP | HPE Master ASE - - - -

- - - - - - - Feel free to give kudos or accept as a solution! - - - - - - - - -
Highlighted
Contributor I

Re: 2930M OSPF wont peer with second switch

Yes i have it untagged on all 4 interfaces.

If is shutdown the interface on peer switch1 then OSPF forms on sw2 fine everthing can be pinged fine.

 

Nothing obivious so its a limitation in the switch or a misconfiguation 

Highlighted
Frequent Contributor I

Re: 2930M OSPF wont peer with second switch

I think what Fabian meant was with all the interfaces up (not shut) you should be able to ping each peers IP address. If you can't do that, then OSPF neigbors will never form

If these are just going to be layer 3 connected interfaces, i'd recommend making them access ports as well. If you really want to have layer 3 connectivity and trunk VLANs across, I think creating a trunk group would be the better path

trunk 1/48 trk1 trunk
vlan 2009 tagged trk1

If both interfaces are up, what happens if you run
show mac-address 1/48
show mac-address 2/47


 

 

 

 

Chris Wickline | Network Engineer | York College of Pennsylvania
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: