Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
Occasional Contributor II

Re: Aruba-2930F-24G-4SFP ( Layer 3)

my goal : principe switch layer 3 linked to switch layer 2 :

not pc linked directly switch layer 3 because i try from switch layer  3 and  pc get ip  address from switch layer 3

 

==========> desktop linked directly to switch layer 2 ( D-link DES-1210 )  and get ip address from switch layer 3 linked to switch layer 2 

 

/////////////////////////////////////////////////////////////////

 

configuration switch layer 3:

 


Aruba-2930F-24G-4SFP# show running-config

Running configuration:

; JL259A Configuration Editor; Created on release #WC.16.09.0001
; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
hostname "Aruba-2930F-24G-4SFP"
module 1 type jl259a
ip routing
interface 1
flow-control
exit
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-28
ip address dhcp-bootp
ipv6 enable
ipv6 address dhcp full
exit
vlan 10
name "RH"
tagged 1
ip address 10.10.10.1 255.255.255.0
dhcp-server
exit
vlan 20
name "office"
tagged 1
ip address 20.20.20.1 255.255.255.0
dhcp-server
exit
dhcp-server pool "RH"
authoritative
default-router "10.10.10.1"
network 10.10.10.0 255.255.255.0
range 10.10.10.2 10.10.10.254
exit
dhcp-server pool "security"
authoritative
default-router "20.20.20.1"
network 20.20.20.0 255.255.255.0
range 20.20.20.2 20.20.20.254
exit
dhcp-server enable

Aruba-2930F-24G-4SFP#
Aruba-2930F-24G-4SFP# conf terminal
Aruba-2930F-24G-4SFP(config)# vlan 10
Aruba-2930F-24G-4SFP(vlan-10)# untagged 3
Aruba-2930F-24G-4SFP(vlan-10)# quit
Aruba-2930F-24G-4SFP(config)# quit
Aruba-2930F-24G-4SFP# write memory
Aruba-2930F-24G-4SFP# show running-config

Running configuration:

; JL259A Configuration Editor; Created on release #WC.16.09.0001
; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
hostname "Aruba-2930F-24G-4SFP"
module 1 type jl259a
ip routing
interface 1
flow-control
exit
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 3
untagged 1-2,4-28
ip address dhcp-bootp
ipv6 enable
ipv6 address dhcp full
exit
vlan 10
name "RH"
untagged 3
tagged 1
ip address 10.10.10.1 255.255.255.0
dhcp-server
exit
vlan 20
name "office"
tagged 1
ip address 20.20.20.1 255.255.255.0
dhcp-server
exit
dhcp-server pool "RH"
authoritative
default-router "10.10.10.1"
network 10.10.10.0 255.255.255.0
range 10.10.10.2 10.10.10.254
exit
dhcp-server pool "security"
authoritative
default-router "20.20.20.1"
network 20.20.20.0 255.255.255.0
range 20.20.20.2 20.20.20.254
exit
dhcp-server enable

//////////////////////////////////////////////////////////////////////////////////////////////////

switch dlink: screen shot

 

////////////////////////////////////////////////////

 

so what i can edit and configure or chek switch layer 3 or layer 2 that allwo desktop get ip address from switch layer 3 linked switch layer 2

 

Occasional Contributor II

Re: Aruba-2930F-24G-4SFP ( Layer 3)

my goal : principe switch layer 3 linked to switch layer 2 :

not pc linked directly switch layer 3 because i try from switch layer  3 and  pc get ip  address from switch layer 3

 

==========> desktop linked directly to switch layer 2 ( D-link DES-1210 )  and get ip address from switch layer 3 linked to switch layer 2 

 

/////////////////////////////////////////////////////////////////

 

configuration switch layer 3:

 


Aruba-2930F-24G-4SFP# show running-config

Running configuration:

; JL259A Configuration Editor; Created on release #WC.16.09.0001
; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
hostname "Aruba-2930F-24G-4SFP"
module 1 type jl259a
ip routing
interface 1
flow-control
exit
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-28
ip address dhcp-bootp
ipv6 enable
ipv6 address dhcp full
exit
vlan 10
name "RH"
tagged 1
ip address 10.10.10.1 255.255.255.0
dhcp-server
exit
vlan 20
name "office"
tagged 1
ip address 20.20.20.1 255.255.255.0
dhcp-server
exit
dhcp-server pool "RH"
authoritative
default-router "10.10.10.1"
network 10.10.10.0 255.255.255.0
range 10.10.10.2 10.10.10.254
exit
dhcp-server pool "security"
authoritative
default-router "20.20.20.1"
network 20.20.20.0 255.255.255.0
range 20.20.20.2 20.20.20.254
exit
dhcp-server enable

Aruba-2930F-24G-4SFP#
Aruba-2930F-24G-4SFP# conf terminal
Aruba-2930F-24G-4SFP(config)# vlan 10
Aruba-2930F-24G-4SFP(vlan-10)# untagged 3
Aruba-2930F-24G-4SFP(vlan-10)# quit
Aruba-2930F-24G-4SFP(config)# quit
Aruba-2930F-24G-4SFP# write memory
Aruba-2930F-24G-4SFP# show running-config

Running configuration:

; JL259A Configuration Editor; Created on release #WC.16.09.0001
; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
hostname "Aruba-2930F-24G-4SFP"
module 1 type jl259a
ip routing
interface 1
flow-control
exit
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 3
untagged 1-2,4-28
ip address dhcp-bootp
ipv6 enable
ipv6 address dhcp full
exit
vlan 10
name "RH"
untagged 3
tagged 1
ip address 10.10.10.1 255.255.255.0
dhcp-server
exit
vlan 20
name "office"
tagged 1
ip address 20.20.20.1 255.255.255.0
dhcp-server
exit
dhcp-server pool "RH"
authoritative
default-router "10.10.10.1"
network 10.10.10.0 255.255.255.0
range 10.10.10.2 10.10.10.254
exit
dhcp-server pool "security"
authoritative
default-router "20.20.20.1"
network 20.20.20.0 255.255.255.0
range 20.20.20.2 20.20.20.254
exit
dhcp-server enable

//////////////////////////////////////////////////////////////////////////////////////////////////

switch dlink: screen shot

 

////////////////////////////////////////////////////

 

so what i can edit and configure or chek switch layer 3 or layer 2 that allwo desktop get ip address from switch layer 3 linked switch layer 2

 

please 

 

Occasional Contributor II

Re: Aruba-2930F-24G-4SFP ( Layer 3)

Aruba-2930F-24G-4SFP# show vlans ports 1 detail

Status and Counters - VLAN Information - for ports 1

VLAN ID Name | Status Voice Jumbo Mode
------- -------------------- + ---------- ----- ----- --------
1 DEFAULT_VLAN | Port-based No No Untagged
10 RH | Port-based No No Tagged
20 office | Port-based No No Tagged

 

MVP Expert

Re: Aruba-2930F-24G-4SFP ( Layer 3)

I'm not used to work with D-Link Switches (no matter if Layer 2 or 3), said so...what is the port configuration where the PC (set DHCP or Static IP on VLAN 10) you're using for testing (I suspect with desired IP Addressing 10.10.10.40)?

 

D-Link Switch side that port should be untagged (and only untagged) in VLAN 10.

 

If you set that PC with temporarily with a Static IP Addressing: 10.10.10.40, Subnet Mask 255.255.255.0 and Default Gateway 10.10.10.1 (which is the IP Address given to VLAN 10 Interface on Aruba 2930F Switch) then you should be able to perform successfully a ping to 10.10.10.1 and also to 20.20.20.1 (because Aruba 2930F if responsible for IPv4 Routing on its VLANs).

 

Your DHCP issue (which should be, as far as I understood, D-Link access hosts are not receiving IP Addressing from DHCP Server set on Aruba 2930F) shoudl be fixed after the above step is verified...that's essential...why? because you first need to verify and be sure that Switch A (Aruba 2930F) and Switch B (D-Link) have a well formed interconnection and also that an host connected to an access port on Switch A (untagged on VLAN 10 or untagged on VLAN 20) is able to ping a corresponding host connected to an access port on Switch B (untagged on VLAN 10 or untagged on VLAN 20) and vice-versa.

Occasional Contributor II

Re: Aruba-2930F-24G-4SFP ( Layer 3)

Hello

 

 from pc vlan 20 , i try to ping 20.20.20.1 and 10.10.10.1 , it not work??????,,!!!! this desktop linked to switch layer 2 -d-link

 

also from pc vlan 10 , i try to ping 10.10.10.1 and 20.20.20.1 , it not work !!???,

 

i send you scrennshot about switch layer 2 and please tell me if the configuration switch layer 2 is correct or not !!!???

 

Occasional Contributor II

Re: Aruba-2930F-24G-4SFP ( Layer 3)

why until now  the ping don't work and aslo dhcp !!??????,,

 

please help me to find the solution and a thanks a lot 

 

Occasional Contributor II

Re: Aruba-2930F-24G-4SFP ( Layer 3)

why until now  the ping don't work and aslo dhcp !!??????,,

 

please help me to find the solution and a thanks a lot

MVP Expert

Re: Aruba-2930F-24G-4SFP ( Layer 3)

Never seen a Network Engineer writing so many "?" and "!" in a thread...by the way...check this D-Link article (I suspect that "Asymmetric VLAN" should be disabled and you should go down the Static VLAN configuration path): https://eu.dlink.com/uk/en/support/faq/switches/layer-2-gigabit/dgs-series/uk_dgs_1210_setup_static_vlans

 

D-Link Port 1 (interlink) MUST me set to be Untagged on VLAN 1, Tagged on VLAN 10 and Tagged on VLAN 20.

D-Link Port 3 (example of access port) MUST be Untagged on VLAN 10 (your "RH") ONLY (remove the actual tagging on VLAN 1).

D-Link Port 4 (example of access port) MUST be Untagged on VLAN 20 (your "office") ONLY (remove the actual tagging on VLAN 1).

 

Try to connect a PC on Port 3 of D-Link (try first setting a free IP Address compatible with subnet of VLAN 10, as described on my previous post) and verify ping against Aruba 2930 VLAN 10 IP Address 10.10.10.1.

 

Do the same on Port 4 of D-Link (try first setting a free IP Address compatible with subnet of VLAN 20, as described on my previous post) and verify ping against Aruba 2930 VLAN 20 IP Address 20.20.20.1.

 

D-Link DGS-1210-28 Manual: https://media.dlink.eu/ftp/products/dgs/dgs-1210/documentation/DGS-1210_man_revF_v6-10_eu_multi_20180110.pdf

 

Occasional Contributor II

Re: Aruba-2930F-24G-4SFP ( Layer 3)

Please i need a reply what i can doing 

///////////////////////////////////////////////////////////////////////////////////

Aruba-2930F-24G-4SFP# show running-config

Running configuration:

; JL259A Configuration Editor; Created on release #WC.16.09.0001
; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
hostname "Aruba-2930F-24G-4SFP"
module 1 type jl259a
ip routing
interface 1
flow-control
exit
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 3
untagged 1-2,4-28
ip address dhcp-bootp
ipv6 enable
ipv6 address dhcp full
exit
vlan 10
name "RH"
untagged 3
tagged 1
ip address 10.10.10.1 255.255.255.0
dhcp-server
exit
vlan 20
name "office"
tagged 1
ip address 20.20.20.1 255.255.255.0
dhcp-server
exit
dhcp-server pool "RH"
authoritative
default-router "10.10.10.1"
network 10.10.10.0 255.255.255.0
range 10.10.10.2 10.10.10.254
exit
dhcp-server pool "security"
authoritative
default-router "20.20.20.1"
network 20.20.20.0 255.255.255.0
range 20.20.20.2 20.20.20.254
exit
dhcp-server enable

Aruba-2930F-24G-4SFP#
Aruba-2930F-24G-4SFP#
Aruba-2930F-24G-4SFP# show running-config

Running configuration:

; JL259A Configuration Editor; Created on release #WC.16.09.0001
; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04
hostname "Aruba-2930F-24G-4SFP"
module 1 type jl259a
ip routing
interface 1
flow-control
exit
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 3
untagged 1-2,4-28
ip address dhcp-bootp
ipv6 enable
ipv6 address dhcp full
exit
vlan 10
name "RH"
untagged 3
tagged 1
ip address 10.10.10.1 255.255.255.0
dhcp-server
exit
vlan 20
name "office"
tagged 1
ip address 20.20.20.1 255.255.255.0
dhcp-server
exit
dhcp-server pool "RH"
authoritative
default-router "10.10.10.1"
network 10.10.10.0 255.255.255.0
range 10.10.10.2 10.10.10.254
exit
dhcp-server pool "security"
authoritative
default-router "20.20.20.1"
network 20.20.20.0 255.255.255.0
range 20.20.20.2 20.20.20.254
exit
dhcp-server enable

Aruba-2930F-24G-4SFP#

 

 

 

Occasional Contributor II

Re: Aruba-2930F-24G-4SFP ( Layer 3)

Thanks very much and it work finally

and desktop get ip address from dhcp 

 

thanks a lot

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: