Aruba Switch OS - How to Configure OSPF Routing

MVP Expert
MVP Expert
Requirement:

How is basic OSPF routing configured on an Aruba OS switch?



Solution:

In the following example, OSPF routing is configured on switches Rack2sw1 and Rack2sw2.

  • IP addresses are configured on the VLAN 1 and Loopback 0 interfaces.
  • OSPF routing is enable for the backbone area.
  • Connected interfaces are redistributed into OSPF.



Configuration:

********** Configure Interfaces **********


Rack2sw1(config)# interface loopback 0 ip address 1.1.1.1
Rack2sw2(config)# interface loopback 0 ip address 2.2.2.2

Rack2sw1(config)# interface vlan 1 ip address 192.168.1.1/24
Rack2sw2(config)# interface vlan 1 ip address 192.168.1.2/24


********** Enable OSPF routing ***********


Rack2sw1(config)# ip routing
Rack2sw1(config)# router ospf enable
Rack2sw1(config)# router ospf area backbone
Rack2sw1(config)# vlan 1 ip ospf area 0
Rack2sw1(config)# router ospf redistribute connected

Rack2sw2(config)# ip routing
Rack2sw2(config)# router ospf enable
Rack2sw2(config)# router ospf area backbone
Rack2sw2(config)# vlan 1 ip ospf area 0
Rack2sw2(config)# router ospf redistribute connected



Verification

Rack2sw1# show ip ospf interface

 OSPF Interface Status

  IP Address      Status   Area ID         State    Auth-type Cost  Pri Passive
  --------------- -------- --------------- -------- --------- ----- --- -------
  192.168.1.1     enabled  backbone        BDR      none      1     1   no

 

Rack2sw1# show ip ospf neighbor

 OSPF Neighbor Information

  Router ID       Pri IP Address      NbIfState State    QLen  Events Status
  --------------- --- --------------- --------- -------- ----- ------ ------
  2.2.2.2         1   192.168.1.2     DR        FULL     0     7      None


Rack2sw1# show ip route ospf

                                IP Route Entries

  Destination        Gateway         VLAN Type      Sub-Type   Metric     Dist.
  ------------------ --------------- ---- --------- ---------- ---------- -----
  2.2.2.2/32         192.168.1.2     1    ospf      External2  10         110
 

Rack2sw2# show ip ospf interface

 OSPF Interface Status

  IP Address      Status   Area ID         State    Auth-type Cost  Pri Passive
  --------------- -------- --------------- -------- --------- ----- --- -------
  192.168.1.2     enabled  backbone        DR       none      1     1   no


Rack2sw2# show ip ospf neighbor

 OSPF Neighbor Information

  Router ID       Pri IP Address      NbIfState State    QLen  Events Status
  --------------- --- --------------- --------- -------- ----- ------ ------
  1.1.1.1         1   192.168.1.1     BDR       FULL     0     6      None


Rack2sw2# show ip route ospf

                                IP Route Entries

  Destination        Gateway         VLAN Type      Sub-Type   Metric     Dist.
  ------------------ --------------- ---- --------- ---------- ---------- -----
  1.1.1.1/32         192.168.1.1     1    ospf      External2  10         110

Version history
Revision #:
1 of 1
Last update:
‎10-08-2018 10:41 AM
Updated by:
 
Comments

Has anyone attempted Route Filtering on the Aruba Switch OS? I am running into an issue described below.


I have a Routing VLAN created, say VLAN 1000. This VLAN is configured with a /30 and is used as a "point to point" to establish OSPF neighbor relationship with another device. 

 

I creat a prefix list for all the VLAN's and interfaces such as loopback to advertise by doing a prefix-list like below:

 

ip prefix-list "OSPFRouteFilter" seq 5 permit 10.1.1.0 255.255.255.0 ge 24 le 24

 

I then create a route map and use the route map in OSPF by running the below commands:

 

route-map OSPFRouteFilterList permit seq 5

match ip address prefix-list OSPFRouteFilterMapList

 

router ospf

redistribute connected route-map OSPFRouteFilterMap

 

While this works by allowing the User VLAN/Loopbacks to be advertised. I am still seeing the Routing VLAN advertised which I do not want. In Cisco and even the HP Comware switches this is handled by simpling using the network statement to match what subnets I want to advertise. 


How do I accomplish this with Aruba Switch OS?

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: