Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
New Contributor

ArubaOS-CX can't delete "public" snmp community

By default the Aruba8320 uses the public community string. I configured a string called "private", and according to documentation, the public community should be removed automatically. However, that is not the case. When I try to remove the community manually, an error is returned:

 

switch(config)# no snmp-server community public
Community 'public' can't be deleted, as it is linked with another configuration.

 

This is the current snmp config:

switch# sh run | i snmp
snmp-server vrf default
snmp-server community private
snmp-server community public
snmp-server host x.x.x.x trap version v2c community private

 

switch# sh snmp comm
---------------------
SNMP communities
---------------------
private
public

 

 

Any ideas on how to remove the public community? 

MVP Guru

Re: ArubaOS-CX can't delete "public" snmp community

Short test I made:

8320-3(config)# sh ru | inc snmp
snmp-server vrf mgmt
snmp-server system-description Lab 8320-3
snmp-server system-location Grenoble
snmp-server system-contact Vincent Giles
snmp-server community ArubA
snmp-server community public
vsx-sync aaa dhcp-server dns mclag-interfaces sflow-global snmp ssh time vsx-global
8320-3(config)# no snmp-server community public
8320-3(config)# sh ru | inc snmp
snmp-server vrf mgmt
snmp-server system-description Lab 8320-3
snmp-server system-location Grenoble
snmp-server system-contact Vincent Giles
snmp-server community ArubA
vsx-sync aaa dhcp-server dns mclag-interfaces sflow-global snmp ssh time vsx-global

 

 

You may try removing all other SNMP commands and then try again.

Highlighted
New Contributor

Re: ArubaOS-CX can't delete "public" snmp community

Removed all the snmp config so the snmp agent got disabled, but unfortunatly I still can't remove the public community. The switch keeps returning the same error message. 

I am running code TL.10.02.0010

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: