Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
New Contributor

Can't remove the command "spanning-tree priority 0 force-version rstp-operation"

I am trying to remove this command  from a 2930. When I do so, it says:

 

Switch(config)# no spanning-tree priority 0 force-version rstp-operation
Module not present for port or invalid port: priority

 

I've been able to remove all other spanning-tree commands, this is the only one I cannot. Any ideas will be most appreciated. Thanks.


Accepted Solutions
Highlighted
Occasional Contributor I

Re: Can't remove the command "spanning-tree priority 0 force-version rstp-operation"

Hi,

 

that are two commands in one....

try

 

spanning-tree priority 8

 

which is the default

and

 

spanning-tree force-version mstp

which is also the default

 

hth

Alex

View solution in original post

Highlighted
MVP Guru

Re: Can't remove the command "spanning-tree priority 0 force-version rstp-operation"

Yes, if you (re)set spanning tree related options to their default values (priority = 8 and mode of operation = mstp) then the row initially highlighted in the config will disappear but doing so will not disable spanning-tree...so if you want to just go to default (mstp enabled) do those two separated defaulting commands...if you, instead, want to disable spanning tree go to no spanning-tree...and it will leave (unproductive) that row in the running configuration.

View solution in original post


All Replies
Highlighted
MVP Guru

Re: Can't remove the command "spanning-tree priority 0 force-version rstp-operation"

Simply a no spanning-tree?

Highlighted
New Contributor

Re: Can't remove the command "spanning-tree priority 0 force-version rstp-operation"

No, that simply removes the "spanning-tree" command. You'll still see "spanning-tree priority 0 force-version rstp-operation" in the config.

Highlighted
Occasional Contributor I

Re: Can't remove the command "spanning-tree priority 0 force-version rstp-operation"

Hi,

 

that are two commands in one....

try

 

spanning-tree priority 8

 

which is the default

and

 

spanning-tree force-version mstp

which is also the default

 

hth

Alex

View solution in original post

Highlighted
MVP Guru

Re: Can't remove the command "spanning-tree priority 0 force-version rstp-operation"

Yes, if you (re)set spanning tree related options to their default values (priority = 8 and mode of operation = mstp) then the row initially highlighted in the config will disappear but doing so will not disable spanning-tree...so if you want to just go to default (mstp enabled) do those two separated defaulting commands...if you, instead, want to disable spanning tree go to no spanning-tree...and it will leave (unproductive) that row in the running configuration.

View solution in original post

Highlighted
New Contributor

Re: Can't remove the command "spanning-tree priority 0 force-version rstp-operation"

Yes this worked, thank you!