Wired Intelligent Edge (Campus Switching and Routing)

Reply
New Contributor

Configuring multiple trunks between 2 5400R series switches

Hi all,

 

Just wanted to say that networking isn't my strongest suit, and I'm not overly familiar with the ArubaOS switches.

 

What I'm trying to achieve is the below. At our school, we have a 5412Rzl2 core switch in the server room, and a 5406Rzl2 switch in the IT office server room. The IT office server room hosts approximately half of the fibre connections from the campus, and a standalone Hyper-V host and iSCSI SAN.

 

At present I have an LACP trunk between the 2 switches for the production network, and I am wanting to configure a secondary trunk that will just be used for iSCSI traffic between our production cluster in the main server room and the standalone host and SAN in our IT office.

 

The secondary trunk will be configured as just VLAN 11. At present I have the below settings for the VLAN and trunks on either end, but STP and LACP are shutting down my second trunk.

 

In the below, ports H21-H22 are the 2 Hyper-V hosts iSCSI nics in the server room.

 

Core Switch#
trunk E2-E3,F2-F3 trk1 lacp
trunk E7,F7 trk2 lacp
vlan 1
   name "DEFAULT_VLAN"
   no untagged H21-H22,Trk2
   untagged A1-A2,B1-B2,C1-C8,D1-D8,E1,E4-E6,E8,F1,F4-F6,F8,G1-G8,H1-H20,I1-I24,J1-J24,K1-K8,L1-L24,Trk1
   ip address x.x.x.x 255.255.0.0
   ip igmp
   jumbo
   exit
vlan 11
   name "iSCSI"
   untagged H21-H22
   tagged Trk2
   no ip address
   jumbo
   exit

 

In the below, port A8,B7-B8 are the iSCSI nics on the SAN and the standalone host in the IT office server room.

IT Core#
trunk A1-A2,B1-B2 trk1 lacp
trunk A3,B3 trk2 lacp
vlan 1
   name "DEFAULT_VLAN"
   no untagged A8,B7-B8,Trk2
   untagged A4-A7,B4-B6,C1-C8,D1-D22,E1-E24,F1-F24,Trk1
   ip address 172.16.2.64 255.255.0.0
   ip igmp
   jumbo
   name "iSCSI"
   untagged A8,B7-B8
   tagged Trk2
   no ip address
   jumbo
   exit

 

Is this a possible scenario with the ArubaOS switches? I have been talking to others about this and they say it is possible with other vendors switches.

 

Appreciate any input you might have. If this is a design issue, then I am open to suggestions.

MVP Expert
MVP Expert

Re: Configuring multiple trunks between 2 5400R series switches

Hi,

 

several options...

 

ugly/dangerous:

konfigure stp BPDU-filter in Trk2. STP will not "see" second link and will not block Trk1 or Trk2. If you do mistakes while configuring, you'll get a loop which stp will not resolve!

 

move to 40 Gbit/s inter switch links.

That way it is unlikely that the isl will get overloaded. But you'll have to buy new modules and loose slots in the switch.

 

Use multiple spanning tree.

Add all VLANs to both trunks.

Define two instances for MSTP.

Assign VLAN 11 to instance "two". All other vlans to instance "one".

Configure MSTP, so that in Instance one Trk1 will be forwarding and two will be blocked. InInstance two, Trk2 will be forwarding and one will be blocked. You'll have to play arround with port priorities.

That way, in normal operation, you get the desired traffic separation. If one trunk dies, traffic will failover to the other trunk. So: in case of outage no separation anymore, but you are still alive.

Details can be found in Advanced Traffic Management Guide.

Spanningtree is not too komplex. But will take a day or two to train. Too much to describe every detail here...

 

Kind regards, Jö

Please give kudos, if you like my post.
Please Accept as solution, if my post was helpful.
Occasional Contributor I

Re: Configuring multiple trunks between 2 5400R series switches

Hi WIlliam,

 

STP blocks redundant physical links even if they are in separate VLANs because  the switch blocks per switch and not per vlan (if you are familiar with Cisco, this doesn't happen to you as they use PVST). You could use PVST on your switch, but i don't recommend non-standard protocols if you can avoid it. Be careful of interoperability between PVST and non-PVST switches if you still want to go with PVST.

 

A solution is to use multiple-instance STP (MSTP) operation, allowing physically redundant links belonging to different VLANs can remain open; this is the solution using open standard STP

 

See "Spanning Tree Operation with VLANs" in "Static Virtual LANs (VLANs)" and "Chapter 5-  Multiple instance spanning tree operation"  in the advanced traffic management guide for your switch for configuration examples.

 

Advance Traffic Management guide attached

New Contributor

Re: Configuring multiple trunks between 2 5400R series switches

Ok, so I've had a bit of a look at this and can't get it to work. I must be doing something wrong.

 

I've run the below commands on both switches and they are still blocking Trk2.

 

spanning-tree force-version mstp-operation
spanning-tree clear-debug-counters
spanning-tree config-name SHS-MSTP
spanning-tree instance 1 vlan 1 20 30 40 50 60 70 80 90 100 110 120 220 230 240
spanning-tree instance 2 vlan 11

Any thoughts? I must be missing something.

 

****EDIT: I just read over the first reply above and realised that I need to add VLANS to both Trunks. I'm going to play around more to see how I go.

MVP Expert
MVP Expert

Re: Configuring multiple trunks between 2 5400R series switches

Hi,

 

additionally you need to set path costs for the trunks.

 

  • Assign lower cost for trk1 in instance 1
  • Assing lower cost for trk2 in instance 2

 

Without doing that, you created two trees, but they both come to the same conclusion, that trk2 must be blocked. With that, you tell the second tree, that trk2 is better than trk1.

 

Regards, Jö

Please give kudos, if you like my post.
Please Accept as solution, if my post was helpful.
Highlighted
New Contributor

Re: Configuring multiple trunks between 2 5400R series switches

Ok, so here is my config (only the Trunk, VLAN and Spanning Tree sections). It is essentially the same between the 2 switches, albeit a few different port numbers.

 

 

hostname "SW-Core"
trunk E2-E3,F2-F3 trk1 lacp
trunk E7,F7 trk2 lacp
vlan 1
   no untagged H21-H22,Trk2
   untagged A1-A2,B1-B2,C1-C8,D1-D8,E1,E4-E6,E8,F1,F4-F6,F8,G1-G8,H1-H20,I1-I24,J1-J24,K1-K8,L1-L24,Trk1
   exit
vlan 11
   name "iSCSI"
   untagged H21-H22
   tagged Trk2
   no ip address
   jumbo
   exit
vlan 20
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 30
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 40
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 50
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 60
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 70
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 80
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 90
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 100
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 110
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 120
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 220
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,L2,Trk1
   exit
vlan 230
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
   exit
vlan 240
   tagged E1,E4-E6,E8,F1,F4-F6,G1-G8,Trk1
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree config-name "SHS-MSTP"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 20 30 40 50 60 70 80 90 100 110 120 220 230
spanning-tree instance 1 vlan 240
spanning-tree instance 1 Trk1 priority 4
spanning-tree instance 2 vlan 11
spanning-tree instance 2 Trk2 priority 4
spanning-tree priority 4
allow-unsupported-transceiver

Here's the output from show spanning-tree mst-config (again, the same between the 2 switches)

 

SW-Core(config)# show spanning-tree mst-config

 MST Configuration Identifier Information

  MST Configuration Name : SHS-MSTP
  MST Configuration Revision : 1
  MST Configuration Digest : 0xAC7030DDB7499BFE9297D6E14A241C77

  IST Mapped VLANs : 2-10,12-19,21-29,31-39,41-49,51-59,61-69,71-79,81-89,
 91-99,101-109,111-119,121-219,221-229,231-239,241-4094

  Instance ID Mapped VLANs
  ----------- ---------------------------------------------------------
  1           1,20,30,40,50,60,70,80,90,100,110,120,220,230,240
  2           11

 

Specifically, with the Spanning Tree config what do I need to clean up? I know there is stuff left over from the legacy config.

 

I don't want redundancy between the trunks at all, I just want to separate the traffic. If Trunk 2 goes down, then I don't want the traffic for VLAN 11 to move to Trunk 1. I've tested this by disconnecting Trunk 2 ports, and VLAN 11 traffic doesn't fail over to Trunk 1.

 

I can see in the interface monitor that this is working as expected when I copy a file to the iSCSI SAN across the Trunk (image attached).

 

On my core switch, I believe I need to set a lower spanning-tree priority than the secondary switch? Do I also need to remove the below 2 lines from each switch?

 

spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4 

 I appreciate all the help. As I said, it's not my forte.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: