Wired Intelligent Edge (Campus Switching and Routing)

Reply
New Contributor

ERR_SSL_PROTOCOL_ERROR after generating SSL certificate on 2930F.

I generated a self-signed certificate with the following command:

 

crypt pki enroll-self-signed certificate-name <SWITCH NAME> key-type rsa key-size 2048 subject common-name <SWITCH NAME> country US locality <CITY> org <COMAPNY> org-unit "Information Services" state <STATE> usage web valid-start 05/20/2019 valid-end 05/20/2029.

 

Problem is when I try to open the GUI from Chrome I get ERR_SSL_PROTOCOL_ERROR.

 

I can open the site fine (with warnings off course) with Edge/IE.

 

Not sure why I'm getting this error.

 

 

 

MVP Guru

Re: ERR_SSL_PROTOCOL_ERROR after generating SSL certificate on 2930F.

I just tried the same on a 2930F and it works for me in Chrome, though as I had a session before I created a new cert, had to open an Incognito window to initiate a fully new SSL session. Chrome does some session caching. Have you tried with Chrome from a different computer? I found a page that has some suggestions on Chrome to solve the issue. 

--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).
New Contributor

Re: ERR_SSL_PROTOCOL_ERROR after generating SSL certificate on 2930F.

Still no luck.  I've tried on 3 different machines and all the same error in Chrome.  I try it in any other browser it works fine.

 

Using Version 74.0.3729.157 (Official Build) (64-bit).

 

This is the exact error in Chrome:

 

This site can’t provide a secure connection 192.168.1.18 sent an invalid response.
Try running Windows Network Diagnostics.
ERR_SSL_PROTOCOL_ERROR

 

I just removed the self-signed cert I created and re-created it and same error.  Just to make sure I disabled all extensions in Chrome and same result.  I've used this same command before and it's always worked. 

MVP Expert

Re: ERR_SSL_PROTOCOL_ERROR after generating SSL certificate on 2930F.

Hi,

 

What firmware ? because there is some buggy firmware (first release 16.07, 16.08) you need to use last firmware and regenerate certificate...

 




PowerArubaSW: Powershell Module to use Aruba Switch API for Vlan, VlanPorts, LACP, LLDP... More info


PowerArubaCP: Powershell Module to use ClearPass API (create NAD, Guest...) More info


PowerArubaCX: Powershell Module to use ArubaCX API (get interface/vlan/ports info)


PowerArubaIAP: Powershell Module to use Aruba Instant AP




ACMP 6.4 / ACMX #107 / ACCP 6.5
New Contributor

Re: ERR_SSL_PROTOCOL_ERROR after generating SSL certificate on 2930F.

Sorry for the delay.  Currently running WC.16.08.0003.

 

I do have some switches not in production that aren't on this firmware.  Might try it on them to see if I have the same issue.  

New Contributor

Re: ERR_SSL_PROTOCOL_ERROR after generating SSL certificate on 2930F.

You can follow this guide to fix this issue.

MVP Expert

Re: ERR_SSL_PROTOCOL_ERROR after generating SSL certificate on 2930F.


@riyasander wrote:

You can follow this guide to fix this issue.


There is a bug on some firmware release...




PowerArubaSW: Powershell Module to use Aruba Switch API for Vlan, VlanPorts, LACP, LLDP... More info


PowerArubaCP: Powershell Module to use ClearPass API (create NAD, Guest...) More info


PowerArubaCX: Powershell Module to use ArubaCX API (get interface/vlan/ports info)


PowerArubaIAP: Powershell Module to use Aruba Instant AP




ACMP 6.4 / ACMX #107 / ACCP 6.5
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: