Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
New Contributor

Invalid input: allow-unsupported-transceiver error on 2930F Switch

I can't figure out why I'm getting the Invalid Input: error. I'm new to Aruba administration, so I might be missing something basic. I've been following the steps in the ArubaOS-Switch Unsupported Transceiver Guide V2 and every command except allow-unsupported-transceiver has been working as expected.

 

I've got a number of 2930F switches, running software revision WC.16.03.0005, so unless this feature has been deprecated I believe our configuration is compatible.

 

I've tried it while signed in as manager, both via ssh and directly through the console port, and I'm getting the same Invalid Input: result in the CLI.


Accepted Solutions
Highlighted
MVP Expert

Re: Invalid input: allow-unsupported-transceiver error on 2930F Switch

Greetings!

 

Just to be certain — are you running the command from the global configuration context, and not from the enable context? For example:

 

switch(config)# allow-unsupported-transceiver 
Warning: The use of third-party transceivers is at your own risk and may void support and warranty. Please see HPE Warranty terms and conditions.
Do you agree, and do you wish to continue enabling? (Y/N) 

The command will not work from the operator, enable, or any individual feature, interface, or VLAN context (even if you are in configuration mode):

 

switch(eth-1/10)# allow-unsupported-transceiver
Invalid input: allow-unsupported-transceiver


Matt Fern
Technical Marketing Engineer, Wired Intelligent Edge

Aruba, a Hewlett Packard Enterprise company

8000 FOOTHILLS BLVD  |  ROSEVILLE, CA 95747
T: 916.540.1759  |  E: mfern@hpe.com   |   Matt @ Twitter

View solution in original post


All Replies
Highlighted
MVP Guru

Re: Invalid input: allow-unsupported-transceiver error on 2930F Switch

Did you type or tab the command? try typing letter by letter the entire command without just typing its first two or three letters and then pressing tab looking for auto-completion.
Highlighted
MVP Expert

Re: Invalid input: allow-unsupported-transceiver error on 2930F Switch

Greetings!

 

Just to be certain — are you running the command from the global configuration context, and not from the enable context? For example:

 

switch(config)# allow-unsupported-transceiver 
Warning: The use of third-party transceivers is at your own risk and may void support and warranty. Please see HPE Warranty terms and conditions.
Do you agree, and do you wish to continue enabling? (Y/N) 

The command will not work from the operator, enable, or any individual feature, interface, or VLAN context (even if you are in configuration mode):

 

switch(eth-1/10)# allow-unsupported-transceiver
Invalid input: allow-unsupported-transceiver


Matt Fern
Technical Marketing Engineer, Wired Intelligent Edge

Aruba, a Hewlett Packard Enterprise company

8000 FOOTHILLS BLVD  |  ROSEVILLE, CA 95747
T: 916.540.1759  |  E: mfern@hpe.com   |   Matt @ Twitter

View solution in original post

Highlighted
New Contributor

Re: Invalid input: allow-unsupported-transceiver error on 2930F Switch

How do you get into the"config" mode or how do you tell if you are there?

Highlighted
MVP Guru

Re: Invalid input: allow-unsupported-transceiver error on 2930F Switch

Log in as manager or, if you were already  logged into as operator, perform an enable (you will prompted to provide manager password). Once logged into manager mode type config...and you will enter the config context. There you will be able to type the above command to allow unsupported transceivers.

Highlighted
New Contributor

Re: Invalid input: allow-unsupported-transceiver error on 2930F Switch

Before I saw this I downloaded the config and added the command there and then uploaded the new config and rebooted. That worked, but I will be adding your solution to my notes as well. Thanks!

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: