Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
New Contributor

Issues with RIPv2 in ArubaOS Switch

Guys, im facing an issue here in one deployment in Workbench... the customer ask me to compare the ArubaOS switch Features with the Cisco IOS.. they are searching for another vendor and they provide us the testing procedure dossiers to fullfill with the Cisco commands and features to translate do the ArubaOS switch configuration.

I am using the KB.16.05.0003 version that is available in the Workbench and i have configured the following:

 

Switch A:

ip routing

interface loopback 0
ip address 192.168.0.1

router rip
redistribute connected
enable
exit

vlan 99
name "VLAN99"
untagged 1
ip address 192.168.3.1 255.255.255.0
ip rip 192.168.3.1
exit

 

Switch B:

ip routing

interface loopback 0
ip address 192.168.1.1

router rip
redistribute connected
enable
exit

vlan 99
name "VLAN99"
untagged 1
ip address 192.168.3.2 255.255.255.0
ip rip 192.168.3.2
exit

 

After i apply both configs i cant see any information about the RIP peer:

 

Switch1# show ip rip

RIP global parameters

RIP protocol : Enabled
Auto-summary : Enabled
Default Metric : 1
Distance : 120
Route changes : 0
Queries : 0


RIP interface information

IP Address Status Send mode Recv mode Metric Auth
--------------- ----------- ---------------- ---------- ----------- ----
192.168.3.1 Enabled V2-only V2-only 1 none


RIP peer information

IP Address Bad routes Last update timeticks
--------------- ----------- ---------------------

Switch2# show ip rip

RIP global parameters

RIP protocol : Enabled
Auto-summary : Enabled
Default Metric : 1
Distance : 120
Route changes : 0
Queries : 0


RIP interface information

IP Address Status Send mode Recv mode Metric Auth
--------------- ----------- ---------------- ---------- ----------- ----
192.168.3.2 Enabled V2-only V2-only 1 none


RIP peer information

IP Address Bad routes Last update timeticks
--------------- ----------- ---------------------

 

But after i apply the "no router rip auto-summary" in both switches everything works:

 

Switch1# show ip rip

RIP global parameters

RIP protocol : Enabled
Auto-summary : Disabled
Default Metric : 1
Distance : 120
Route changes : 1
Queries : 0


RIP interface information

IP Address Status Send mode Recv mode Metric Auth
--------------- ----------- ---------------- ---------- ----------- ----
192.168.3.1 Enabled V2-only V2-only 1 none


RIP peer information

IP Address Bad routes Last update timeticks
--------------- ----------- ---------------------
192.168.3.2 0 28

 

Switch2# show ip rip

RIP global parameters

RIP protocol : Enabled
Auto-summary : Disabled
Default Metric : 1
Distance : 120
Route changes : 1
Queries : 0


RIP interface information

IP Address Status Send mode Recv mode Metric Auth
--------------- ----------- ---------------- ---------- ----------- ----
192.168.3.2 Enabled V2-only V2-only 1 none


RIP peer information

IP Address Bad routes Last update timeticks
--------------- ----------- ---------------------
192.168.3.1 0 9

 

Switch1# show ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
127.0.0.0/8 reject static 0 0
127.0.0.1/32 lo0 connected 1 0
192.168.0.1/32 lo0 connected 1 0
192.168.1.1/32 192.168.3.2 99 rip 2 120
192.168.3.0/24 VLAN99 99 connected 1 0

 

Switch2# show ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
127.0.0.0/8 reject static 0 0
127.0.0.1/32 lo0 connected 1 0
192.168.0.1/32 192.168.3.1 99 rip 2 120
192.168.1.1/32 lo0 connected 1 0
192.168.3.0/24 VLAN99 99 connected 1 0

 

My problem is.. the customer want to use the auto-summary feature... there is anything that i can do to solve this?

 

Thanks in advance :)

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: