Wired Intelligent Edge

last person joined: 16 hours ago 

Bring performance and reliability to your network with the HPE Aruba Networking Core, Aggregation, and Access layer switches. Discuss the latest features and functionality of your switching devices, and find ways to improve security across your network to bring together a mobile-first solution
Expand all | Collapse all

LACP Aruba 2930F to Cisco Catalyst 2960 stack

This thread has been viewed 27 times
  • 1.  LACP Aruba 2930F to Cisco Catalyst 2960 stack

    Posted Sep 18, 2020 10:45 AM

    So I've seen some conflicting info on configuring LACP trunks between Aruba and Cisco, particularly pertaining to channel group mode on Cisco.  What we have inherited is a Cisco shop which we are slowly transitioning to Aruba, which means we will have both devices in some locations.  In this example, we are replacing an end of life Cisco Catalyst C2960S switch with an Aruba 2930F.  Currently there is an EtherChannel consisting of 2 fiber links which originates on the distribution switch, which is to be replaced, and terminates at a Cisco access switch stack with 1 fiber link going to each stack member.  The question is how to configure the Aruba's LACP so it can talk to the Cisco.  Below are config snippets with swt1 being the distribution switch and swt2 being the access switch stack.

     

    swt1#sh run

    interface Port-channel5
    description Port channel 5
    switchport trunk native vlan 999
    switchport trunk allowed vlan 30,100,1130,1200
    switchport mode trunk
    spanning-tree guard root
    !
    interface GigabitEthernet1/0/25
    description Port channel 5 > swt2
    switchport trunk native vlan 999
    switchport trunk allowed vlan 30,100,1130,1200
    switchport mode trunk
    spanning-tree guard root
    channel-group 5 mode active
    !
    interface GigabitEthernet1/0/26
    description Port channel 5 > swt2
    switchport trunk native vlan 999
    switchport trunk allowed vlan 30,100,1130,1200
    switchport mode trunk
    spanning-tree guard root
    channel-group 5 mode active


    swt2#sh run

    interface Port-channel5
    description Port channel 5
    switchport trunk native vlan 999
    switchport trunk allowed vlan 30,100,1130,1200
    switchport mode trunk
    spanning-tree guard loop
    !
    interface GigabitEthernet1/0/49
    description Port channel 5 > swt1
    switchport trunk native vlan 999
    switchport trunk allowed vlan 30,100,1130,1200
    switchport mode trunk
    spanning-tree guard loop
    channel-protocol lacp
    channel-group 5 mode active
    !
    interface GigabitEthernet2/0/49
    description Port channel 5 > swt1
    switchport trunk native vlan 999
    switchport trunk allowed vlan 30,100,1130,1200
    switchport mode trunk
    spanning-tree guard loop
    channel-protocol lacp
    channel-group 5 mode active

     

    Thank you in advance for any help you can give.



  • 2.  RE: LACP Aruba 2930F to Cisco Catalyst 2960 stack

    MVP GURU
    Posted Sep 18, 2020 11:23 AM

    Hi,

     

    You need to add trunk (TrkX) and attach interface port on this trunk

    and after tag vlan on Trunk (vlan XXX tagged TrkYY)



  • 3.  RE: LACP Aruba 2930F to Cisco Catalyst 2960 stack

    Posted Sep 18, 2020 11:58 AM

    Thanks for your reply.  I searched before I posted and found this post from 2016.  https://community.arubanetworks.com/t5/ArubaOS-and-Controllers/EtherChannel-between-Aruba-and-Cisco-switch/td-p/438

     

    Not exactly the same hardware, but are you aware of any issues with channel group mode on the Cisco side?



  • 4.  RE: LACP Aruba 2930F to Cisco Catalyst 2960 stack

    MVP GURU
    Posted Sep 19, 2020 09:16 AM

    Pretty strange that on swt1 (Cisco, Distribution layer):

     

    interface Port-channel5
    description Port channel 5
    switchport trunk native vlan 999
    switchport trunk allowed vlan 30,100,1130,1200
    switchport mode trunk
    spanning-tree guard root
    
    interface GigabitEthernet1/0/25
    description Port channel 5 > swt2
    switchport trunk native vlan 999
    switchport trunk allowed vlan 30,100,1130,1200
    switchport mode trunk
    spanning-tree guard root
    channel-group 5 mode active
    
    interface GigabitEthernet1/0/26
    description Port channel 5 > swt2
    switchport trunk native vlan 999
    switchport trunk allowed vlan 30,100,1130,1200
    switchport mode trunk
    spanning-tree guard root
    channel-group 5 mode active

     

    Gigabit Ethernet interfaces 1/0/25 and 1/0/26 haven't the "channel-protocol lacp" explicitly declared (as on swt2, Access layer) although they both were declared to be members of "channel-group 5 mode active"

     

    That's just a doubt about how the EtherChannel (link aggregation) was formed between Cisco switches.

     

    As per VLAN membership:

     

    switchport trunk encapsulation dot1q
    switchport trunk native vlan 999
    switchport trunk allowed vlan 30,100,1130,1200
    switchport mode trunk

     

    the corresponding ArubaOS-Switch configuration just requires that you set the VLANs memberships of the Aruba's Port Trunk as @alagoutte wrote:

     

    vlan 999 untagged trk<TRK-ID> (for the native untagged VLAN)

    vlan 30 tagged trk<TRK-ID>

    vlan 100 tagged trk<TRK-ID>

    vlan 1130 tagged trk<TRK-ID>

    vlan 1200 tagged trk<TRK-ID>

     

    Or, if you want to achieve the same outcome by using just two commands:

     

    interface ethernet trk<TRK-ID> untagged 999

    interface ethernet trk<TRK-ID> tagged 30,100,1130,1200

     

    We suppose your Port Trunk trk<TRK-ID> is going to be configured as LACP:

     

    trunk ethernet <1st-interface-ID>,<2nd-interface-ID> trk<TRK-ID> lacp

     

    Also, have a look at this document.



  • 5.  RE: LACP Aruba 2930F to Cisco Catalyst 2960 stack

    Posted Sep 20, 2020 10:02 AM

    Thank you for the clarification and the link to that doc.

     

    I noticed the channel protocol discrepancy too.  I just chalked it up to the charming Cisco feature whereby if the channel mode is set to active (or passive), the channel uses LACP since those are the only modes available to LACP.  It makes the protocol declaration superfluous, but I like having it specifically declared if for no other reason than documentation.  Obviously, it will be declared on the Aruba trunk.

     

    Also, the encapsulation command won't be necessary as newer Cisco's don't support ISL and 802.1Q is the default.

     

    Anyway, I believe I know how to configure these devices now.  I'll report back here with my experience.  Thank you all.

     



  • 6.  RE: LACP Aruba 2930F to Cisco Catalyst 2960 stack

    MVP GURU
    Posted Sep 21, 2020 05:37 AM

    @macellaio wrote: I noticed the channel protocol discrepancy too.  I just chalked it up to the charming Cisco feature whereby if the channel mode is set to active (or passive), the channel uses LACP since those are the only modes available to LACP.  It makes the protocol declaration superfluous, but I like having it specifically declared if for no other reason than documentation.

    I agree with you, it looks like the protocol declaration would be automatically derived by the fact that the active mode could only be related to LACP and there is no similar concept on non protocol based link aggregations such as static ones (HP/Aruba non protocol based link aggregations are called simply "trunk" instead of "lacp", not an happy option name when you're configuring a Port Trunk with the trunk command starting with the word "trunk" too...but it's OK if you already know that...this generated and generates a lot of confusion...an option named, as example, "non-protocol" would have been better IMHO).


    @macellaio wrote: Anyway, I believe I know how to configure these devices now.  I'll report back here with my experience.  Thank you all.

    Great!



  • 7.  RE: LACP Aruba 2930F to Cisco Catalyst 2960 stack

    Posted Sep 21, 2020 09:26 AM

    One last question for clarification.  Do I need to set the trunked interfaces on the Aruba to active mode to match the Cisco configuration?

     

    int 25-26 lacp active



  • 8.  RE: LACP Aruba 2930F to Cisco Catalyst 2960 stack

    MVP GURU
    Posted Sep 21, 2020 10:53 AM

    No, you don't need to do that (lacp active): if you will use lacp active you will end up with a "Dynamic" LACP Port Trunk (the logical interface will be labelled as Dyn<Trunk-ID> and not as Trk<Trunk-ID> as per "Static" LACP or per "Static" Non Protocol port trunking methods).

     

    Here the lacp "active" option means more "dynamic" lacp versus "static" lacp.

     

    Please note that Dynamic LACP trunks operate only in the default LAN (unless GVRP is enabled and Forbid is used to prevent the trunked ports from joining the default VLAN).

    Thus, if an LACP dynamic port forms using ports that are not in the default VLAN, the trunk automatically moves to the default VLAN unless GVRP operation is configured to prevent this from occurring. In some cases, this can create a traffic loop in your network.

     

    So YMMV...but I've never used the lacp active (so Dyn<Trunk-ID>) and I never had any issue in forming the LACP with my peers (Servers or other Switches).

     

    I admit there is some sort of confusion because, in terms of links aggregation, you could deal with three scenarios (the third was - at least for me - never used at all):

     

    • Trunk AKA "Non Protocol" (basically "static" port trunking with no aggregation control protocol such as the famous LACP) -> logical interface will be labelled as Trk<Trunk-ID>
    • LACP (basically "static" not necessarily passive, IMHO it's active) -> logical interface will be labelled as Trk<Trunk-ID>
    • LACP active (basically "dynamic" necessarily active) -> logical interface will be labelled as Dyn<Trunk-ID>

    Have a look to Aruba 2930F / 2930M Management and Configuration Guide for ArubaOS-Switch 16.10 (Chapter 5 "Port Trunking" starting from page 118 of 759) of October 2019, Edition 1 and you should be able to recognize what I summed up above.