Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
Occasional Contributor I

Re: Mac-based vlan not working

I'm stuck at the same place as you are. I just posted a new post here without noticing your post here. I don't have the un-managed switch like you are but it is still not working. I've done this setup multiple times with Cisco or Juniper switches and it is WELL documented out there.

Highlighted
Aruba Employee

Re: Mac-based vlan not working

See:  https://support.hpe.com/hpsc/doc/public/display?docId=a00038755en_us 

(page 219)

 

The following features cannot run concurrently with RPVST+:
•◦ MAC-Based VLANs
Aruba Employee

Re: Mac-based vlan not working

See:  https://support.hpe.com/hpsc/doc/public/display?docId=a00038755en_us 

(page 219)

 

The following features cannot run concurrently with RPVST+:
•◦ MAC-Based VLANs
Highlighted
HGW
Occasional Contributor II

Re: Mac-based vlan not working

I finally found the problem a couple of weeks ago, but didnt have the time to respond. Thanks for your link, but my problem was something different.

 

On one day, i enabled full debugging on the switch, which (ofcourse) gave me tons of information. when i filtered on the mac-address i saw one little line that pushed me in the right direction. 

 

We've one accesspoint with 2 network cables. One is a uplink for the accesspoint, but the other functions as a guest network. in short, when 802.1x fails and mac-auth fails, you'll be placed in the vlan that gives guest-access. This is configured on the second port of the AP and somehow the AP had some sort of bridge mode active. So the mac-address that was failing, was first seen on the 802.1x port, but 2 seconds later also on the second port of the AP. This then bounced like this for the rest of its lifetime :(

 

when i disabled that second port, everything worked like it should. So i did some changes on the accesspoint and after that, all was ok and 802.1x is now working fine.

 

View solution in original post

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: