Wired Intelligent Edge (Campus Switching and Routing)

Reply
Highlighted
New Contributor

PTP on 2930M: Invalid input (with no flexible modules)

The issue we experience is very similar to the one reported here, except we do not have any flexible modules:


https://community.arubanetworks.com/t5/Wired-Intelligent-Edge-Campus/PTP-on-2930M-Invalid-input-ptp/td-p/617541

 

We are attempting to enable PTP (precision time protocol) on Aruba-2930M-40G-8SR-PoE+ without any extra modules installed, with all factory settings (except for IP and Mask) untouched.

 

Configuration report:

 

Aruba-2930M-40G-8SR-PoEP# show config

Startup configuration: 7

; JL323A Configuration Editor; Created on release #WC.16.07.0003
; Ver #14:01.4f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:02

hostname "Aruba-2930M-40G-8SR-PoEP"
module 1 type jl323a
snmp-server community "public" unrestricted
oobm
   ip address dhcp-bootp
   exit
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-48
   ip address 192.168.0.100 255.255.255.0
   ipv6 enable
   ipv6 address dhcp full
   exit
spanning-tree

 

The issue:

 

Aruba-2930M-40G-8SR-PoEP# ptp enable
Invalid input: ptp
Aruba-2930M-40G-8SR-PoEP# show ptp
Invalid input: ptp

 

All attempts to do anything related to ptp result in "Invalid input: ptp". Switch is connected to one machine via ethernet cable. CLI over usb cable or over ethernet cable makes no difference.

 

Curiously, we have the exact same software version (WC.16.07.0003) reported in the link above. Is it known to have such an issue? Maybe there are versions known to have ptp configurable and working correctly, so that picking another one is less of a shot in dark?


Accepted Solutions
Highlighted
MVP Expert

Re: PTP on 2930M: Invalid input (with no flexible modules)

Greetings!

 

PTP is supported on the following 2930M switch models:

 

  • Aruba 2930M 24G 1-slot Switch (JL319A)
  • Aruba 2930M 24G PoE+ 1-slot Switch (JL320A)
  • Aruba 2930M 48G 1-slot Switch (JL321A)
  • Aruba 2930M 48G PoE+ 1-slot Switch (JL322A)

PTP is not supported on 2930M models with built-in Smart Rate ports, due to internal port hardware differences; we are working on getting our documentation updated to clearly note these model limitations.



Matt Fern
Senior Technical Marketing Engineer, Aruba Switching

Aruba, a Hewlett Packard Enterprise company

8000 FOOTHILLS BLVD  |  ROSEVILLE, CA 95747
T: 916.540.1759  |  E: mfern@hpe.com   |   Matt @ Twitter

View solution in original post


All Replies
Highlighted
MVP Guru Elite

Re: PTP on 2930M: Invalid input (with no flexible modules)

do you have try on config mode ? (and also to remove flexible module like on the other link)

 

it will be a good idea also to upgrade



PowerArubaSW: Powershell Module to use Aruba Switch API for Vlan, VlanPorts, LACP, LLDP... More info

PowerArubaCP: Powershell Module to use ClearPass API (create NAD, Guest...) More info

PowerArubaCX: Powershell Module to use ArubaCX API (get interface/vlan/ports info)

PowerArubaIAP: Powershell Module to use Aruba Instant AP

PowerArubaMC: Powershell Module to use Mobility Controller / Master


ACMP 6.4 / ACMX #107 / ACCP 6.5 / ACSP
Highlighted
New Contributor

Re: PTP on 2930M: Invalid input (with no flexible modules)

Yes, in config mode response is exactly the same "invalid input: ptp". There were never any modules attached, and the provided above configuration report does not list any. The only "extra" module is a single power supply.

 

We will certainly test newer software versions. However, even if the switch would give a formal confirmation that ptp is "enabled" on another version, we would have uncertainty that the transparent clock functionality actually works on that version. This is why we are interested which software versions were actually verified to provide packet delay adjustments.

 

Highlighted
New Contributor

Re: PTP on 2930M: Invalid input (with no flexible modules)

Updating software to WC.16.10.0005 (or downgrading to WC.16.04.0011) does nothing:

 

Aruba-2930M-40G-8SR-PoEP# show config

Startup configuration: 7

; JL323A Configuration Editor; Created on release #WC.16.10.0005
; Ver #14:27.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:04

hostname "Aruba-2930M-40G-8SR-PoEP"
module 1 type jl323a
snmp-server community "public" unrestricted
oobm
   ip address dhcp-bootp
   exit
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-48
   ip address 192.168.0.100 255.255.255.0
   ipv6 enable
   ipv6 address dhcp full
   exit
spanning-tree

Aruba-2930M-40G-8SR-PoEP# ptp enable
Invalid input: ptp
Aruba-2930M-40G-8SR-PoEP# show ptp
Invalid input: ptp

Aruba-2930M-40G-8SR-PoEP(config)# ptp enable
Invalid input: ptp
Aruba-2930M-40G-8SR-PoEP(config)# show ptp
Invalid input: ptp

Aruba-2930M-40G-8SR-PoEP(eth-1-48)# ptp enable
Invalid input: ptp
Aruba-2930M-40G-8SR-PoEP(eth-1-48)# show ptp
Invalid input: ptp

 

Highlighted
MVP Expert

Re: PTP on 2930M: Invalid input (with no flexible modules)

Greetings!

 

PTP is supported on the following 2930M switch models:

 

  • Aruba 2930M 24G 1-slot Switch (JL319A)
  • Aruba 2930M 24G PoE+ 1-slot Switch (JL320A)
  • Aruba 2930M 48G 1-slot Switch (JL321A)
  • Aruba 2930M 48G PoE+ 1-slot Switch (JL322A)

PTP is not supported on 2930M models with built-in Smart Rate ports, due to internal port hardware differences; we are working on getting our documentation updated to clearly note these model limitations.



Matt Fern
Senior Technical Marketing Engineer, Aruba Switching

Aruba, a Hewlett Packard Enterprise company

8000 FOOTHILLS BLVD  |  ROSEVILLE, CA 95747
T: 916.540.1759  |  E: mfern@hpe.com   |   Matt @ Twitter

View solution in original post

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: